Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-14-2009, 05:40 PM
vang0017 vang0017 is offline
Learning to use the forums
 
Join Date: Jul 2009
Posts: 6
Default Hello From Milwaukee, WI

Hello fellows... I am new here... I am also a mechanic... i am here to share knowledge and learn from all the pros in here. Let me know if you need help and I sure will ask if i need help. Thank you.
Reply With Quote
  #2  
Old 07-14-2009, 06:35 PM
98blownranger 98blownranger is offline
Custom KeyChain R Me
 
Join Date: Feb 2009
Posts: 718
Default

welcome if you need anything let me know I am 1 hour north of you
__________________
Quote:
Originally Posted by redrumedge View Post
98blown you should be an MD! that's the same stuff my doc asks and ur spot on man!!!
98 4.0 2wd-----supercharger fully build heads cam...all show with go......3 time world of wheels champ 5 time national winner


lots of ranger parts for sale leftovers from my 94/96
96 sitting on the frame, waiting to go lower


custom billet parts by me intake adapters and billet steps for the step sides

please sign my guestbook!!
http://breyperformancemachine.shutterfly.com/
Reply With Quote
  #3  
Old 07-14-2009, 07:11 PM
vang0017 vang0017 is offline
Learning to use the forums
 
Join Date: Jul 2009
Posts: 6
Default

Quote:
Originally Posted by 98blownranger View Post
welcome if you need anything let me know I am 1 hour north of you
Recently, my 1996 Ford Ranger 4.0 V6 4 wheel drive...have been dying in and out. Sometime it works and drive for a bit, if i stop and turn off the engine ...then it will not turn back on... it cranks...but no turn over... I check and it seem like there is no fuel coming...so i though it was the fuel pump but...SOME MECHANIC TOLD ME THAT... is the fuel sensor???

My question is... are there such things as fuel sensor for these kind of car...cause i never heard of it before... If it does have it...where would it be located at? And if the sensor is bad...would it cause these kind of problems... ??? please help... i don't want to spend 500$ for nothing. Thanx
Reply With Quote
  #4  
Old 07-14-2009, 07:33 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Welcome
__________________
2005 Edge

Reply With Quote
  #5  
Old 07-14-2009, 09:00 PM
Jay FX4 Jay FX4 is offline
▲▼▲▼▲▼▲▼
 
Join Date: Jun 2009
Posts: 2,511
Default

Welcome
__________________
Quote:
Originally Posted by Ranger Dave (B25) View Post
Our foreign policy is laughable at best. As is the recipient of this years Cracker-Jacks prize for 'peace.'
Quote:
Originally Posted by Toms984x4 View Post
NOS for teh horse powaz!!!
ɹǝʌo ǝɯ dılɟ
Reply With Quote
  #6  
Old 07-15-2009, 12:59 PM
scooby stew scooby stew is offline
Ford Ranger Driver
 
Join Date: Apr 2009
Posts: 963
Default

welcome
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search