Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-04-2018, 12:43 PM
Cardenas.Frank Cardenas.Frank is offline
Learning to use the forums
 
Join Date: Feb 2018
Posts: 5
Cool Hola

New here.

Just became an owner of a 1994 Ford Ranger Splash.

I love my truck but there is something not right.

I posted the issue on the Ford Ranger Splash group.

If anyone has any ideas on what I can do to make my Ranger running smoothly I would greatly appreciate it.



Frank
__________________
I love my Ford Ranger Splash
Reply With Quote
  #2  
Old 02-04-2018, 12:53 PM
Welcome Bot Welcome Bot is offline
Welcome to Ford Ranger Forum
 
Join Date: Jan 2012
Posts: 5
Default Welcome to Ford Ranger Forum - Forums for Ford Ranger enthusiasts!!

Welcome to FRF!

Here are two links to help you use the forum:
http://www.fordrangerforum.com/site-...ger-forum.html
http://www.fordrangerforum.com/how-t...-pictures.html

You can switch the style of this forum to a light theme by going to http://www.fordrangerforum.com/profi...do=editoptions and scrolling down the last option of "forum skin" and selecting light. You can switch back and forth anytime.

Please insert a signature with information on your truck by going here:
http://www.fordrangerforum.com/profi...=editsignature

We have three contests you can participate in, which you can view here:
http://www.fordrangerforum.com/contests/

Our how-to guides are a great way to begin customizing your truck, view them here:
http://www.fordrangerforum.com/how-tos/

Also, if you're interested in forum stickers, shirts, or ford merchandise visit the FRF store here:
http://www.fordrangerforum.com/store
__________________
I'm a bot that works for FRF. So please don't PM or ask me questions. I'm not that kind of program!
Reply With Quote
  #3  
Old 02-04-2018, 08:35 PM
12 Deg North Industries 12 Deg North Industries is offline
Vehicle Upfitters
 
Join Date: Jan 2018
Posts: 90
Default Re: Hola

Quote:
Originally Posted by Cardenas.Frank View Post
New here.

Just became an owner of a 1994 Ford Ranger Splash.

I love my truck but there is something not right.

I posted the issue on the Ford Ranger Splash group.

If anyone has any ideas on what I can do to make my Ranger running smoothly I would greatly appreciate it.

Frank

Well Frank, welcome to FRF. Lay on the couch, make yourself comfy, and tell us your Ranger woes...
__________________
12 North Industries
Las Vegas, Nevada 89118
Sales 702.781.0302
Email sales@12degnorth.com

Web www.12degnorth.com
Reply With Quote
  #4  
Old 02-05-2018, 09:54 AM
Cardenas.Frank Cardenas.Frank is offline
Learning to use the forums
 
Join Date: Feb 2018
Posts: 5
Default Re: Hola

Thank you very much for the welcome!

Right now when I start up the engine the voltage odometer drops but the engine light does not come on. Then the engine will stop. I will start it up again and it's fine. Then while driving as I slow down the voltage odometer will start to drop then go back up.

When I go in reverse it does this more then I shift over to drive it doesn't do it.

Now when I drive a mile or more and put it in park the engine idles fine. It sounds great.

I have replaced many various parts and my mechanic says to replace the IAC sensor again.

The alternator has been tested several times and it's passed.

It has a new starter and battery.

It just got the oil change and tune up.

So I ordered another IAC sensor and gasket.


Any help would be greatly appreciate it.
__________________
I love my Ford Ranger Splash
Reply With Quote
  #5  
Old 02-18-2018, 02:12 PM
Cardenas.Frank Cardenas.Frank is offline
Learning to use the forums
 
Join Date: Feb 2018
Posts: 5
Default Re: Hola

So I replaced the idle control valve and gasket. It does run a lot better but it still stalls when I turn it on. The voltage odometer will swing to the low end at various speeds then shut off. once I restart it it's fine. could it be a vaccum hose????

Thanks
__________________
I love my Ford Ranger Splash
Reply With Quote
  #6  
Old 02-18-2018, 02:57 PM
PluckinDaisies PluckinDaisies is offline
Learning to use the forums
 
Join Date: Feb 2018
Posts: 13
Default Re: Hola

My alternator caused similar symptoms; it would charge at idle but anything above 1100 would result in the battery gauge dropping & battery light illuminating. Funny thing is that the alternator tested good. But I replaced it anyway and haven't had the issue since; hope it helps!
__________________
2000 Ranger XLT 4.0L Offroad Package
Reply With Quote
  #7  
Old 02-19-2018, 05:29 AM
Odyssey Odyssey is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2018
Posts: 29
Default Re: Hola

Welcome to the Forum Frank.
Reply With Quote
  #8  
Old 02-19-2018, 11:18 AM
Cardenas.Frank Cardenas.Frank is offline
Learning to use the forums
 
Join Date: Feb 2018
Posts: 5
Default Re: Hola

Quote:
Originally Posted by PluckinDaisies View Post
My alternator caused similar symptoms; it would charge at idle but anything above 1100 would result in the battery gauge dropping & battery light illuminating. Funny thing is that the alternator tested good. But I replaced it anyway and haven't had the issue since; hope it helps!
Thanks for the reply. I had it looked at by three different places and all three said the alternator was good as was the belt.

I changed the Idle valve sensor and it doesn't do the stalling as much as before. I read that it could be a clogged EGR valve which Im going to change out soon. Hopefully that does the trick. Keep fingers crossed!!!

----------

Quote:
Originally Posted by Odyssey View Post
Welcome to the Forum Frank.

Thank you!
__________________
I love my Ford Ranger Splash
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hola incongruency Introduce Yourself 2 10-05-2015 05:51 PM
Hola hermdiggle Introduce Yourself 5 05-26-2014 07:44 PM
Hola! gabrielguyreyes Introduce Yourself 7 09-14-2013 06:10 PM
Hola! richarddhoward Introduce Yourself 14 11-17-2009 07:12 PM