Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-03-2015, 04:46 PM
dmonixed dmonixed is offline
Learning to use the forums
 
Join Date: May 2015
Posts: 2
Default Hi im new :)

hey i was searching for info on some problems im having getting my ranger to start and found some useful material while browsing the forum so i decided to register. i have a 99 ranger xlt 4.0 4wd with a stepside that i have taken off and am building a flatbed. got the truck dirt cheap a few years back from a buddy whose girlfriend put it in a ditch or two haha. fix the front end up and got some new toyo open country at2s and an alignment and been roddin on her ever since.

truck died a few months back and i put in a new fuel pump and got er running again then it died maybe a week later. Ive been puttin off gettin er fixed but just started working on it the past week and fruitlessly changed fuel filter and relay and cps to no avail. my buddy is bringin his odb2 tester over when he gets off work at oreilleys so we can scan the computer to see what codes its throwing and go from there. the motor turns over but will not fire, i got it to fire once today though actually while fartin around with it but it just stuttered like it wasnt getting enough fuel and died and i couldnt get it to fire back up at all.

well just wanted to introduce myself and say that you guys have a darn good set off forums here and I will be using them often as i do my projects.

-Daniel
Reply With Quote
  #2  
Old 05-03-2015, 04:53 PM
Welcome Bot Welcome Bot is offline
Welcome to Ford Ranger Forum
 
Join Date: Jan 2012
Posts: 2
Default Welcome to Ford Ranger Forum - Forums for Ford Ranger enthusiasts!!

Welcome to FRF!

Here are two links to help you use the forum:
http://www.fordrangerforum.com/site-...ger-forum.html
http://www.fordrangerforum.com/how-t...-pictures.html

You can switch the style of this forum to a light theme by going to http://www.fordrangerforum.com/profi...do=editoptions and scrolling down the last option of "forum skin" and selecting light. You can switch back and forth anytime.

Please insert a signature with information on your truck by going here:
http://www.fordrangerforum.com/profi...=editsignature

We have three contests you can participate in, which you can view here:
http://www.fordrangerforum.com/contests/

Our how-to guides are a great way to begin customizing your truck, view them here:
http://www.fordrangerforum.com/how-tos/

Also, if you're interested in forum stickers, shirts, or ford merchandise visit the FRF store here:
http://www.fordrangerforum.com/store
__________________
I'm a bot that works for FRF. So please don't PM or ask me questions. I'm not that kind of program!
Reply With Quote
  #3  
Old 05-03-2015, 06:17 PM
msparks msparks is offline
Ford Ranger Driver
 
Join Date: Mar 2015
Posts: 907
Default Re: Hi im new :)

Welcome, I hope you get your truck going. I would say relay, but you have already replaced that.
__________________
2005 FX4 4.0 SOHC L/S 4.10 Automatic Transmission k&n drop-in air filter, filter box mod, LED tag and back up lights
Reply With Quote
  #4  
Old 05-03-2015, 06:22 PM
99Ranger376 99Ranger376 is offline
Still around
 
Join Date: Jun 2012
Posts: 2,201
Default

Possibly the crankshaft position sensor. This will not throw a code unfortunately.
Welcome to the FRF
__________________
2011 Ranger XLT 4x4 3.73 8.8" Trac-lok #1 T-bars, K -springs, LineX bedliner, General Grabber AT2's, Tonnopro tri-fold, CoverKing Realtree AP seat covers, OEM pre-keys, axle spacers, Bilstein 4600's, Hellwig AAL. Ziebart Undercoat
'98 Ranger XLT 2WD (sold)
Reply With Quote
  #5  
Old 05-03-2015, 06:28 PM
J's 05 J's 05 is offline
Same Shirt, Different Day
 
Join Date: Feb 2013
Posts: 1,582
Default

Welcome!
Considering what you have replaced already, you might check to see if the fuel inertia switch may be tripped.
__________________
Gold 05 xlt 4.0 auto 4x4.

My build thread
http://www.fordrangerforum.com/proje...build-log.html
Reply With Quote
  #6  
Old 05-03-2015, 08:11 PM
Mike69 Mike69 is offline
Another old fart
 
Join Date: Oct 2013
Posts: 6,978
Default Re: Hi im new :)

Quote:
Originally Posted by J's 05 View Post
Welcome!
Considering what you have replaced already, you might check to see if the fuel inertia switch may be tripped.
Daniel. welcome to FRF. X2 on checking the fuel inertia switch. Also check your fuel pressure to see if you are even getting fuel to the injectors.
Mike.
__________________
2000 Ranger Extd Cab XLT, 4X4 Off Road, 4.0L, Auto, 8.8 - 4.10's (My DD)
Build thread http://www.fordrangerforum.com/proje...oad-build.html
69 Mustang(project) 5.0, T-5, 9" rear.
Build thread http://1969stang.com/forum/index.php...9-coupe-build/
99 Explorer Sport, 4.0 SOHC, Auto, 8.8 - 4.10's, PW, PL, PM, Cruise, Tilt. (Wife's DD)
Build thread http://www.explorerforum.com/forums/...=429940&page=4
Reply With Quote
  #7  
Old 05-03-2015, 08:31 PM
dmonixed dmonixed is offline
Learning to use the forums
 
Join Date: May 2015
Posts: 2
Default Re: Hi im new :)

I put in a new fuel pump few months back and fixed the problem temporarily.

The truck has sat for a couple months as ive been busy and have another vehicle to drive.

since ive started to work on it again, I replace the fuel filter, fuel pump relay, crankshift position sensor all to no avail. checked the inertia switch first thing because it caused a no start problem for me a couple years back.

I didnt get it hooked up to see what codes are being thrown today but will tomorrow.

I can get the truck to turn over and sometimes it will fire but then stutter and die before it really even gets going. It sounds like the fuel pump is only turning on intermittently. Searching for possibilities but im kinda stuck until i check the codes tomorrow. any suggestions would be more than welcome
__________________
99 ranger xlt 4wd ext. cab 4.0 v6. all standard issue right now but is my lil project truck
Reply With Quote
  #8  
Old 05-03-2015, 08:32 PM
97rangerstepside 97rangerstepside is offline
Woosah
 
Join Date: Mar 2014
Posts: 1,063
Default Re: Hi im new :)

Welcome from across the Columbia river
__________________
1997 Ranger xlt standard cab stepside. 2.3 5 speed
06 mirrors, white face gauges, explorer limited leather seats, shorty console, UWS Toolbox, proper hitch, proper spray in bed liner.
Build Thread
1981 Honda CB900c fully dressed
2004 Jeep Wrangler 2.4 5speed
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search