Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-15-2014, 03:28 PM
will1963 will1963 is offline
Learning to use the forums
 
Join Date: Aug 2014
Posts: 7
Default High rev when starting

I am having some problems when I start my Ranger it revs high then it will idle out. This is don't matter what time of the day it is or temperature. I thought maybe you guys have more experience than me and/or this happened to you or some. Help guys and gals!!

Ford Ranger 2000 4.0L 4X4
__________________
2000 Ford Ranger 4.0L XLT 4X4 Extended cab
Reply With Quote
  #2  
Old 08-15-2014, 03:34 PM
Welcome Bot Welcome Bot is offline
Welcome to Ford Ranger Forum
 
Join Date: Jan 2012
Posts: 2
Default Welcome to Ford Ranger Forum - Forums for Ford Ranger enthusiasts!!

Welcome to FRF!

Here are two links to help you use the forum:
http://www.fordrangerforum.com/site-...ger-forum.html
http://www.fordrangerforum.com/how-t...-pictures.html

You can switch the style of this forum to a light theme by going to http://www.fordrangerforum.com/profi...do=editoptions and scrolling down the last option of "forum skin" and selecting light. You can switch back and forth anytime.

Please insert a signature with information on your truck by going here:
http://www.fordrangerforum.com/profi...=editsignature

We have three contests you can participate in, which you can view here:
http://www.fordrangerforum.com/contests/

Our how-to guides are a great way to begin customizing your truck, view them here:
http://www.fordrangerforum.com/how-tos/

Also, if you're interested in forum stickers, shirts, or ford merchandise visit the FRF store here:
http://www.fordrangerforum.com/store
__________________
I'm a bot that works for FRF. So please don't PM or ask me questions. I'm not that kind of program!
Reply With Quote
  #3  
Old 08-16-2014, 03:56 AM
johnday johnday is offline
Useless olde guy
 
Join Date: Dec 2012
Posts: 3,224
Default Re: High rev when starting

Welcome! I asked this same question a while back, and was told it's normal. 126k on it, and still, so far, so good. I always thought, cold engine/no oil pressure/high rpm= bad. But the older I get, the physics get fuzzier. One of these days I'll run it by the guys at the dealer.
__________________
'04 Edge, Scab/flareside, 2wd, 3.0, 5 speed, 4:10 open. Billet grille, Raceline Raptor black wheels, 265/75/16 DuraTracs. Tbar crank, AAL. Fox shocks, Thrush welded SI/DO swept back side exit. Morimoto projectors, '06 tails and power mirrors. LEDs all the way around. Blacked out fender badge. Access Limited rollup tonneau. 5% tint on back three windows. Airbox mod, FWIW. And a Border Collie that likes it too!!
Reply With Quote
  #4  
Old 08-16-2014, 04:11 AM
Vogenitz69 Vogenitz69 is offline
Ford Ranger Driver
 
Join Date: Nov 2012
Posts: 3,161
Default

Quote:
Originally Posted by johnday View Post
Welcome! I asked this same question a while back, and was told it's normal. 126k on it, and still, so far, so good. I always thought, cold engine/no oil pressure/high rpm= bad. But the older I get, the physics get fuzzier. One of these days I'll run it by the guys at the dealer.
mine idles high at start as well. Once the engine heats up it slows back down. Depending on the weather it can take 5-10 seconds or what feels like a solid minute. Either way it's normal on older ford engines
__________________
2000 Ford Ranger GT 5.0 V8 ~ Work-in-progress, 4" Spindle, 2" Shackle, 2" AAL, Bilstein 4600's, 7/8" Hellwig Rear Sway Bar, 33x10.5r15, Torque Monster Headers, M5R2 5 Speed, ARE Bed Cap
1987 Ford F-150 Lariat 5.0 V8 ~ "Heavy" Hauler, 2" AAL, Stock otherwise
2006 Honda Civic LX 1.6 Totaled
2011 Acura TSX 2.4 ~Daily Driver
Reply With Quote
  #5  
Old 08-16-2014, 05:26 AM
djfllmn djfllmn is offline
ford dealer parts guy
 
Join Date: Apr 2011
Posts: 20,770
Send a message via AIM to djfllmn
Default

That's any engine
__________________
2016 F150 Supercrew XLT 5.0
1968 Ford Thunderbird Tudor 429 Thunderjet V8

(Click for Project Log)

traded-2007 F150 XLT Supercab 5.4
Sold:03 Sonic Blue FX4 Steppie 4.0SOHC 5spd
ranger free since 6/15/2012

Quote:
Originally Posted by Logan03CO View Post
These threads make me feel better about myself....
Quote:
Originally Posted by guell View Post
Welcome to the internet, if this is your first visit to it I suggest you stock up on a lot of preparation h cause you gonna be butt hurt a lot
Reply With Quote
  #6  
Old 08-16-2014, 06:02 AM
littlelauricella littlelauricella is offline
Jimbo James
 
Join Date: Mar 2013
Posts: 83
Default

Quote:
Originally Posted by Vogenitz69 View Post
mine idles high at start as well. Once the engine heats up it slows back down. Depending on the weather it can take 5-10 seconds or what feels like a solid minute. Either way it's normal on older ford engines
My engine is brand new, 27,000 miles on it and it does this.
__________________
2008 Ranger XLT | 2.3L | 2WD | 5-Speed Manual | Flowmaster Exhaust | Aftermarket Fogs | AFE Cold Air Intake
Reply With Quote
  #7  
Old 08-16-2014, 07:10 AM
tredeh tredeh is offline
I almost bought a chevy
 
Join Date: Mar 2014
Posts: 3,727
Default

I always hear it revs up to get the oil flowing. Mine will usually shoot up to 2k rpm and over the course of 45 seconds lower to 900.
__________________
1996 ranger 3.0 extended cab 2wd straight shift SOLD 6/13/15

2003 f150 4.2 regular cab 2wd straight shift still in the driveway

1998 f150 4.2 regular cab 2wd automatic daily driver
Reply With Quote
  #8  
Old 08-16-2014, 07:50 AM
will1963 will1963 is offline
Learning to use the forums
 
Join Date: Aug 2014
Posts: 7
Default Re: High rev when starting

Thanks Guys!! I was kinda worried. I thought it might have been some sensor or something.
__________________
2000 Ford Ranger 4.0L XLT 4X4 Extended cab
Reply With Quote
  #9  
Old 08-16-2014, 09:11 AM
tredeh tredeh is offline
I almost bought a chevy
 
Join Date: Mar 2014
Posts: 3,727
Default

Quote:
Originally Posted by will1963 View Post
Thanks Guys!! I was kinda worried. I thought it might have been some sensor or something.
yea, it worried me too lol
__________________
1996 ranger 3.0 extended cab 2wd straight shift SOLD 6/13/15

2003 f150 4.2 regular cab 2wd straight shift still in the driveway

1998 f150 4.2 regular cab 2wd automatic daily driver
Reply With Quote
  #10  
Old 08-16-2014, 08:51 PM
mxpxpunkrock1987 mxpxpunkrock1987 is offline
Ford Ranger Driver
 
Join Date: Dec 2012
Posts: 744
Default Re: High rev when starting

sounds like an issue with the sensor going to the charcoal sensor which is known for doing this. and welcome to frf
Reply With Quote
  #11  
Old 08-17-2014, 05:03 AM
johnday johnday is offline
Useless olde guy
 
Join Date: Dec 2012
Posts: 3,224
Default Re: High rev when starting

Quote:
Originally Posted by tredeh View Post
yea, it worried me too lol
After 10 years, and 125k+ miles, it still makes me wonder. Makes me wonder how much metal to metal rubbing I've had at 15-2000 rpm with zero oil pressure. But like I've said before, the older I get, the fuzzier my physics gets, and somehow the engine seems fine.
__________________
'04 Edge, Scab/flareside, 2wd, 3.0, 5 speed, 4:10 open. Billet grille, Raceline Raptor black wheels, 265/75/16 DuraTracs. Tbar crank, AAL. Fox shocks, Thrush welded SI/DO swept back side exit. Morimoto projectors, '06 tails and power mirrors. LEDs all the way around. Blacked out fender badge. Access Limited rollup tonneau. 5% tint on back three windows. Airbox mod, FWIW. And a Border Collie that likes it too!!

Last edited by johnday; 08-20-2014 at 07:06 PM.
Reply With Quote
  #12  
Old 08-17-2014, 05:30 AM
dfpgnm dfpgnm is offline
wysiwyg
 
Join Date: Apr 2013
Posts: 908
Default Re: High rev when starting

Quote:
Originally Posted by mxpxpunkrock1987 View Post
sounds like an issue with the sensor going to the charcoal sensor which is known for doing this. and welcome to frf
Oh? I'll file that one away in the memory bank. Didn't know that.
__________________
98 XLT 3.0 manual 4x4 standard cab 6ft bed
RTFM!!!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Another weird high rev question!!! Bigcat84 3.0 Vulcan Tech 3 02-04-2013 09:20 PM
94 2.3 High Rev's when shifting Lflan03 4-Cylinder Tech 5 04-18-2012 10:34 PM
High rev on startup Laser 4.0 SOHC / 4.0 OHV Tech 4 03-12-2012 08:25 PM
High rev while mudding Gumby General Ford Ranger Discussion 2 10-11-2011 09:00 PM
High rev when a/c has been on for a while? Badb3000 3.0 Vulcan Tech 6 03-27-2011 05:28 PM