Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-20-2009, 10:08 AM
driftwoodranger driftwoodranger is offline
Learning to use the forums
 
Join Date: May 2009
Posts: 2
Default heyo!

Hi, name's Robert. i live in south cali and i own an 01 ranger xlt with the 3.0

havent done much to it cept exhaust. went to a quarter inch bigger pipe from the cat to a flowmaster 44 and out the side of the truck in front of the right rear tire also did a custom intake just to get rid of the baffle and the box. thats it so far. truck is at ford at the moment due to some electrical issues. anyways, nice to meet all of you. hope to have some good talks.

-Robert
Reply With Quote
  #2  
Old 05-20-2009, 11:58 AM
scooby stew scooby stew is offline
Ford Ranger Driver
 
Join Date: Apr 2009
Posts: 963
Default

welcome to the fourm like a chinwag myself lol
Reply With Quote
  #3  
Old 05-20-2009, 01:16 PM
RangerJustin RangerJustin is offline
~+!)@(#*$&%^
 
Join Date: May 2009
Posts: 3,033
Send a message via AIM to RangerJustin Send a message via Skype™ to RangerJustin
Default

Hey Robert! I have been thinking of redoing my exhaust that way, just have to find some scrap pipe and a decent tip for it. What did you make the custom intake out of? What were the electrical issues causing?

I am in SoCal as well, out in Eastern Ventura County.
__________________
Sold:2004 XLT 4x2 Ext. Cab. 3.0 Mods: 3" spindle, AAL, shackle, 32x11.5 on 15x8s, billet grille, clear corners, flow 40 dumped, line-x, CB/PA, traction bars, lil sound system, auto up down windows
Sold:2005 XLT 4x4 Ext. Cab. 4.0 Mods: ProComp lights w/ HID swap on tabs, 32x11.5 on 15x8s, CB/PA, black out heads/corners, lil sound system, cranked t-bars, flow 40 dumped, line-x, shell, bed rug, 06+ tails, metal tail gate handle since plastic one shattered, OHC, Mustang Dome.
Reply With Quote
  #4  
Old 05-20-2009, 01:53 PM
98blownranger 98blownranger is offline
Custom KeyChain R Me
 
Join Date: Feb 2009
Posts: 718
Default

welcome all you guys are from Cali
__________________
Quote:
Originally Posted by redrumedge View Post
98blown you should be an MD! that's the same stuff my doc asks and ur spot on man!!!
98 4.0 2wd-----supercharger fully build heads cam...all show with go......3 time world of wheels champ 5 time national winner


lots of ranger parts for sale leftovers from my 94/96
96 sitting on the frame, waiting to go lower


custom billet parts by me intake adapters and billet steps for the step sides

please sign my guestbook!!
http://breyperformancemachine.shutterfly.com/
Reply With Quote
  #5  
Old 05-20-2009, 03:31 PM
TazDevil07 TazDevil07 is offline
Lyfted and Lovin It!!
 
Join Date: May 2009
Posts: 120
Default

Robert!
__________________
Brenda
07 Ford Ranger FX4 Level II+
Toys: 01 Mustang Cobra SVT, 90 Mustang LX 5.0

Reply With Quote
  #6  
Old 05-20-2009, 04:40 PM
driftwoodranger driftwoodranger is offline
Learning to use the forums
 
Join Date: May 2009
Posts: 2
Default

Quote:
Originally Posted by RangerJustin View Post
Hey Robert! I have been thinking of redoing my exhaust that way, just have to find some scrap pipe and a decent tip for it. What did you make the custom intake out of? What were the electrical issues causing?

I am in SoCal as well, out in Eastern Ventura County.

Actually, i just removed the box, baffle and made a plastic converter to mount a standard cone filter to the stock intake hose, so the MAF works just great. I used an existing mount hole on the backside of the hose and made an 90 degree bracket to secure it to the radiator, so when you pop the hood, it looks like its just being held in place by air, i got pictures on my car domain. 2001 Ford Ranger 3.0l RWD - Ventura, California Not much yet cause its been sitting for a while.

The electrical issue is very strange. It's leaning out my mixture on its own. I get no acceleration, and if i do I hear quite a bit of backfire from the exhaust. I get random misfire codes and random times. Truck stutters on initial acceleration like from a stopped position right when i start it up, regardless of it being hot or cold. Some other issues as well. I love the truck and I was a novice mechanic for a while... I can do work on it myself as long as I have the tools but it's still hard to diagnose on my own.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Heyo Superlifted06FX4 Introduce Yourself 7 05-08-2009 11:59 AM