Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-13-2013, 07:09 PM
shaund shaund is offline
Ford Pickup
 
Join Date: Feb 2013
Posts: 116
Default Oil pressure gauge

Ok so when I go out ans start my truck the check gauge light come on and the oil pressure gauge is just sitting there like the truck never was started after it has ran a few mins the check gauge light goes off and it goes upto it's normal place like mid ways the is my first ranger , just wonder if any one else has had this problem and any help or suggestion would be very appreciate . It's a 4.0 with 169000 miles on it

Sent from my iPad using FRF App
__________________
2001 Ranger Edge step side , 4.0 5speed auto trans
Super cab
Plasti dipped wheels
33x12.50's NO LIFT cranked T-bars
Fog light mod
Reply With Quote
  #2  
Old 03-13-2013, 07:16 PM
patrickposton92 patrickposton92 is offline
Ford Tough
 
Join Date: Mar 2013
Posts: 314
Default

How old is the Ranger? It could be the pickup screen on the oil pump. It could be worn out motor oil. It could also be you need a new oil psi sensor. I would start withe the sensor, then an oil change. If still low psi, you can try a motor flush, but fallow the directions to the t. If none of that does it, oil pump screen. Worst case scenairo is bearings.
__________________
Patrick Poston 1990 ford ranger 4cyl 5spd 4wd & 1984 ford ranger 2.0 4spd 2wd. Love em' both
Reply With Quote
  #3  
Old 03-13-2013, 08:08 PM
thatranger thatranger is offline
Ford Ranger Driver
 
Join Date: Aug 2011
Posts: 1,061
Default Re: Oil pressure gauge

Quote:
Originally Posted by shaund View Post
Ok so when I go out ans start my truck the check gauge light come on and the oil pressure gauge is just sitting there like the truck never was started after it has ran a few mins the check gauge light goes off and it goes upto it's normal place like mid ways the is my first ranger , just wonder if any one else has had this problem and any help or suggestion would be very appreciate . It's a 4.0 with 169000 miles on it

Sent from my iPad using FRF App
Our 1999 Ranger 2.5L has done this for over 50,000miles, but sure if its true the oil isn't flowing or just sensors or crap messing up the readings.

When my cam syncro killed my first engine (my 2002 in sig), it decided to kill the oil gauge in the cluster. After replacing the engine, it didn't fix itself so I believe its the cluster. Never fixed it. However I have heard the oil pressure gauges on rangers are 'fake' gauges. I don't think their fake, but don't know for sure, never really looked into it.

You could try a number of things however on something like that, I would take it up to the ford dealership and let them figure it out if your worried your engine is not getting oil.
__________________
2002 Ranger 3.0 XLT | 5Speed | Flareside | 2wd | 3.73open |
__________________________________________________

Quote:
"You rev it, and rev it, and rev it until the valves come out and dance on top of the bonnet. And then you change gear" - James May
Quote:
"9,000rpms into third!"- Jeremy Clarkson
Reply With Quote
  #4  
Old 03-13-2013, 09:18 PM
shaund shaund is offline
Ford Pickup
 
Join Date: Feb 2013
Posts: 116
Default

Well I've only had the truck for maybe a month and two weeks of having it she started doing it ... The motor doesn't sound funny or anything and it goes normal after a few mins of running ...so really don't know

Sent from my iPad using FRF App

----------

And my truck is a 2001 with 169000 4.0 auto trans , the oil looks clean but not sure what they put in it and oil is no low

Sent from my iPad using FRF App
__________________
2001 Ranger Edge step side , 4.0 5speed auto trans
Super cab
Plasti dipped wheels
33x12.50's NO LIFT cranked T-bars
Fog light mod
Reply With Quote
  #5  
Old 03-13-2013, 09:51 PM
jake7586 jake7586 is offline
Learning to use the forums
 
Join Date: Feb 2013
Posts: 1
Default

My 99 was doing this and I replaced the oil sending sensor a week ago and mines been fine ever since
Reply With Quote
  #6  
Old 03-13-2013, 10:01 PM
SweetLeafs421 SweetLeafs421 is offline
Learning to use the forums
 
Join Date: Mar 2013
Posts: 13
Default

Quote:
Originally Posted by shaund View Post
Ok so when I go out ans start my truck the check gauge light come on and the oil pressure gauge is just sitting there like the truck never was started after it has ran a few mins the check gauge light goes off and it goes upto it's normal place like mid ways the is my first ranger , just wonder if any one else has had this problem and any help or suggestion would be very appreciate . It's a 4.0 with 169000 miles on it

Sent from my iPad using FRF App
2000 3.0 v6 4x4 132063 My gauge will flicker while it starts up or while shifting or holdingvthe clutch in but no problems with the vehicle so far put some work in on it about 4000 just because the previous owner didnt do jack to it...
Reply With Quote
  #7  
Old 03-13-2013, 10:02 PM
2010 2010 is offline
Ford Ranger Driver
 
Join Date: Sep 2010
Posts: 1,196
Default Re: Oil pressure gauge

chek oil level. I really cannot notice anything wrong in your description. My older tundra did have a dynamic oil gauge. At a red light itll be indicating a little low oil pressure but a green light came on and I wanted to haulll azzz on the V8 ranger the oil gauge indicated high oil pressure and after picking up speed and cruising into the highway it went back to the "NORMAL" range. never had a problem with that v8 tundra. that v8 tundra haulled some serious azzzz it was fuken fast and quick even with the 285/75/16 tires and lifted tooo. mannnnn good days and expensive tooo when gas was like 4.80 a gallon.
__________________
2010 Ranger XL Reg. Cab 4 cyl... 5 speed manual... W/reverse.

Mods: 5% tint on rear window, JVC KDHDR40 Headunit, Kicker KS-68 speakers, Kicker TCVT102 (10TCVT102) Sub, JVC DRVN KSAX3102 Amp, JVC DRVN KSAX3101D mono amp, Ford black rubber mat, White LED license plate lights. Added 6000k HID Fogs, 6000k Digital HID Heads.

This isn't gramhar skool so dont cry and whine about spelling.
Reply With Quote
  #8  
Old 03-14-2013, 05:18 AM
shaund shaund is offline
Ford Pickup
 
Join Date: Feb 2013
Posts: 116
Default

And it only does it after it has sit a while like over night or been parked for 5 or6 hours
__________________
2001 Ranger Edge step side , 4.0 5speed auto trans
Super cab
Plasti dipped wheels
33x12.50's NO LIFT cranked T-bars
Fog light mod
Reply With Quote
  #9  
Old 03-14-2013, 06:08 AM
patrickposton92 patrickposton92 is offline
Ford Tough
 
Join Date: Mar 2013
Posts: 314
Default

You really need to try a new sensor and see if that helps. When it first starts, does the engine make any bad noises? Rattels, chatter, or knocks?
__________________
Patrick Poston 1990 ford ranger 4cyl 5spd 4wd & 1984 ford ranger 2.0 4spd 2wd. Love em' both
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with Oil Pressure Gauge!!! bordum128 Electrical Tech 6 10-02-2013 08:12 PM
Oil Pressure gauge SandlewoodRager 4-Cylinder Tech 7 01-24-2013 07:55 PM
Want to Buy: Tranny temp gauge, oil pressure gauge, intake temp gauge. Zac150 Engine & Drivetrain Parts 0 10-28-2012 12:53 PM
Oil Pressure Gauge? tpelle Interior Tech 0 06-20-2012 04:53 AM
Oil pressure gauge 91ranger 4.0 SOHC / 4.0 OHV Tech 3 02-20-2010 10:32 AM