Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-21-2009, 11:52 PM
Ddavis91 Ddavis91 is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 10
Send a message via AIM to Ddavis91 Send a message via Yahoo to Ddavis91
Exclamation HELP!!! Weird heater problem!

Okay, so when it gets up to operating temperature my heat is slightly warm...if i'm lucky...if i rev it up or just drive it hard it gets to where it normally used to be...it never did this until i replaced the heater control valve...i dont have the vacuum line hooked up to it but it didnt have it on the other one before...so therefore it's always open...no big deal...but i dont get why i dont have any heat unless i rev it up real high...sometimes it will stay and i'll have heat after i do that but usually it just gets cold again...is there air stuck in my heater core or something?
Reply With Quote
  #2  
Old 11-22-2009, 07:10 AM
ballistic ballistic is offline
Learning to use the forums
 
Join Date: Jul 2009
Posts: 12
Send a message via AIM to ballistic Send a message via Yahoo to ballistic
Default

I know with my patrol car that happens when I am low on radiator fluid. If I sit in a spot the heater goes cold, once I drive it is hot, I had the radiator topped off by mobile maintenance and it solved the problem.
Reply With Quote
  #3  
Old 11-22-2009, 07:51 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default

Thermostat is sticking open. Prevents the coolant from getting warm. Replace it.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #4  
Old 11-22-2009, 09:04 AM
blueovelboy blueovelboy is offline
GO SHARKS
 
Join Date: Aug 2009
Posts: 1,523
Default

heater control valve... you mean the blend door?
__________________
Jay's
09 XL reg cab
L4 2.3 , 40 series flowmaster , tinted windows 5% back 35% sides ,muffler removed from air box mod ,and ac on off switch mod , blinker mod, avs window vent shades
coming soon! k&n drop in/fiberglass bed cover/bed sprayed liner
Reply With Quote
  #5  
Old 11-22-2009, 02:56 PM
littleblue littleblue is offline
Semper Paratus
 
Join Date: May 2009
Posts: 274
Default

Quote:
Originally Posted by ballistic View Post
I know with my patrol car that happens when I am low on radiator fluid. If I sit in a spot the heater goes cold, once I drive it is hot, I had the radiator topped off by mobile maintenance and it solved the problem.
^x2 Double check the coolant level before tearing everything apart again. Need to get the any air out of the system.
__________________
'00 XLT 3.0 Exted cab
Mods: Roush hood & cai, ASP pwr pulley, hot wtr bypass, 180 therm, e-fan, Gibson exh., 4.10 l/s, FabTech lift, kyb's, bii sway bar. 31x10.50 Yokahama ATs, Panther rims, light bar, SS grille, 03 stang buckets, explorer console, hurst shifter


http://www.cardomain.com/ride/706028/1
Reply With Quote
  #6  
Old 11-22-2009, 11:06 PM
Ddavis91 Ddavis91 is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 10
Send a message via AIM to Ddavis91 Send a message via Yahoo to Ddavis91
Default

i tried EVERYTHING to get out the air...no the heater control valve...it controls whether heat goes to your heater core or not...i think i still have air stuck back in the SOB...lol....i just put a new thermostat in....no matter how long i drive it it still stays cold unless i really really get on it....like the water pump just forces coolant through the heater core whether it likes it or not!
Reply With Quote
  #7  
Old 11-22-2009, 11:33 PM
littleblue littleblue is offline
Semper Paratus
 
Join Date: May 2009
Posts: 274
Default

Top the radiator off through the radiator cap and then fill up the overflow bottle. Drive it around for a day and allow it to do a couple of thermal cycles to force the air out and draw coolant back in. Also squeeze the upper radiator hose while it is cold and force any air out of it. Hope that helps.
__________________
'00 XLT 3.0 Exted cab
Mods: Roush hood & cai, ASP pwr pulley, hot wtr bypass, 180 therm, e-fan, Gibson exh., 4.10 l/s, FabTech lift, kyb's, bii sway bar. 31x10.50 Yokahama ATs, Panther rims, light bar, SS grille, 03 stang buckets, explorer console, hurst shifter


http://www.cardomain.com/ride/706028/1
Reply With Quote
  #8  
Old 11-23-2009, 01:25 AM
Ddavis91 Ddavis91 is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 10
Send a message via AIM to Ddavis91 Send a message via Yahoo to Ddavis91
Default

Thanks a lot guys...tried to get some help on rangerpowersports...no replys...this site is a lot better! I'll try that
Reply With Quote
  #9  
Old 11-23-2009, 06:36 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default

Again, thermostat is sticking open. Prevents the coolant from getting warm. Replace it.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #10  
Old 12-05-2009, 09:10 PM
DannMarr DannMarr is offline
Not as smart as I think
 
Join Date: Nov 2009
Posts: 258
Default

I just had this problem on my 2001 Ranger, it was the heater control valve. My mechanic bypassed it and it heats up great! I will need to replace it in the summer. This valve stops the flow to the heater coil when the A/C is activated.
__________________
2001 Ford Ranger with the flare sides. 4x4 with a 4.0 engine. The only thing I did so far is: F/R Brakes, rotors, drums, F/R shocks, tires, bed cap, cone filter, hanger/shackles, F/P wheel bearing, upper control arm, lower ball joint, filler neck, fuel filter and DPFE sensor, muffler, sway bar links and spark plugs!
Reply With Quote
  #11  
Old 12-07-2009, 02:49 AM
Ddavis91 Ddavis91 is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 10
Send a message via AIM to Ddavis91 Send a message via Yahoo to Ddavis91
Default

thats what i replaced when it started doing this....but i think it just had a lot of air trapped in the heater core...it's mostly worked its way out now...it still doesnt get as hot as it used to but it gets better day by day!
Reply With Quote
  #12  
Old 02-04-2014, 05:28 PM
deb2gram1991 deb2gram1991 is offline
Learning to use the forums
 
Join Date: Jan 2014
Posts: 1
Default Re: HELP!!! Weird heater problem!

My 2001 Ford Ranger just blows out cold and the temp gage never moves up to comfort level. We have replaced 2 sensors, the heat module, thermastat and have a new heater core. How do we check the vacuum that goes into the heat module?
Reply With Quote
  #13  
Old 02-19-2014, 10:49 AM
Tractorboy95 Tractorboy95 is offline
Learning to use the forums
 
Join Date: Mar 2012
Posts: 9
Default Re: HELP!!! Weird heater problem!

I dont understand the purpose of the HCV.. Mine hasnt worked properly in years. In fact i had to replace it again last weekend because the two plastic ports blew off the back of the dang valve. LITERALLY, the valve blew up! That'll scare the heck out of you when your crusin down the trail and white smoke starts pouring out from under the hood.
__________________
1998 4wd Ford Ranger XLT 4.0L V6 step side. Stock engine, 3'' body lift, 3'' keys and 2.5'' rear blocks, 33" hercules trail diggers/mickey thompson classicIII rims. CB radio/ Pa speaker, front hitch...
Reply With Quote
  #14  
Old 02-19-2014, 03:15 PM
Grampybox Grampybox is offline
**************
 
Join Date: Aug 2013
Posts: 930
Default Re: HELP!!! Weird heater problem!

Quote:
Originally Posted by Ddavis91 View Post
Okay,..i dont have the vacuum line hooked up to it but it didnt have it on the other one before...
Did you try connecting the vacuum line?
I mean you know, Just for giggles & grins?
__________________
I Picked a hell of a week to stop Snorting Crushed Dung Beetles!!!
Black '98 XLT
4.0 liter, super/extended cab, 4X4, 5 speed manual
*Mods & Pseudo Mods*
Sony head unit, Expo OHC, Uniden CB

Quote:
Originally Posted by cowboybilly9mile View Post
*People who do stupid things normally don't get better but rather, they just continue doing stupid things.
I Don't Always Mod My Ranger

But when I do, I Post Pictures
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
New guy here!!! Weird noise byrdi 4-Cylinder Tech 19 12-01-2009 07:27 PM
Heater and A/C problem? SmashedRanger Electrical Tech 2 10-20-2009 07:28 PM
Heater control problem Thunderstorm2_2002 General Tech 6 09-16-2009 07:15 PM
Weird issue? jasonmcr Drivetrain Tech 0 08-30-2009 08:44 PM