Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-03-2011, 05:38 PM
Cableone Cableone is offline
Rick
 
Join Date: Feb 2011
Posts: 16
Default Speedo no work

Hey ya'll, i just changed the cluster and everything works fine except the speedo. Any ideas? how hard would it be to take my old speedo and place in the new cluster? Thanks Rick
__________________
2000 XLT single cab flare side
massive 2.5 ltr , 5spd
Bone stock for now except rims
mods done: OHC, instrument cluster and custom roll n lock bed cover.
Reply With Quote
  #2  
Old 08-03-2011, 07:36 PM
Cableone Cableone is offline
Rick
 
Join Date: Feb 2011
Posts: 16
Default Re: Speedo no work

never mind, duh
__________________
2000 XLT single cab flare side
massive 2.5 ltr , 5spd
Bone stock for now except rims
mods done: OHC, instrument cluster and custom roll n lock bed cover.
Reply With Quote
  #3  
Old 08-03-2011, 08:27 PM
TuricksTruck TuricksTruck is offline
Crimson Tide, RTR
 
Join Date: Jul 2011
Posts: 57
Default Re: Speedo no work

Was the fuse blown??
__________________
CRIMSON
2002 4cyl 2.3l Automatic 4x2 STD CAB, K&N Drop in Air Filter, Autolight double platinum spark plugs and wires, Mustang Dome, White Custom Interior, Sony Xplod 200w deck with 4 6x8's 3way Sony Xplod speakers
Reply With Quote
  #4  
Old 08-04-2011, 05:11 PM
Cableone Cableone is offline
Rick
 
Join Date: Feb 2011
Posts: 16
Default Re: Speedo no work

no fuse prob, I just needed to read a bit.
__________________
2000 XLT single cab flare side
massive 2.5 ltr , 5spd
Bone stock for now except rims
mods done: OHC, instrument cluster and custom roll n lock bed cover.
Reply With Quote
  #5  
Old 08-19-2011, 05:07 PM
speeddr2000 speeddr2000 is offline
Learning to use the forums
 
Join Date: Jul 2011
Posts: 11
Default Re: Speedo no work

what did you read mines doing the same thing. been searcing for 3 hours. help please ! thanks
Reply With Quote
  #6  
Old 08-19-2011, 05:11 PM
Jimmeh Jimmeh is offline
I am THE Hank Hill.
 
Join Date: Sep 2009
Posts: 1,085
Send a message via AIM to Jimmeh
Default Re: Speedo no work

Yeah, please specify what you did so when guys have to search for the problem they may get a solution.
__________________
92 Ford Ranger Supercab XLT 4X4.
Not a ton done to it, but it's nowhere near finished
05 Chevy Silverado 1500 W/T 4X4
Way too much done to list and it's also not even close to done

"The only woman I'm pimping from now on is Sweet Lady Propane. And I'm tricking her out all over this town."
Reply With Quote
  #7  
Old 08-21-2011, 07:33 PM
Cableone Cableone is offline
Rick
 
Join Date: Feb 2011
Posts: 16
Default Re: Speedo no work

Sorry about that, I had changed out my cluster for one with a tach. Every thing was fine xcept the speedo did not work. What i did was swap my original speedo unit for the newer unit that did not work. All works now and odometer is original. My question was is there a way to swap speedo units. Itis in the how to section under changing odometer. Hope this helps
__________________
2000 XLT single cab flare side
massive 2.5 ltr , 5spd
Bone stock for now except rims
mods done: OHC, instrument cluster and custom roll n lock bed cover.
Reply With Quote
  #8  
Old 08-22-2011, 08:21 AM
speeddr2000 speeddr2000 is offline
Learning to use the forums
 
Join Date: Jul 2011
Posts: 11
Default Re: Speedo no work

K thank you
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!!! with speedo 02dangerrangerjosh Interior Tech 7 07-27-2011 05:51 AM
calibrating speedo.... brobes600 Interior Tech 6 03-12-2011 01:56 PM
Speedo doesnt work need assistance Westiedog General Tech 0 02-16-2011 05:42 PM
speedo question ranginlow 4-Cylinder Tech 8 12-24-2010 07:04 PM
Speedo calibration RallyTruck Lifted Suspension 5 01-17-2010 03:59 PM