Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 06-28-2011, 07:01 PM
NPRanger12 NPRanger12 is offline
Learning to use the forums
 
Join Date: Jun 2011
Posts: 2
Default Turn signals don't work!!?? Help

The turn signals in my 03 ranger quit working. The hazards work fine along with all of the other functions of the multi-funtion switch. I have replaced the multi-function switch along with the largest plug that plugs into it, as some of the connections were bad. After replacing the switch everything seems to work fine except for the turn signals, both left and right sides still don't work. Occasionaly the signal will blink when I use them, but does not stay on. Could there be a bad connection somewhere?? Much help please.
__________________
2003 Ford Ranger XLT, 4L 6 Cylinder
Reply With Quote
  #2  
Old 06-28-2011, 07:03 PM
klinger86 klinger86 is offline
Ford Ranger Driver
 
Join Date: Jan 2011
Posts: 2,970
Default Re: Turn signals don't work!!?? Help

could be a bad flasher but not really sure.....
Reply With Quote
  #3  
Old 06-28-2011, 07:10 PM
NPRanger12 NPRanger12 is offline
Learning to use the forums
 
Join Date: Jun 2011
Posts: 2
Default Re: Turn signals don't work!!?? Help

Ill check it out. Its been a mystery. Just trying to avoid getting raped by a dealer or shop over this. Thanks
__________________
2003 Ford Ranger XLT, 4L 6 Cylinder
Reply With Quote
  #4  
Old 06-28-2011, 07:19 PM
tmoore78 tmoore78 is offline
Ford Ranger Driver
 
Join Date: Oct 2010
Posts: 981
Default Re: Turn signals don't work!!?? Help

i would check the relay. when they go out, it will either have really long flashes or "randomly flash"/work when you punch the dash. lol
__________________
2007 FORD RANGER XLT EXTENDED CAB - 4.0, 4x4, 5sp
Ultragauge, 10" L7 W/ 2200W PA Amp, CB W/4' Fiberglass whip, PA system, LEER shell w/led 3rd brake and custom remover, LED taillights in mudflaps, 5K 55W HIDs, Aux reverse lights, DIY bed liner, Hellas, Bed mat (cut up livestock mat).


Quote:
Originally Posted by 2004xlmiller View Post
yea with 4.10s a 3.slow and 33s it will be a 3.dudegetthefuckouttamywayyouresoslow
Reply With Quote
  #5  
Old 06-28-2011, 07:21 PM
DiabloBlanco DiabloBlanco is offline
Get Lifted.
 
Join Date: Nov 2010
Posts: 6,402
Default Re: Turn signals don't work!!?? Help

check your bulbs, relay, and fuses. also harness.
__________________
YZ the way to be!
The Brotherhood!

Mods to come: Camburg entry 6.0 system. FiberwerkX Fenders and bedsides. Tube bumper.
R.I.P. Jeff Ashton. 1992-2011
Reply With Quote
  #6  
Old 06-28-2011, 07:46 PM
Dcrymes99ranger Dcrymes99ranger is offline
Explorer seats are in
 
Join Date: Oct 2009
Posts: 6,176
Default Re: Turn signals don't work!!?? Help

I would say check your flasher under the dash... It should be round..
__________________
1999 Ford Ranger 3.0xl


My Build Thread!!!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
turn signals wont work. Stolley94Ranger Electrical Tech 2 03-27-2011 01:19 PM
turn signals mazdab2300 Exterior Tech 8 12-18-2010 06:31 PM
1995 turn signals TexasRanger16 Electrical Tech 1 11-14-2010 10:26 PM
turn signals tompesar Electrical Tech 5 10-29-2009 06:18 PM
Turn signals not working Poody86 Electrical Tech 8 10-08-2009 08:52 PM