Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-22-2011, 12:29 PM
penguin penguin is offline
Ford Ranger Owner
 
Join Date: Mar 2011
Posts: 68
Default Help Please

Finally got aroung to installing my OHC. Down to the wire to the speed sensor. Where does this go & what damn color of wire? There are enough wires to run a nuclear submarine.
__________________
have a 2008 Ranger 4.0 auto., 4 whl dr. Installed a K&N cold air induction & Magnaflo cat back duals.
Reply With Quote
  #2  
Old 05-22-2011, 12:35 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: Help Please

The grey/black VSS does not exist in the 2007+ Ranger. The color code for 2007+ is violet w/orange stripe and it runs only under the hood between the PCM plug and the Speed Control Servo.
__________________
2005 Edge

Reply With Quote
  #3  
Old 05-22-2011, 12:40 PM
penguin penguin is offline
Ford Ranger Owner
 
Join Date: Mar 2011
Posts: 68
Default Re: Help Please

Thanks so much. Damn your truck is beautiful.
__________________
have a 2008 Ranger 4.0 auto., 4 whl dr. Installed a K&N cold air induction & Magnaflo cat back duals.
Reply With Quote
  #4  
Old 05-22-2011, 12:50 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: Help Please

Your welcome that is what the forum is for helping others.
__________________
2005 Edge

Reply With Quote
  #5  
Old 05-22-2011, 01:34 PM
penguin penguin is offline
Ford Ranger Owner
 
Join Date: Mar 2011
Posts: 68
Default Re: Help Please

Just fiinshed running my wire thru firewall. So I don't screw up my baby,2 more questions please. Is the speed contol servo directly behind the winsow washer bottle? If so there appears to be 2 violet/orange strip wires. One @ top of harness & one @ bottom.
__________________
have a 2008 Ranger 4.0 auto., 4 whl dr. Installed a K&N cold air induction & Magnaflo cat back duals.
Reply With Quote
  #6  
Old 05-22-2011, 02:09 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: Help Please

The PCM is in the passenger side firewall and has 3 connectors. The center connector contains the VT/OR wire. The #1 pin location is almost always marked on the connector shell with an embossed "1" if you want to bother looking for it.

Yes it is located by the window washer bottle There are only about 8 wires to deal with at the servo.
__________________
2005 Edge

Reply With Quote
  #7  
Old 05-22-2011, 03:03 PM
penguin penguin is offline
Ford Ranger Owner
 
Join Date: Mar 2011
Posts: 68
Default Re: Help Please

You are "The Man".
__________________
have a 2008 Ranger 4.0 auto., 4 whl dr. Installed a K&N cold air induction & Magnaflo cat back duals.
Reply With Quote
  #8  
Old 05-23-2011, 05:47 PM
DangerRanger379 DangerRanger379 is offline
B. A. M. F.
 
Join Date: Dec 2009
Posts: 483
Default Re: Help Please

i have my speed sensor wire connected but what does it even do?
__________________
2003 | XLT | Extended Cab | V6 | 4x4 | 4.0L SOHC | 3 Inch Body Lift | Cranked T-Bars | TJM Wench Bumper | Blacked Out Heads | Fog Light Mod | Surround Delete Mod | Blinker Mod | Custom Center Console | OHC | Pacer Bullet Rims | 33x12.5 All Terrains | 1 Inch Wheel Spacers
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search