Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-12-2011, 06:03 AM
jcostin jcostin is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2011
Posts: 29
Default guage cluster issue

Good morning! Aside from my newly aquired 05 4x4, I have a 96 xlt 2.3lt 5-speed with 214+K miles. Several years ago, the oil pressure gauge quit working. Then a couple years later, the gas gauge went screwy going up and down then dropped below E and has not moved again. I was using the odo to keep up with gas knowing that at 380 miles on a full tank and I'd better be looking for a gas station (worked perfectly except one time when I had to let the truck warm up for a couple of weeks before taking my daughter to school...idling does burn gas!). Now back in October, the odo quit working. I'm heading out to a "parts" yard this morning and was thinking about pulling a cluster, but do you think I'd be better off purchasing one new?....and, since it's a 96, what are the chances that I will have to get it reprogrammed if I do purchase a used one?

Thanks in advance!
__________________
2005 FX4 109K miles
4.0 SOHC
no mods...yet!
Reply With Quote
  #2  
Old 02-12-2011, 06:06 AM
turbographx turbographx is offline
Ford Tough
 
Join Date: Sep 2010
Posts: 273
Default Re: guage cluster issue

Easy swap, nothing to program. there is a post here on the forums showing you how to set the odometer once you get a replacement cluster.
__________________
93 Ranger Splash. Standard cab. 3.0 v-6, 5spd.
Mods: New engine and trans. Cluster swap with tach. New headunit and speakers all around. 4x4 front valance. Led turn indicator mirrors. Crystal clear head lamps. Clear corners. 5" driving lights in Valance.
Mods to come: 'stang seats, explorer console, window tint, flowmaster cat back, some mild port work.
Reply With Quote
  #3  
Old 02-12-2011, 01:07 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: guage cluster issue

Ya no programing and you can refer to this thread on rolling the odometer up or down.
http://www.fordrangerforum.com/inter...03-trucks.html<===CLICK
__________________
2005 Edge

Reply With Quote
  #4  
Old 02-12-2011, 01:18 PM
jcostin jcostin is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2011
Posts: 29
Default Re: guage cluster issue

Thanks...I pulled one from a 97 with 280K...not concerned with trying to keep it in sellible conditon...just need the gauges to work as my son is driving 70 miles round trip to school every day.
__________________
2005 FX4 109K miles
4.0 SOHC
no mods...yet!
Reply With Quote
  #5  
Old 02-12-2011, 01:19 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: guage cluster issue

Cool deal.
__________________
2005 Edge

Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Want to Buy: Guage Cluster Prunedale 4x4 Interior Parts 5 12-23-2010 11:58 PM
guage cluster question carcrazi07 Interior Tech 3 11-17-2010 04:34 AM
Guage cluster LED's tmbrockett Interior Tech 4 10-02-2010 04:16 PM
Guage Cluster Swap gwhunter07 Electrical Tech 7 06-10-2010 12:25 PM
Reseting cluster guage clos210 Interior Tech 3 01-24-2010 12:52 PM