Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 12-11-2010, 12:43 PM
majestic47 majestic47 is offline
Learning to use the forums
 
Join Date: Nov 2010
Posts: 7
Default New problems

I just got through troubleshooting an idling issue I've been having. after screwing around under the hood for a while cleaning some stuff, I ended up changing the fuel pump which fixed the problem. In the process of fixing this, I unplugged and plugged back in a lot of different wires and also had a dead battery for an extended period of time. now that the idling problem is fixed, I have no heat, air will only come out of the defroster, and the oil temp won't work. the channels I had set on the radio are also gone, which is leading me to believe that something just needs to be reset. I broke and then changed the heat valve trying to get leverage on my O2 sensor, but considering nothing electrical hooks to the valve I don't know how it could be part of the issue... did I short something out? does the computer just need to be reset? if so, how do I do it?


__________________
1998 Ford Ranger
2.5L 153CI L4 FI VIN: C
Reply With Quote
  #2  
Old 12-11-2010, 02:59 PM
drppdyllwrngr drppdyllwrngr is offline
Ford Ranger Driver
 
Join Date: Feb 2010
Posts: 3,122
Default Re: New problems

the hvac runs off vacuum for the most part. there is a vacuum line on the heater bypass valve. check there, or on the sphere that is around the passenger inner fender.

rangers don't have an oil temp gauge.

as for the radio, if the battery goes dead, you lose all your presets.
__________________
Krylon Fusion is for Amateurs.
Reply With Quote
  #3  
Old 12-11-2010, 03:36 PM
terryduanemiller terryduanemiller is offline
www.shanewootenband.com
 
Join Date: Oct 2010
Posts: 1,896
Default Re: New problems

when you broke the HCV maybe you snatched the vacuum line out of the firewall. check n see if it is sucking? if not maybe you have an air pocket in heater core
__________________
MY BUILD THREAD
1999 MAZDA 2500SE, 2.5L 4-clanger, 5 speed, Green n slow. Rangers as daily drivers since 1988.
ASE Certified Mechanic, Builder of Show Destroying Protouring and Classic cars..
Reply With Quote
  #4  
Old 12-11-2010, 08:25 PM
drppdyllwrngr drppdyllwrngr is offline
Ford Ranger Driver
 
Join Date: Feb 2010
Posts: 3,122
Default Re: New problems

Quote:
Originally Posted by terryduanemiller View Post
check n see if it is sucking? if not maybe you have an air pocket in heater core
what? an air pocket in the heater core? an air pocket in the heater core would be coolant, not a vacuum issue.
__________________
Krylon Fusion is for Amateurs.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
i have many problems BryFin83 Electrical Tech 16 06-20-2011 04:27 AM
AC Problems earnbud General Tech 4 06-09-2011 06:54 PM
some little problems with my 3.0, HELP!! 2004xlmiller 3.0 Vulcan Tech 19 08-24-2010 05:49 AM
C4 Problems!!! Hinderburger Drivetrain Tech 1 06-22-2010 08:19 AM
problems IVAN General Ford Ranger Discussion 1 02-17-2010 07:40 PM