Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 10-12-2010, 10:55 AM
somidscr21 somidscr21 is offline
Buy a Ford
 
Join Date: Sep 2010
Posts: 194
Default Speedometer Issues

I recently swapped out my cluster for a white sport trac cluster. Everything was peachy keen for a week or so, but now my speedometer stopped working correctly. I followed the guide for making sure it worked while swapping the odometer and that went fine.

Yesterday, however, it sits between 40-60 even with the truck off. When I turn it on it stays up in that area instead of going down to 0. It also does not move smoothly or predictably. It doesn't move for a while, then it jumps up 5-10 mph, then sits, then jumps, etc, etc...

Any ideas on how to fix this would be outstanding, luckily I can tell roughly how fast I'm going based on what gear I'm in, but that won't be even close to accurate on the highway...
__________________
2003 Ranger 4Cyl 2.3L XL Styleside bed
Pioneer DEH-3100UB, Lund Genesis Tonneau, grill painted black, black front emblem, clear corners, ultra-guage, LED cluster.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is my speedometer still off...? BlackMoses Wheels and Tires 4 10-05-2010 03:43 PM
Speedometer Dead! bolivartech 4-Cylinder Tech 6 08-06-2010 02:24 PM
Speedometer Problem Ruff Electrical Tech 0 03-11-2010 08:41 AM
speedometer HELP camoman Electrical Tech 3 11-25-2009 05:58 AM
Speedometer is off, at best Momboy007 General Tech 3 11-15-2009 12:10 AM