Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-07-2009, 03:41 PM
Buddythetruck Buddythetruck is offline
Eat-Sleep-Mod
 
Join Date: May 2009
Posts: 235
Default No power to my dome light

Hello, I have a '97 ford ranger and my dome light won't work. I was planning on replacing it with a custom lighted overhead console, and using the power supply for the console.
I pulled the dome light out, but when I check the wires with a multimeter I get no voltage, but I do get continuity.

What is going on, and how can I fix it?

Thanks in advance

note: I have replaced the fuse (#27)
Reply With Quote
  #2  
Old 07-07-2009, 04:01 PM
98blownranger 98blownranger is offline
Custom KeyChain R Me
 
Join Date: Feb 2009
Posts: 718
Default

can you turn it on with the switch? if so look at the door switch, if no power at all then look at the fuse again and do you have power there
__________________
Quote:
Originally Posted by redrumedge View Post
98blown you should be an MD! that's the same stuff my doc asks and ur spot on man!!!
98 4.0 2wd-----supercharger fully build heads cam...all show with go......3 time world of wheels champ 5 time national winner


lots of ranger parts for sale leftovers from my 94/96
96 sitting on the frame, waiting to go lower


custom billet parts by me intake adapters and billet steps for the step sides

please sign my guestbook!!
http://breyperformancemachine.shutterfly.com/
Reply With Quote
  #3  
Old 07-07-2009, 06:12 PM
Buddythetruck Buddythetruck is offline
Eat-Sleep-Mod
 
Join Date: May 2009
Posts: 235
Default

I pulled the fuse and plugged in the multi meter. It read 12.23 volts.
Then something interesting happened. I put the fuse back in, and the dome light flashed for a second, and then I heard a click (like a circuit breaker) and the light went out.
Any thoughts of where this breaker is?
Reply With Quote
  #4  
Old 07-07-2009, 06:47 PM
98blownranger 98blownranger is offline
Custom KeyChain R Me
 
Join Date: Feb 2009
Posts: 718
Default

no breaker only a fuse and bulb
__________________
Quote:
Originally Posted by redrumedge View Post
98blown you should be an MD! that's the same stuff my doc asks and ur spot on man!!!
98 4.0 2wd-----supercharger fully build heads cam...all show with go......3 time world of wheels champ 5 time national winner


lots of ranger parts for sale leftovers from my 94/96
96 sitting on the frame, waiting to go lower


custom billet parts by me intake adapters and billet steps for the step sides

please sign my guestbook!!
http://breyperformancemachine.shutterfly.com/
Reply With Quote
  #5  
Old 07-08-2009, 12:08 PM
4evermodding 4evermodding is offline
Modding To Continue >>>>
 
Join Date: May 2009
Posts: 1,114
Default

please make sure that the middle screw in your dome light is making good contact. this is your ground screw. it may be scripped and remembe their is only a direct source for your domelight. its directly to your dimmer switch. please check both the ground and dimmer switch.
Reply With Quote
  #6  
Old 07-08-2009, 05:39 PM
Buddythetruck Buddythetruck is offline
Eat-Sleep-Mod
 
Join Date: May 2009
Posts: 235
Default

My dome light module didn't have continuity, so I took it out. Currently I just have an LED from rat shack that is twisted together with the two wires that were attached to the Dome light module.
Are you saying there is also a ground? I assume I should just attached the negative wiere on my LED to the body of the car, correct?
Reply With Quote
  #7  
Old 07-08-2009, 05:51 PM
Buddythetruck Buddythetruck is offline
Eat-Sleep-Mod
 
Join Date: May 2009
Posts: 235
Default

I just checked it, and sure enough. Both wires are positive. So hooking the LED to either of the two wires and to the ground works great. I never would have thought that both of the wires were positive.

Thankyou very much.
Reply With Quote
  #8  
Old 07-08-2009, 10:07 PM
4evermodding 4evermodding is offline
Modding To Continue >>>>
 
Join Date: May 2009
Posts: 1,114
Default

Quote:
Originally Posted by Buddythetruck View Post
I just checked it, and sure enough. Both wires are positive. So hooking the LED to either of the two wires and to the ground works great. I never would have thought that both of the wires were positive.

Thankyou very much.

YOU ARE VERY WELCOME. WHEN YOU LOOK UP AT THE DOMELIGHT AREA. you will see a screw hole that is where your middle screw grounds at. thats called your ground screw and it looks as though the info worked. congrats
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
98' 3.0L... No acceleration, power, or pep HarveyT1184 3.0 Vulcan Tech 30 12-30-2011 05:42 PM
Changing Dome Light TruckerTom Interior Tech 9 04-10-2011 11:05 AM
3.0 needs a power boost. sho_or_go 3.0 Vulcan Tech 6 07-15-2009 08:19 AM
91 dome light issues dogboy Electrical Tech 0 06-02-2009 12:39 PM
Power Steering '97 4.0 V6 pmadill General Tech 2 05-20-2009 01:54 PM