Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 12-05-2019, 03:22 PM
laxmasterj2 laxmasterj2 is offline
Learning to use the forums
 
Join Date: Nov 2019
Posts: 14
Default Dash lighting went out of no where

I had a dew burnt out bulbs, namely the top of the speedometer, and fuel illuminator, but all of the sudden i noticed every light left of center doesn't work anymore. Still have voltage, oil pressure and most of the speedo as well as all of the warning a fault lights across the whole dash, but all of the illumination including the needles dies all of the sudden.

Also, 4x4 switch is still illuminated but the headlight and dash brightness switches on the left are dark now too. They still work, just no light.
The tach needle is on but the illumination stops halfway up the length of it and looks really dim.

Sent from my LM-V405 using Tapatalk
Reply With Quote
  #2  
Old 12-06-2019, 12:41 AM
Fx4wannabe01 Fx4wannabe01 is offline
Ford Ranger Driver
 
Join Date: Sep 2009
Posts: 4,104
Default Re: Dash lighting went out of no where

Do what you've put off for so long.....replace the cluster bulbs. Up to 95-03 only use 6 bulbs to illuminate the cluster. Sounds like 4 out of those 6 are burnt.

The dimmer switch isn't illuminated and 99.9% of Ranger's headlight switch bulbs are burnt out.

No truck info but I'm making an assumption of 95-11. Dash of 04-11 slightly different but same exact process. Clicky:
__________________
'01 XLT disguised as a '03 Fx4 Level II.
Reply With Quote
  #3  
Old 12-12-2019, 12:44 AM
laxmasterj2 laxmasterj2 is offline
Learning to use the forums
 
Join Date: Nov 2019
Posts: 14
Default Re: Dash lighting went out of no where

Apologies for no info
2002 Ford Ranger XLT 4x4 (4.0L)

also, when I first got the truck, it had a couple bulbs out in that area so I replaced them, got all but the 12 o'clock one I mentioned in the op (didn't take a pic before starting job and missed it.). I was a little worried abt the timing of them all going out cus I have that odd noise in the dash when turning the wheel past center at speed that some say is a loose harness. Figured it could have worn down and damaged some wires :/

Sent from my LM-V405 using Tapatalk
Reply With Quote
  #4  
Old 02-06-2020, 09:27 AM
laxmasterj2 laxmasterj2 is offline
Learning to use the forums
 
Join Date: Nov 2019
Posts: 14
Default Re: Dash lighting went out of no where

Looks like they were just old and I must have hit a big bump and broke them. Pulled it out and replaced all 6, looks great and works fine. Took the chance to take the dash apart and wipe the gauges down with interior shine and clean the glass.

Thought I had an after pic, the cleaning and shining made it look brand new, save for the spool reading 235k miles-_-. Bright and full as ever

Sent from my LM-V405 using Tapatalk
Reply With Quote
  #5  
Old 02-06-2020, 02:30 PM
Scrambler82 Scrambler82 is offline
The EDGE
 
Join Date: Nov 2009
Posts: 167
Default Re: Dash lighting went out of no where

Whats the Maps Unit on the dash ?
__________________
Grev B
Do it right the first time !
03 EDGE, E4 RED, SL Lifted w/Coil Over in frt, BFG AT, 33 x 12.50 x 15 a lot of little things.
Custom front and rear bumpers - C4x4, in OK.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
LED dash lighting question cowboybilly9mile Interior Tech 10 12-13-2013 05:09 AM
Dash lighting?? chad0285 Interior Tech 7 04-13-2012 07:49 PM
Dash lighting change??? chyzdad Interior Tech 1 09-11-2010 01:52 PM
Dash lighting EMB1230 Interior Tech 8 07-28-2010 04:29 PM
LED lighting for dash. Grizzly Interior Tech 2 05-10-2010 01:56 PM