Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-30-2017, 01:15 PM
Murph99Ranger Murph99Ranger is offline
Learning to use the forums
 
Join Date: Nov 2017
Posts: 4
Default Instrument cluster problem

I have a 99 Ford Ranger I have had this problem since Iíve had the truck for 4 years all my gauges work in th cluster but only one light out of the six lights up so I went and bought all new lights for it and when I changed the bulbs a couple was burnt up I changed all six and still only the one lights up the top one above the speedometer every fuse in my truck are good some light and headlights every light works just canít figure out why the cluster lights wonít work besides that one any help please

----------

Instrument cluster problem
I have a 99 Ford Ranger I have had this problem since Iíve had the truck for 4 years all my gauges work in th cluster but only one light out of the six lights up so I went and bought all new lights for it and when I changed the bulbs a couple was burnt up I changed all six and still only the one lights up the top one above the speedometer every fuse in my truck are good some light and headlights every light works just canít figure out why the cluster lights wonít work besides that one any help please. Thanks In Advance

----------

Instrument cluster problem

I have a 99 Ford Ranger
I have had this problem since Iíve had the truck for 4 years all my gauges work in th cluster but only one light out of the six lights up so I went and bought all new lights for it and when I changed the bulbs a couple was burnt up I changed all six and still only the one lights up the top one above the speedometer every fuse in my truck are good some light and headlights every light works just canít figure out why the cluster lights wonít work besides that one any help please.
Thanks in advance.
Reply With Quote
  #2  
Old 12-01-2017, 11:15 AM
Kealel Kealel is offline
Bringing hell to the city
 
Join Date: Feb 2015
Posts: 2,587
Default Re: Instrument cluster problem

Did you replace the bulbs with new filament-in-glass bulbs it with LED bulbs.

If the glass route, did you get 194 bulbs?
__________________
Baby Girl: 2006 White Ranger XL with many memories. R.I.P. 1/26/15
Quote:
Originally Posted by Logan03CO View Post
I knew you were an alright guy!
Quote:
Originally Posted by ford4thot View Post
The only reason it's worn out junk is because you've gone 70k miles without changing the oil.
Reply With Quote
  #3  
Old 12-01-2017, 01:15 PM
Murph99Ranger Murph99Ranger is offline
Learning to use the forums
 
Join Date: Nov 2017
Posts: 4
Default Re: Instrument cluster problem

We placed the stock bulbs with leds but still only the same one that lit up before is working and yes 194 bulbs
Reply With Quote
  #4  
Old 12-01-2017, 02:11 PM
Murph99Ranger Murph99Ranger is offline
Learning to use the forums
 
Join Date: Nov 2017
Posts: 4
Default Re: Instrument cluster problem

I talked to a guy and he said my whole cluster could be bad even tho the gauges are working it could be bad making the lights not work
Reply With Quote
  #5  
Old 12-01-2017, 06:55 PM
JAMMANICA JAMMANICA is offline
Craigslist is awesome
 
Join Date: Jun 2016
Posts: 548
Default Re: Instrument cluster problem

?

Do you have the polarity on the LED's correct? They have a distinct positive and negative which isn't marked on the cluster because regular bulbs will work in either direction. I think you got 20% lucky on the LED placement.
__________________
00 XLT 4WD XCSB 4.0 my new baby
00 XLT 2WD RCSB 5.0 swap in progress.
98 XLT 4WD XCSB 4.0 dead
99 EXPO donor motor for dead one and parts for the others.
Newest Ranger Forum
Reply With Quote
  #6  
Old 12-02-2017, 07:07 AM
Murph99Ranger Murph99Ranger is offline
Learning to use the forums
 
Join Date: Nov 2017
Posts: 4
Default Re: Instrument cluster problem

Not sure I didnít know there was a difference what should I do to try
Reply With Quote
Reply

Tags
cluster, ford, instrument, ranger

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
instrument cluster speedometer problem? Rclemmer Interior Tech 2 09-05-2014 04:19 PM
Newby with instrument cluster problem ejaylink Interior Tech 0 12-14-2013 10:12 AM
instrument cluster& hvac light problem TBUSH Interior Tech 3 03-31-2012 07:39 AM
Instrument Cluster Muscleford Interior Tech 3 02-05-2012 06:53 AM
Instrument Cluster yodercop Interior Tech 15 07-02-2011 08:09 AM