Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-21-2017, 09:06 AM
fithers fithers is offline
Learning to use the forums
 
Join Date: Feb 2017
Posts: 10
Default Changed Cam sync/sensor, now high idle

Hey everyone, new here to this forum after getting my Ranger in August and just introduced myself in the intro forum. I bought my truck with 143k on the clock and was in great shape, recently passed inspection and full maintenance records from previous owner. Flushed all fluids, new brakes, new IAC valve, new plugs, and a few other things with my dad who is an engineer and a super mechanic type. I have always done basic things like oil change etc. growing up, but really trying to learn my engine since buying my truck.

She had been running like a champ and a few weeks ago around 149k i noticed this chirping noise that sounded like a belt. Did my homework here and around the internet and found it was the camshaft synchronizer and sensor. here's a video of the noise


I know there a million threads about camshaft syncros, my issue here is since replacing mine



now, I got a new duralast gold camshaft syncro and sensor from autozone for $35, and carefully swapped it out making sure to replace the new one in the exact same position as the old one i pulled out. truck started right up, no more noise. but now I am idling around 1300rpm. it will come back down eventually to around 900 when i am fully stopped at a red light, but stays up at 1500 if I am driving and coast in neutral. No check engine light or anything, I took it to a mechanic and the computer didnt give any codes or any indication anything was wrong. Went out of town this weekend and put 450 miles on it since changing the part, mechanic said this was ok and high idle would just cost me a little gas.

But now I'm back in town and want to get this sorted out and get my idle back down to the cool 900rpm she used to purr at. Is my timing off? Do i need to redo my camshaft sync positioning at TDC?
__________________
2000 Ford Ranger XLT v6 3.0 4x4 manual extended cab
Reply With Quote
  #2  
Old 02-21-2017, 01:20 PM
fithers fithers is offline
Learning to use the forums
 
Join Date: Feb 2017
Posts: 10
Default Re: Changed Cam sync/sensor, now high idle

old one


new one


didnt get the camera angles exactly right in the before and after but im 99% sure i put it back in in the same position
__________________
2000 Ford Ranger XLT v6 3.0 4x4 manual extended cab
Reply With Quote
  #3  
Old 02-21-2017, 07:19 PM
ranger*danger ranger*danger is offline
Semper Fi
 
Join Date: Jun 2012
Posts: 104
Default Re: Changed Cam sync/sensor, now high idle

Shouldn't hurt to redo it, and yes it should be at TDC on #1 on the exhaust stroke.


Sent from my iPhone using Tapatalk
__________________
99 XLT Super Cab 4.0 OHV - Manual - 4wd - Live Axle Conversion - Interior & Exterior LEDs - Mustang Dome
97 XLT Regular Cab 2.3 - Auto - 2wd (R.I.P)
Reply With Quote
Reply

Tags
cam synchro, high idle, vulcan

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cam sensor/cam sync fatdab 3.0 Vulcan Tech 4 05-07-2016 04:38 PM
Update:Cam Sync and Sensor Bob C. of Indiana General Ford Ranger Discussion 6 02-23-2013 11:25 AM
Cam Sync and Sensor Replacement gcextreme 3.0 Vulcan Tech 0 02-03-2013 12:06 PM
Help high idle!!!!!! Changed tps cleaned iac!!!!! Anthony96 3.0 Vulcan Tech 19 01-10-2013 08:38 PM
Code P0340 Cam Sync Sensor Ranger Blake 3.0 Vulcan Tech 3 08-02-2012 07:06 AM