Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Ford Ranger Semi-Technical > Interior Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 05-25-2010, 08:49 AM
Learning to use the forums
 
Join Date: May 2010
Posts: 9
Default Fan Speed Control only works on High?

Hey guys, Very cool site! I Just picked up a Red 1998 Ranger XLT 4x4. I have to say, It is a neat little truck! Body is pretty solid, no rust but underneath is scabby! I had to put brakes on it, everything seems to work but the fan speed control for the heat/AC, It only works on high speed. Does anyone know if it is a cheap fix???
Reply With Quote
  #2  
Old 05-26-2010, 06:05 AM
Learning to use the forums
 
Join Date: May 2010
Posts: 9
Default Re: Fan Speed Control only works on High?

Quote:
Originally Posted by 98Vermillion View Post
Hey guys, Very cool site! I Just picked up a Red 1998 Ranger XLT 4x4. I have to say, It is a neat little truck! Body is pretty solid, no rust but underneath is scabby! I had to put brakes on it, everything seems to work but the fan speed control for the heat/AC, It only works on high speed. Does anyone know if it is a cheap fix???
Any body have any ideas?????? How to make the fan speed controller work on all 4 speeds, It just works on high speed. Thanks!!
__________________
1998 Ranger XLT 4x4
1980 Malibu Show/Street driven/1/8 mi. Drag
1984 Cutlass Street/Soon to be Drag, Sons car
2000 Astro, Family cruiser, 3 kids/wife
1995 Lumina, Sons daily driver
Reply With Quote
  #3  
Old 05-26-2010, 04:35 PM
Some assembly required...
 
Join Date: Jun 2009
Posts: 886
Default Re: Fan Speed Control only works on High?

Look at the Blower Resistor and the connector going to it - held in by 2 screws next to the blower fan in the heater/AC plenum. Either the coils of the blower resistor have fractured or the connector to the resistor is corroded. If needed, you can pick up a new resistor for under $20 at the dealer or auto parts store.
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

Ford owners' manuals ONLINE, then click "Vehicle Basics"
Reply With Quote
  #4  
Old 12-15-2010, 10:51 AM
Liking the Ford Ranger Forum
 
Join Date: Sep 2010
Posts: 24
Default Re: Fan Speed Control only works on High?

I hate to dig this one back up again, but mine is doing the same thing. I was wondering if you found out what was wrong with it?
__________________
Tom

'99 4WD Stepside 3.0L Flex
142,000+ miles
Reply With Quote
  #5  
Old 12-15-2010, 11:03 AM
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Fan Speed Control only works on High?

Well, if you read the reply above yours, you will see the answer. It's a common failure.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #6  
Old 12-15-2010, 11:47 AM
Liking the Ford Ranger Forum
 
Join Date: Sep 2010
Posts: 24
Default Re: Fan Speed Control only works on High?

Quote:
Originally Posted by FireRanger View Post
Well, if you read the reply above yours, you will see the answer. It's a common failure.
Just wondered what the OP found out.
__________________
Tom

'99 4WD Stepside 3.0L Flex
142,000+ miles

Last edited by wvwirenut; 12-15-2010 at 12:21 PM.
Reply With Quote
  #7  
Old 12-15-2010, 12:33 PM
Tank Diver
 
Join Date: Mar 2010
Posts: 3,056
Default Re: Fan Speed Control only works on High?

Blower resistor, definitely. You might need a new pig tail too depending on the condition of the plug on your wiring harness. Mine was corroded and shorted out when I replaced mine.

I RTV'd the crap out of the back of the pig tail and used a lot of dielectric grease to prevent moisture in the resistor socket where the pig tail plugs in.
__________________
Sgtsandman's Work in Progress
2011 Ranger XLT, 4X4, 4 door Super Cab. 4.0L, 5 Speed M50D-R1HD, 3.73:1, 8.8" open differential, Jason Pace cap
1999 Honda CR-V EX, RT4WD, 2.0L, 5 Speed MT, 4.56:1, open differential
Reply With Quote
  #8  
Old 12-16-2010, 06:08 AM
Learning to use the forums
 
Join Date: May 2010
Posts: 9
Default Re: Fan Speed Control only works on High?

It was the resistor, I got a new one and then had to hit the local U PULL IT to get the plug and some of the wire harness, The plug was so coroded it just crumbled once I pryed it off. soldered on about 6 inchesd of new {used} wire harness, plugged her in and all is good!
__________________
1998 Ranger XLT 4x4
1980 Malibu Show/Street driven/1/8 mi. Drag
1984 Cutlass Street/Soon to be Drag, Sons car
2000 Astro, Family cruiser, 3 kids/wife
1995 Lumina, Sons daily driver
Reply With Quote
  #9  
Old 12-20-2010, 03:56 PM
Liking the Ford Ranger Forum
 
Join Date: Oct 2010
Posts: 20
Default Re: Fan Speed Control only works on High?

damn i need to do that i have that same exact problem in my 2000 but the thing is so corroded its impossible to take off without destroying it
__________________
2000 v6 3.0 Ford Ranger no modifications
Reply With Quote
  #10  
Old 12-20-2010, 03:58 PM
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Fan Speed Control only works on High?

Quote:
Originally Posted by brentroy View Post
damn i need to do that i have that same exact problem in my 2000 but the thing is so corroded its impossible to take off without destroying it
It's already destoryed. Just cut it off or pull harder. It's already toast, how can you make it worse? That's like people who don't do CPR because they're afraid they'll hurt the person. They're dead. You can't make them worse.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #11  
Old 12-20-2010, 05:30 PM
Liking the Ford Ranger Forum
 
Join Date: Oct 2010
Posts: 20
Default Re: Fan Speed Control only works on High?

thanks man but should i get a new wiring harness as well
__________________
2000 v6 3.0 Ford Ranger no modifications
Reply With Quote
  #12  
Old 12-20-2010, 06:12 PM
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Fan Speed Control only works on High?

The easiest thing to do is go to a junk yard and cut off the plug and a foot of wire from a good one. Then cut yours off and splice the new one in.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #13  
Old 12-21-2010, 08:11 AM
Tank Diver
 
Join Date: Mar 2010
Posts: 3,056
Default Re: Fan Speed Control only works on High?

That's what I did. Spliced in a new pig tail. The old one was beyond repair and the resistor was "welded" to the plug. I destroyed the resistor looking into this. If the plug won't come out, consider it toast and save yourself the trouble. If you don't feel comfortable with a junk yard plug, stealerships and auto parts stores sell new pig tails.
__________________
Sgtsandman's Work in Progress
2011 Ranger XLT, 4X4, 4 door Super Cab. 4.0L, 5 Speed M50D-R1HD, 3.73:1, 8.8" open differential, Jason Pace cap
1999 Honda CR-V EX, RT4WD, 2.0L, 5 Speed MT, 4.56:1, open differential
Reply With Quote
  #14  
Old 12-22-2010, 10:16 AM
Liking the Ford Ranger Forum
 
Join Date: Oct 2010
Posts: 20
Default Re: Fan Speed Control only works on High?

where is it located
__________________
2000 v6 3.0 Ford Ranger no modifications
Reply With Quote
  #15  
Old 12-24-2010, 11:22 AM
Liking the Ford Ranger Forum
 
Join Date: Oct 2010
Posts: 20
Default Re: Fan Speed Control only works on High?

so i fixed it but all i really did was replace the relay the other one looked fine but ya never kknow and i replaced the resistor and i really thiink it was the resistor sprayed wd40 on that and apply vasaline and wa la it works and this video helped too for future reference
__________________
2000 v6 3.0 Ford Ranger no modifications
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fan Speed-High Only redfish10 General Tech 10 09-16-2011 09:02 AM
Interior fan works on only low & high speed velozp 4-Cylinder Tech 3 03-04-2010 05:15 AM
fan control issue tubzilla Electrical Tech 2 08-21-2009 04:02 PM
Why an electric fan & clutch fan tychobrahe1911 4-Cylinder Tech 5 07-28-2009 01:47 PM
My ford Ranger 05 keeps making this high pitch noise when in high gear? rickymercer17 General Ford Ranger Discussion 1 12-08-2008 07:40 PM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.