Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #31  
Old 03-15-2012, 06:30 AM
tigerpb tigerpb is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 6
Cool Re: Fan Speed Control only works on High?

I'm only aware of the resistor pack in the engine compartment, screwed to the HVAC box. It's the same one in the posted video. This is the one that causes the lack of fan speeds. Replacing it cured my problem.

BTW, any one have any tips on loosening the clips like the one holding the pigtail to the resistor? I couldn't get it to move at all, and judging how tight the new parts went together I doubt I could get the new parts separated.

Last edited by tigerpb; 03-15-2012 at 06:32 AM.
Reply With Quote
  #32  
Old 10-08-2013, 12:22 PM
mustangsally227 mustangsally227 is offline
Learning to use the forums
 
Join Date: Oct 2013
Posts: 9
Default Re: Fan Speed Control only works on High?

Thanks for all the advice guys I figure I could give a little back. I've got a 99 B3000 3.0 4x2 that had the same issue high speed only on the A/C and my resistor bank connector corroded away. Well the options are as above you can buy a new resistor bank and plug ~$15 - $40 or if you look at your resistors they actually are perfectly fine only the metal contacts holding them in place as well as the plug are corroded. What I did was patch 4 cables directly to the resistor bank and spliced them into the wiring harness and bypassed the old plug.


It was pretty easy, you tap a hole in the plastic backplate to feed the wires through and just match up the leads to the resistors. Just need to remove some rust off the contacts to make the solder stick but she works like a charm now and it only cost me 4 pieces of wire and $2 bucks for a thermal fuse! Don't make that mistake when soldering, avoid overheating the fuse with your soldering iron =)




Thanks guys/gals!
Dave

Last edited by mustangsally227; 10-09-2013 at 06:04 AM. Reason: Pictures added
Reply With Quote
  #33  
Old 01-30-2014, 02:49 PM
GatorBaitR6 GatorBaitR6 is offline
Learning to use the forums
 
Join Date: Jan 2014
Posts: 2
Default Re: Fan Speed Control only works on High?

Thanks everyone... ranger forums is always my first stop with issues with my 4.0... only gotta fix the airbag light and no more issues.. for now.. thanks again everyone...
Reply With Quote
  #34  
Old 02-01-2014, 05:12 PM
Oscar313 Oscar313 is offline
Retired
 
Join Date: Jan 2014
Posts: 4
Default Re: Fan Speed Control only works on High?

I pulled the resistor today and found an old dried leaf caught up in it. It looked very clean and was not corroded at all, a surprise for 25 years old. I went ahead and replaced it because of its age. Sometimes the fan would not come on at all and then would run with no problem. Love to know how all the leaves and trash got in there.
__________________
Stock 1989 Ford Ranger 4x4, manual transmission and hubs. 2.9 V6.

Last edited by Oscar313; 02-01-2014 at 05:13 PM. Reason: additions
Reply With Quote
  #35  
Old 02-03-2014, 05:44 PM
GatorBaitR6 GatorBaitR6 is offline
Learning to use the forums
 
Join Date: Jan 2014
Posts: 2
Default Re: Fan Speed Control only works on High?

The wiring pigtail I got from autozone was colored unlike the youtube video but the orange and black wires were backwards... *******s almost pulled a fast one on me
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fan Speed-High Only redfish10 General Tech 10 09-16-2011 08:02 AM
Interior fan works on only low & high speed velozp 4-Cylinder Tech 3 03-04-2010 05:15 AM
fan control issue tubzilla Electrical Tech 2 08-21-2009 03:02 PM
Why an electric fan & clutch fan tychobrahe1911 4-Cylinder Tech 5 07-28-2009 12:47 PM
My ford Ranger 05 keeps making this high pitch noise when in high gear? rickymercer17 General Ford Ranger Discussion 1 12-08-2008 07:40 PM