Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #226  
Old 03-20-2012, 02:50 AM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default Re: How-To: OHC Install

Quote:
Originally Posted by Lalogga View Post
My ohc decided to start acting up a few days ago. Temp would only change at start up in the morning. Would not change throughout the day at all. Next day, different temp in the morning, but no changes during the day. Very weird.
This usuallly happens when the console does not have the Vehicle Speed Sensor input from the gray/black wire. The console freezes the temp reading while the vehicle is stopped to keep engine/radiator heat from causing false (high) readings. Without the VSS, the reading will be correct when initially started but fail to update.


Quote:
Originally Posted by Lalogga View Post
I'm still having issues with my temp reading 30 degrees cooler. Tried another OHC and same issue...anyone?
You are using the EATC (climate control) temp sensor which looks similar but has the wrong impedance. Swap in an overhead console sensor and it should be good. The Explorer harness color codes for the correct sensor are blue/white and blue/yellow.
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid

Last edited by rwenzing; 03-20-2012 at 03:01 AM.
Reply With Quote
  #227  
Old 03-20-2012, 01:27 PM
Lalogga Lalogga is offline
Old Skool
 
Join Date: Jan 2012
Posts: 178
Default Re: How-To: OHC Install

Quote:
Originally Posted by rwenzing View Post
This usuallly happens when the console does not have the Vehicle Speed Sensor input from the gray/black wire. The console freezes the temp reading while the vehicle is stopped to keep engine/radiator heat from causing false (high) readings. Without the VSS, the reading will be correct when initially started but fail to update.


You are using the EATC (climate control) temp sensor which looks similar but has the wrong impedance. Swap in an overhead console sensor and it should be good. The Explorer harness color codes for the correct sensor are blue/white and blue/yellow.
You are correct...the vehicle speed sensor wire must not have been making a good connection. I rewired it to the gem modue and it works. Sensor is ok...I have 2 just in case. Appreciate your help...thanks.
__________________
1998 2.5 Ranger XLT 2wd...with a cap
Reply With Quote
  #228  
Old 03-26-2012, 12:39 PM
RangerEdgeWhite RangerEdgeWhite is offline
Ford Ranger Driver
 
Join Date: Apr 2011
Posts: 1,720
Default

Should the console still turn on with out the black and gray wire?
__________________
2003 Ranger Edge ... crashed

2011 sport 4x4 with a little modification
Reply With Quote
  #229  
Old 03-26-2012, 01:31 PM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default Re: How-To: OHC Install

Quote:
Originally Posted by RangerEdgeWhite View Post
Should the console still turn on with out the black and gray wire?
Yes. The gray/black only affects updating of the temperature display value.
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
  #230  
Old 03-26-2012, 02:00 PM
RangerEdgeWhite RangerEdgeWhite is offline
Ford Ranger Driver
 
Join Date: Apr 2011
Posts: 1,720
Default

Oh because my screen won't light up and I've replaced overhead console but could it be the harness? I've checked all the connections and they seemed fine
__________________
2003 Ranger Edge ... crashed

2011 sport 4x4 with a little modification
Reply With Quote
  #231  
Old 03-26-2012, 04:25 PM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default Re: How-To: OHC Install

It is fairly common for the console to have cracked solder connections on the PC board. That can kill the display. If you're good with a soldering iron, it is not hard to fix.

http://www.explorerforum.com/forums/...d.php?t=187953
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
  #232  
Old 03-31-2012, 07:04 PM
huskerman16 huskerman16 is offline
DFWM
 
Join Date: Apr 2011
Posts: 522
Default Re: How-To: OHC Install

my digital readout of temp and direction doesnt come on anymore any ideas? the lights still come on but the other doesnt let me no guys!!
__________________
2000 Ford Ranger Sport 4.0 4x4
Custom Black Body Lines
Nice Little Sound System
Light Bar Bull Bar 4 Hella 500's
Lots Of Mods Coming Stay Tuned
Reply With Quote
  #233  
Old 03-31-2012, 07:31 PM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default Re: How-To: OHC Install

Check the link in the post before yours.
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
  #234  
Old 04-01-2012, 11:35 AM
RagerTom RagerTom is offline
Ford Ranger Driver
 
Join Date: Oct 2011
Posts: 4,177
Default Re: How-To: OHC Install

ok guys...... Finally got my ohc mounted and now ready to wire up. I don't have a temp sensor so just planned on wiring up the lights only for now........ My harness on the ohc has one white wire and..........7 black wires................

Was i supposed to cut the other end of the harness that plugs into the one i have? I can figure this out for the lights but what if i want to hook up the temp display later.... How will i figure out which wire is which?

Any ideas?
__________________
Not a F150 sellout? Click HERE

Quote:
Originally Posted by robertmcclure View Post
adamantium tamponicus!
Reply With Quote
  #235  
Old 04-01-2012, 02:01 PM
Lalogga Lalogga is offline
Old Skool
 
Join Date: Jan 2012
Posts: 178
Default Re: How-To: OHC Install

Quote:
Originally Posted by RagerTom View Post
ok guys...... Finally got my ohc mounted and now ready to wire up. I don't have a temp sensor so just planned on wiring up the lights only for now........ My harness on the ohc has one white wire and..........7 black wires................

Was i supposed to cut the other end of the harness that plugs into the one i have? I can figure this out for the lights but what if i want to hook up the temp display later.... How will i figure out which wire is which?

Any ideas?
Yes...you needed to cut the other end of the harness...those wires are color coded for the install instructions posted here.
__________________
1998 2.5 Ranger XLT 2wd...with a cap
Reply With Quote
  #236  
Old 04-01-2012, 03:14 PM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default Re: How-To: OHC Install

Quote:
Originally Posted by RagerTom View Post
My harness on the ohc has one white wire and..........7 black wires................

How will i figure out which wire is which?

Any ideas?
It is much easier to use the color coded pigtail cut from the Explorer harness. If you are stuck without one, all is not lost.

Here's my post from a few years ago:

Quote:
Originally Posted by rwenzing
OK ...... I just went out and dissected my truck.

Here are the color codes and destinations for the Explorer Overhead Console. This would be useful for consoles that are missing the matching pigtail or those that have had the plug cut off. (Note: this wiring info applies to an Explorer console that does NOT have the sunroof switch. The sunroof style console wiring MAY be the same but I don't have one here to look at.)

~~~~~~~~

Look at the back of the 2 map light switches. Each has a WHITE and a BLACK wire. These color-matching pairs are spliced together and originally went to the plug connector.

The spliced together WHITE pair gets tapped into the BLACK/LIGHT BLUE hot wire of your trucks dome light (same CC Ranger & Explorer).

The spliced together BLACK pair gets tapped into the LIGHT GREEN/ORANGE wire of your trucks map light (same CC Ranger & Explorer). (NOTE: This LIGHT GREEN/ORANGE wire does not exist above the headliner on 2004+ Rangers and would need to be added)

~~~~~~~~

You will see a BLACK wire coming from the MODE switch. It is spliced together with the #2 wire from the microprocessor. This spliced together pair of wires goes to chassis ground.

~~~~~~~~

Look at the back (hidden side) of the console with the microprocessor positioned at the top. You will see 6 wires arranged crosswise above the microprocessor. In the Wiring Manual these are numbered 1 through 6, starting from the right to the left.

like this--> 6-5-4-3-2-1

#1 GRAY/YELLOW to 12V hot in RUN or RUN/ACC (Explorer Color Code)
#2 BLACK (again, spliced with black wire from MODE switch) to chassis ground (Explorer CC)
#3 GRAY/BLACK tapped to VSS wire on GEM, some models without GEM can tap into the GY/BK at the PCM (same CC Ranger & Explorer)
#4 LIGHT BLUE/RED or RED/BLACK tapped to instrumentation illumination (most Rangers use LIGHT BLUE/RED)
#5 DARK BLUE/YELLOW to outside temp sensor (Explorer CC, does not wire directly to Ranger harness)
#6 DARK BLUE/WHITE to outside temp sensor (Explorer CC, does not wire directly to Ranger harness)

Put this info together with a good set of installation instructions and you should be able to overcome being connectorless.


Installation and wiring instructions:
http://www.cardomain.com/ride/296394/3
http://www.cardomain.com/ride/296394/4
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
  #237  
Old 04-08-2012, 09:55 PM
KyBucks10 KyBucks10 is offline
"That's what" -She
 
Join Date: Mar 2012
Posts: 366
Default Re: How-To: OHC Install

Alright fellas. I spent the last 45 minutes reading through this thread trying to figure out the answers to my question. I saw my question a few times, but I didn't really get a great answer. I got my OHC mounted, and wired up tonight. I ran all the wires to where they need to go (I think???) but my display is not coming on. This is where I ran all of my wires:

Black-Grounded to bracket
Green/Orange-Dome
Black/Blue-Dome
Blue/Red-Blue/Red on wiring harness going in the radio
Yellow/Gray-Yellow/Gray on wiring harness going in the radio
Blue/Yellow-Sensor
Blue/White-Sensor
Black/Gray-I did not run this wire. I saw other instructions saying its not necessary to run this, but after reading this thread, I want to run it now so my temp is correct at all times.

Now, does anyone know what my problem could be? Did I hook everything up right? I used the tap connectors behind the radio, and in the dome light. My lights on my OHC come on with the door, and if I hit the "Lamp" switches. My display is the only thing that does not work. I'm sure that someone will have answers for me that will be obvious, but I am stumped right now.

If it matters, I got the OHC out of a 96 (I'm pretty sure thats the right year...) Explorer, and my truck is a 95 Ranger XLT regular cab.

Thanks for any help!!
__________________
2002 Ford Ranger 2.3 I4 Engine Stock Transmission Regular Cab Short Bed

1995 Ford Ranger XLT 2.3 I4 Engine Stock Transmission Regular Cab Short Bed
RIP Thread

How To Fix Your Odometer
Reply With Quote
  #238  
Old 04-09-2012, 05:37 AM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default Re: How-To: OHC Install

Display:

If you are sure that all of the new wiring is sound, then the problem could be a poor solder connection on the PC board. This a not an uncommon problem with these consoles.

I posted this link earlier in this thread for the display fix:
Quote:
Originally Posted by rwenzing View Post
It is fairly common for the console to have cracked solder connections on the PC board. That can kill the display. If you're good with a soldering iron, it is not hard to fix.

http://www.explorerforum.com/forums/...d.php?t=187953


VSS:

The gray/black can and should be tied into the truck's gray/black. In a 95~97, this wire can be found at several places. The easiest for this mod is probably at the GEM module connector near the center of the dash.
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
  #239  
Old 04-09-2012, 07:32 AM
KyBucks10 KyBucks10 is offline
"That's what" -She
 
Join Date: Mar 2012
Posts: 366
Default Re: How-To: OHC Install

Quote:
Originally Posted by rwenzing View Post
Display:
VSS:

The gray/black can and should be tied into the truck's gray/black. In a 95~97, this wire can be found at several places. The easiest for this mod is probably at the GEM module connector near the center of the dash.
Where else can it go other than the GEM?
__________________
2002 Ford Ranger 2.3 I4 Engine Stock Transmission Regular Cab Short Bed

1995 Ford Ranger XLT 2.3 I4 Engine Stock Transmission Regular Cab Short Bed
RIP Thread

How To Fix Your Odometer
Reply With Quote
  #240  
Old 04-09-2012, 09:50 AM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default Re: How-To: OHC Install

Instrument cluster, PCM, transmission, cruise module under the hood. If you want to pick through the large bundle of wires near the parking brake pedal, it is also there. All are gray/black color code.
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to: Install new carpet Korey How-To Submissions 7 01-16-2012 02:45 PM
Discuss How To: Jet Chip Install 02'4.04x4 How-To Submissions 11 07-01-2011 06:44 PM
'04 3.0 install new battery g-ann General Ford Ranger Discussion 4 11-03-2009 07:44 PM
How-To: OHC Install mossyoak03 Interior Guides 0 09-23-2009 08:09 AM
How to: Install new carpet Korey Interior Guides 0 09-23-2009 08:05 AM