Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 03-19-2010, 07:56 PM
stargazer stargazer is offline
Learning to use the forums
Join Date: Mar 2010
Posts: 1
Question 99 XLT 2.5L - fuel pump or ??????

Hi Folks...

I have been scratching my head for a few months on this one. With key on...hear clicks of PCM and fuel pump relays...but no fuel pump hum. After several key on attempts (more in cold weather it seems) pump will fire up and truck runs fine. Thought when battery tested marginal that was the problem...but no luck. Replaced fuel pump relay as it was only $10...still no luck. Also replaced fuel filter (which did improve smoothness but not my problem). Measured sawtooth type rise to 12v at IFS and even jumpered dk grn/yel to pnk/blk ... still shows same behavior AT START. The thing I am second guessing is once the pump does fire up and engine starts...RUNS GREAT!!! I would think if it was fuel pump that some issues would be observed during running if it is behaving this way at startup. NO check engine light either.

I am not against replacing the pump BUT I am having trouble believing it will make a difference due to no issues observed during running state...ONLY at start does fuel pump exhibit this intermittent behavior. Anyone experience this in their truck ?
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel Sensor...Fuel Pump...???? vang0017 4.0 SOHC / 4.0 OHV Tech 23 10-26-2015 11:58 AM
Is the fuel pump in my '86 two wheel ranger an in-line pump? Josh C General Tech 3 07-09-2012 09:20 AM
fuel pump? isaact 3.0 Vulcan Tech 9 02-28-2011 03:51 PM
Fuel Pump AlphaRanger General Tech 9 03-05-2010 10:56 AM
FUEL PUMP??? MAYBE? Johnny Larue 4.0 SOHC / 4.0 OHV Tech 1 02-04-2010 12:05 PM