Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 03-16-2010, 03:59 PM
95ranger99 95ranger99 is offline
Learning to use the forums
Join Date: Mar 2010
Posts: 1
Default Problems w/fuel pump fuse ?

First off i would like to say hi to everyone,as i am new here .

My problem is when i turn the ignition over ,i am blowing the fuel pump fuse.

Anybody know what can be the cause ?
Reply With Quote
Old 05-15-2010, 10:50 AM
IPBprez IPBprez is offline
Join Date: May 2010
Posts: 16
Send a message via AIM to IPBprez
Default Re: Problems w/fuel pump fuse ?

Hello - I am new here, as well.

Not sure if my problem is similar or not. Have you taken it to a Computer readout machine? It may be there is an issue in the Computer control center.

My problem is that it will start, but then dies almost immediately.
Then, it won't start at all for almost 30 minutes (sometimes less or more)
After that, it just suddenly starts and runs flawlessly until the next time I try to use it.

- I've changed the Fuel pump (1st thing) - easy enuf, just pull the box off the back
- I've added two new Coils ($50/ea) on top of the engine - 8 spark plugs / 2.3 4cyl Engine
- eventually had the timing chain changed (180K miles), along with two sensors on back of engine
- truck ran fine for about 6 weeks, with only an occasional die-ing in traffic, only to start right back up
- I'm into this nonsense now for about $1,000.00 on this issue (still luv the truck)

The issue is - once it starts, I have no troubles - it runs as if there's nothing wrong
EVERYONE says - it's the fuel pump and you can buy pump after pump and they could all be bad
I say - bull$hit - the fuel filter and the fuel control valve on top of the engine are also brand new
It never loses so much juice that I need a jump to get it home

Starter, etc., all seem fine --- it's just not getting spark.....??
Or, it's losing pressure along the fuel line somewhere and gets an air bubble ???


As far as blowing fuses - that's totally electrical and could be your computer command module

But, my issue might be along the same lines, except when it starts, it never dies off on me
Either it starts and immediately dies or it doesn't start at all
If it does start, I can't seem to trust if I'll get back home safely - it's hit or miss

Anything? Anyone ??
Reply With Quote
Old 05-15-2010, 02:27 PM
mickblock mickblock is offline
Get off my lawn
Join Date: Apr 2010
Posts: 1,059
Default Re: Problems w/fuel pump fuse ?

Start testing that wire loom for damage/shorts gentlmen! These are intermittant probems right? Get a scan tool hooked up and you can still see intermitant failures as pending codes even if youre' running good at the moment. Unless you've gone through I think 40 (?) run cycles without problems. Then ya gotta wait.
08 4.0 Sport 4x4
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel Sensor...Fuel Pump...???? vang0017 4.0 SOHC / 4.0 OHV Tech 23 10-26-2015 11:58 AM
Is the fuel pump in my '86 two wheel ranger an in-line pump? Josh C General Tech 3 07-09-2012 09:20 AM
Having problems with fuel pump, i think RAIDER_1 4-Cylinder Tech 3 09-24-2009 03:58 PM
91 2.3l fuel pump problems heather.18 4-Cylinder Tech 2 09-19-2009 11:56 AM
starting problems after installing new fuel pump BONE Introduce Yourself 0 06-24-2009 02:25 AM