Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Ford Ranger Forum - Forums for Ford Ranger enthusiasts! (http://www.fordrangerforum.com/)
-   General Tech (http://www.fordrangerforum.com/general-tech/)
-   -   94 ranger no cel or fuel (http://www.fordrangerforum.com/general-tech/74283-94-ranger-no-check-engine-light-fuel.html)

eureka77 10-10-2012 08:21 PM

94 ranger no cel or fuel
 
1st hello everybody. My name is Anthony, long time lurker, 1st time poster:D: Will put the short and sweet on the bottom. Vehicle is a 1994 ford ranger xlt. ext. cab, 5spd., with 4.0L non-cal.{non-egr}
Driving along 1 day truck started acting like it was running out of gas. Made it to the side of the road and it died. Restarted briefly then died again. Couldn't hear the fuel pump whine so I assumed that was the problem. Had it towed home and the next day replaced the fuel pump, relay, and inertia switch. Still nothing. I can ground out the pump and the fuel system works fine. Noticed that I had no CEL. This was my problem all along.
Replaced ALL fuses and relays in the PDB., even bought a new eec[pcm]. NOTHING! cranks but won't start. no fuel and still no cel.
I verified power once I turn the key on from ignition switch to the power diode to the relay and pcm fuse. Unplugged the harness from the eec and am getting 12 volts at both red wires and the yellow wire.
So the correct power is going into the eec but it still isnt powering up.
What do I look for fellas? really need this on the road. Where are the grounds?
If I left anything out please just ask. Read ALOT of posts with this very problem but no one comes back and posts the fix. Those who have I've tried already.

*** NO CEL, no power to eec, therfore no fuel.***
Replaced all fuses and relays in the PDB.. New eec[pcm]. fuel pump, inertia switch new.

06RangerXLT 10-10-2012 08:27 PM

Re: 94 ranger no cel or fuel
 
in all honesty if you ground the pump and it works, just run a new ground. Easy fix that wont take a year to find.

Stinkbaitj 10-10-2012 08:30 PM

Quote:

Originally Posted by 06RangerXLT
in all honesty if you ground the pump and it works, just run a new ground. Easy fix that wont take a year to find.

X2

You have a corroded ground wire somewhere. Running a new one is your best option.

--1993 ford ranger ext cab 3.0 v6--

eureka77 10-10-2012 08:32 PM

Re: 94 ranger no cel or fuel
 
If my eec isnt powering up though, then I'm probably not getting any spark aswell?

Stinkbaitj 10-10-2012 08:35 PM

Quote:

Originally Posted by eureka77
If my eec isnt powering up though, then I'm probably not getting any spark aswell?

Not sure. If a memeber named Fireranger doesn't pop in here, pm him and ask him.

Also ask buggman and see if he knows.

--1993 ford ranger ext cab 3.0 v6--

eureka77 10-10-2012 08:36 PM

Re: 94 ranger no cel or fuel
 
Thanks bud.

06RangerXLT 10-10-2012 08:36 PM

Re: 94 ranger no cel or fuel
 
well pull a plug and hold it to the block while you crank. if you have no spark you have a bad crank sensor or coil.

or a bad PCM

eureka77 10-10-2012 08:38 PM

Re: 94 ranger no cel or fuel
 
Already have a new pcm.

eureka77 10-11-2012 07:06 AM

Re: 94 ranger no cel or fuel
 
Anybody? The dude above didnt even read the post or doesnt know what hes talking about.
THE PROBLEM IS EEC IS NOT POWERING UP.

FireRanger 10-11-2012 10:21 AM

Re: 94 ranger no cel or fuel
 
If you have power to the ECC and it doesn't work, I would suspect the ECC is shot? I'm not familiar everything that is wired to it, so for all I know there is something else disconnected. You could grab an ECC from a junk yard truck and see if it works.

eureka77 10-11-2012 10:52 AM

Re: 94 ranger no cel or fuel
 
thanks man. I thought the same thing so bought a new eec. what are the odds the new 1 is defective too?

FireRanger 10-11-2012 11:03 AM

Re: 94 ranger no cel or fuel
 
Oh I didn't notice that you already tried that. The chances of the original one being bad is slim. The chances of the original and the new one being bad are even slimmer.

Something is still disconnected, or a fuse is still popped.

eureka77 10-11-2012 11:35 AM

Re: 94 ranger no cel or fuel
 
Man what a time to quit smoking. I made an ******* post but it dissapeared thank goodness. Have 12volts at #1, #37, #57. Power is getting to the eec.
Also have good ground at #40, & #60. so the eec grounds are good.
I guess my last question on this and from bugging yall is can a bad sensor cause the eec from powering up? Say a tps or any of the other ones?

FireRanger 10-11-2012 01:33 PM

Re: 94 ranger no cel or fuel
 
Unlikely. Why do you think the ECC is not powering up... besides the fuel pump not running.

eureka77 10-11-2012 02:07 PM

Re: 94 ranger no cel or fuel
 
I have no CEL at KOEO.
Before I replaced the eec with a remanufatured one from autozone, Every 15 to 20 time of turning the key off and on the CEL would come on and I'd hear the fuel pump run, all normal etc.. But the next cycle of key on/off it would dissapear again. So it's not a burned out CEL bulb. Everything pointed to the eec. Maybe the reman. one from autozone is bad too?


All times are GMT -7. The time now is 08:52 AM.

Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.