Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-01-2012, 08:49 AM
Range829 Range829 is offline
Learning to use the forums
 
Join Date: Aug 2010
Posts: 5
Exclamation Problem with 97 Ford Ranger 2.3 Manual Please help!!!

OK so first I have a 97 ford ranger 2.3L Manual

I Changed the timing belt and fan belt a week ago.
Did it successfully. Put everything back together correct 100% positive had it checked 4 times Timing was on the dot perfect, all 3 points.
Then when i was done the check engine light came on saying the Cam sensor wasn't working. Checked by a scanner several times tried clearing the code but always came back after the truck was started up the second time.
So i replaced the sensor cleaned the connector made sure no oil or dirt was in it put it back together the code was still pending and the check engine light still came on and that did not solve the problem still said the cam sensor wasn't working. So just for the heck of it i replaced the crank sensor that did not correct the problem.
so light is still on
For some reason when i tested the wires for the cam sensor to see if any power was going through them the reading was 0.12Volts and i believe its supposed to read 5.12Volts for that sensor. Im not sure if thats my problem or how to correct that if it is.

If anyone has gone through this any help would be awesome!


Again
Timing is on key.
Everything is plugged in right
checked wires around see if any pulled out
changed sensors
checked all fuses
The code comes up i think if i remember the code is MO FFFF it says cam sensor but i think thats the code that comes up too..

Thanks guys for help.

Last edited by Range829; 08-01-2012 at 09:26 AM.
Reply With Quote
Reply

Tags
electric problems, ford ranger 2.3 5 speed, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
1998 Ranger 2.5L Manual Trans Shifting Problem cole2kb 4-Cylinder Tech 10 10-08-2011 09:18 AM
Ranger 98 2.5l manual transmision problem. Wujek Drivetrain Tech 2 03-23-2011 11:07 AM
Manual shifter problem - 87 Ranger desertOwl Drivetrain Tech 1 12-22-2010 03:20 PM
92 ranger 4x4 manual tranny clutch problem socaltrash714 Drivetrain Tech 4 01-17-2010 11:30 AM
ford ranger 1991 problem with manual ? GREGGER General Ford Ranger Discussion 1 12-25-2008 04:55 PM