Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-25-2010, 12:19 AM
utahpredator_7 utahpredator_7 is offline
Like the Forums
 
Join Date: Dec 2009
Posts: 31
Default Gas tank not filling properly, heater won't always turn on.

My gas tank in my '88 ranger leaked from around the locking ring badly when I got it. There was no gasket there so I put a cork one in. Leak fixed. Now it won't fill up right... It will go up to about 3/8 of a tank and then it takes forever to get it up even to 1/2 tank. It didn't have this problem before. The filler hose isn't kinked or anything. Any vents that may be clogged or anything?
Next question: My heater works sometimes, and blows hot air when it does (plenty of coolant) Any idea why it won't turn on every time?
Thanks in advance for info.
__________________
1988 Ford Ranger
2.9L V6, 5 spd. Manual (220,000 Miles)
2" Lift
Reply With Quote
  #2  
Old 01-25-2010, 02:07 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

what do you mean heat works sometimes. Do you mean the blower fan works sometimes?
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #3  
Old 01-25-2010, 02:19 PM
utahpredator_7 utahpredator_7 is offline
Like the Forums
 
Join Date: Dec 2009
Posts: 31
Default

Right. It doesn't usually blow, but occasionally it does come on.
__________________
1988 Ford Ranger
2.9L V6, 5 spd. Manual (220,000 Miles)
2" Lift
Reply With Quote
  #4  
Old 01-25-2010, 02:24 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

I think in your year truck you have a combination switch/relay. it is probably that, but could also be a lose wire. you could just replace the switch($10-30) and hope you get lucky or else start poking around with a tester looking for power. I think you also have a resister but I think that just controls the speed of the fan, lets see what some other peeps suggest
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #5  
Old 02-01-2010, 09:14 AM
utahpredator_7 utahpredator_7 is offline
Like the Forums
 
Join Date: Dec 2009
Posts: 31
Default

If it helps any this morning it wouldn't come on. I slammed the vent lever back and forth a few times and got the blower to come on. This works sometimes.
__________________
1988 Ford Ranger
2.9L V6, 5 spd. Manual (220,000 Miles)
2" Lift
Reply With Quote
  #6  
Old 02-03-2010, 11:18 AM
Yrac Yrac is offline
diMwit
 
Join Date: May 2009
Posts: 341
Default

Gas tank sounds like a vent problem, fan sounds like a short. Take a look at your switch first.
__________________
'88 STX Super Cab 4x4
2.9 5spd 180,000 miles
Crappy Paint, Worn Parts,
Fix'em as they Break
when Nowhere is Now Here
Reply With Quote
  #7  
Old 02-03-2010, 11:37 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

i agree the tank issue sounds like a vennt problem. onmy 99 i have a filler hose that is about 2" and a vent hose that is about 1". on the fan issue a Digital Multimeter is your friend( harbor freight sells them for as low as $8)
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #8  
Old 02-08-2010, 09:32 AM
utahpredator_7 utahpredator_7 is offline
Like the Forums
 
Join Date: Dec 2009
Posts: 31
Default

Fixed the gas tank. The little hose on the inside wasn't hooked up right. Then I broke one of the fittings putting the tank back on... they are heck to find!
__________________
1988 Ford Ranger
2.9L V6, 5 spd. Manual (220,000 Miles)
2" Lift
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Overflow tank is bubbling yet engine is not overheating? Please Help. jennifer1207 General Tech 26 04-02-2013 04:05 PM
How big is my gas tank? smurphy General Tech 13 01-18-2010 06:15 PM
gas tank problems...I think corto General Tech 0 10-26-2009 10:10 AM
my 88 dies when i only have half a tank mrdadeink 2.9 Liter Tech 31 09-24-2009 11:20 AM
hard to put fuel in tank slomoto 3.0 Vulcan Tech 1 06-12-2009 03:22 PM