Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 01-25-2010, 08:37 AM
4.0fan 4.0fan is offline
Like the Forums
Join Date: Jan 2010
Posts: 44

My 95 3.0L showed the same codes. one of my fuel injectors was dirty. so it was getting clogged and not producing enough fuel so the 02 sensors showed to lean. i put a new injector in and it was fixed. ti check which one it was i just found which cylinder was missing. while its running individually pull a wire off of a plug and if the truck runs more rough then that cylinder is running. when you come across one that it doesnt change when you pull a wire then you know that that cylinder is not firing. make sure your plugs are correctly gapped and that your wires are good. most likely your injector.
Reply With Quote
Old 01-28-2010, 04:18 PM
cliftonfts cliftonfts is offline
Learning to use the forums
Join Date: Jan 2010
Posts: 8

Originally Posted by Jp7 View Post
you just wasted your money!
Your right Jp7; I'm just wasting my money.
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
P0171 Code nrsoccer08 4.0 SOHC / 4.0 OHV Tech 8 02-01-2010 12:30 PM
Want to Buy: parts for a 1999 ford ranger talkington Trucks 0 12-16-2009 08:58 PM
For Sale: 1999 Ford Ranger 4x4 Reg Cab Jon4x4 Trucks 0 11-22-2009 12:21 PM
1999 Ford Ranger brakes? Ford Man General Ford Ranger Discussion 3 09-17-2009 11:31 AM
On a 1999 Ford Ranger what is the XLT part? blr8t2 General Ford Ranger Discussion 1 12-22-2008 03:37 PM