Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Ford Ranger Technical > General Tech
Forgot Password? Join Us!


View Poll Results: AM I EVER GOING TO BE WARM??
yes 1 100.00%
no 0 0%
Voters: 1. You may not vote on this poll

Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 11-18-2011, 01:34 AM
Learning to use the forums
 
Join Date: Nov 2011
Posts: 3
Default 94 Ranger NO HEAT TEMP Gauge always on COLD!

ive had this truck for 5 years now and it has never blew hot (or even luke warm) air nor has the tempature gauge moved into the "normal" area. My brother in law is a "mechanic" in his free time and we have taken many measure to fix this but none have worked. in the last 2 months i have put a new water pump in.. a new T-stat.. flushed my core using the garden hose method and even verified that both hoses from the core are HOTT! im at witts end trying to figure this out. Summer time the gauge will almost get into the normal but in the winter it barley moves from the dead spot. NEVER have i overheated..any ideas..?

Sincerely
--VERY COLD FOR 5+ YEARS IN NORTHERN OHIO

----------

anti-freeze level is good as well and im fairly certain theres not air in the lines..like i said its been the same problem for 5 years and has never changed even a little with regards to anything we changed..
__________________
1994 Ford Ranger 2.3 L 2WD
Reply With Quote
  #2  
Old 11-18-2011, 03:18 AM
Mr. One Fitty
 
Join Date: Apr 2011
Posts: 17,222
Send a message via AIM to djfllmn
Default Re: 94 Ranger NO HEAT TEMP Gauge always on COLD!

search!
NO HEAT Troubleshooting Guide
__________________
2014 F150 Supercrew XLT 5.0(ALL the options)
1968 Ford Thunderbird Tudor 429 Thunderjet V8

(Click for Project Log)
DD-1992 Olds Cutlass Ciera
traded-2007 F150 XLT Supercab 5.4
Sold:03 Sonic Blue FX4 Steppie 4.0SOHC 5spd

Quote:
Originally Posted by Logan03CO View Post
These threads make me feel better about myself....
Quote:
Originally Posted by guell View Post
Welcome to the internet, if this is your first visit to it I suggest you stock up on a lot of preparation h cause you gonna be butt hurt a lot
Reply With Quote
  #3  
Old 11-29-2011, 02:26 AM
Learning to use the forums
 
Join Date: Nov 2011
Posts: 3
Default Re: 94 Ranger NO HEAT TEMP Gauge always on COLD!

weve pretty much tackled everything on that chart IE new water pump, themostate flushed radiator and back flushed heater core. thing that gets me is ive read so many posts over and over again about "No heat in ranger and temp. gauge dont leave cold" that i almost have to believe they are connected. but i have yet to see a good answer to that question..

----------

is there any chance replacing the radiator cap could help?
__________________
1994 Ford Ranger 2.3 L 2WD
Reply With Quote
  #4  
Old 11-29-2011, 04:23 AM
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: 94 Ranger NO HEAT TEMP Gauge always on COLD!

No.

Replacing something doesn't mean it is working. Do you have that 4-port hot water valve pictured in my troubleshooting guide? If so, you you verify it is open to the heat position?
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #5  
Old 11-29-2011, 10:26 PM
Learning to use the forums
 
Join Date: Nov 2011
Posts: 3
Default Re: 94 Ranger NO HEAT TEMP Gauge always on COLD!

to be honest im not sure what you mean by the 4 port.. i just have my 2 hoses (from water pump and from engine) going into the firewall. dumb qeustion i thought of.. which side should the water pump be hooked up to the passenger side inlet or the driver side inlet? is it possible someone has these hoses on backwards?"
__________________
1994 Ford Ranger 2.3 L 2WD
Reply With Quote
  #6  
Old 01-24-2013, 11:44 PM
Learning to use the forums
 
Join Date: Jan 2013
Posts: 1
Default Re: 94 Ranger NO HEAT TEMP Gauge always on COLD!

To me it sounds like you have a Simple Air bubble in the houses that is preventing your thermostat from opening properly cause if both hoses are hot to the touch it sounds like its working just an air bubble that needs to be flushed out
Reply With Quote
Reply

Tags
94 ford, 94 ranger, no heat, ranger, temp gauge

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
2.5l temp gauge not working at all-little heat Mystervaughn 4-Cylinder Tech 7 03-05-2011 10:03 AM
temp gauge always on cold never goes above a 1/4 huffa12 3.0 Vulcan Tech 7 01-02-2011 06:56 PM
Temp gauge not moving off cold jdavenport4329 3.0 Vulcan Tech 0 09-15-2010 04:32 PM
New Problem Temp Gauge 99 ranger 4.0 opus007 4.0 SOHC / 4.0 OHV Tech 2 03-17-2010 12:20 PM
Temp. Gauge running on the cold side.. teamFORD414 General Tech 4 02-18-2010 04:26 AM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.