Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 06-05-2011, 04:17 PM
94rangerdanger 94rangerdanger is offline
Learning to use the forums
 
Join Date: May 2011
Posts: 4
Default i cant find the problem

My 94 ranger has been shutin off on me or not startin, I replaced the battery, terminals, alt, ignition coils, plugs and wires, and checked all the grounds and jus can't figure out the problem. Has anyone ever had this prob. I will run fine for weeks then jus start doin this again. Could it be the fuel pump relay or the filter.
Reply With Quote
  #2  
Old 06-05-2011, 04:28 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: i cant find the problem

Symptoms don't fit the fuel filter. The problem wouldn't come and go, though it's a cheap and easy replacement anyway.

Yes it could easily be the fuel pump or the fuel pump relay. When this happening, listen close and see if you can hear the fuel pump run when you turn the key on. If it isn't, swap the relay with one of the others and see if that fixes it. Sounds like you've replaced everything else anyway.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Overheating - can't find problem Brock1385 3.0 Vulcan Tech 23 12-29-2012 01:49 PM
Rough starting problem as well as high/low idle problem Ins4nity 4-Cylinder Tech 7 02-16-2011 06:10 AM
Help me find another one like this! DieHard4rd Off Topic 6 01-20-2011 06:27 PM
What part is this? (pic) Blower problem, this the problem? stuck on vent! Chargerondavins General Tech 2 10-02-2010 09:46 AM
still tring 2 find problem Rob Electrical Tech 3 12-20-2009 09:35 AM