Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-18-2011, 07:06 PM
Searcherwolfe Searcherwolfe is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 9
Default stops running at 4 to 6 miles

87 ranger with 2.3 stops running after 4 and 6 miles - runs perfect to that point - no indication of problem before she quits - computer self tests - engine cranks good - timing dead on - new components - distributor, coil, control module, pickup, trans sender, fuel and ecm relay, ECM, temp sensor - high pressure pump - MAP. When it quits it can be 5 hrs before restart - it then runs a little rough like the computer is off time for about a mile and the smooths out. 6 months ago it would shut off and turning the key on and off would restart - got progressively worse - not throwing ANY codes. Truck has 358k Suggestions please.
Andy

Last edited by Searcherwolfe; 05-18-2011 at 07:09 PM.
Reply With Quote
  #2  
Old 05-18-2011, 08:08 PM
OhioMike OhioMike is offline
Ford Ranger Driver
 
Join Date: Dec 2010
Posts: 2,761
Default Re: stops running at 4 to 6 miles

As weird as it sounds, something may be in the tank like a small piece of paper. I know someone (who had a Ranger), and a very small piece of paper, like when you fold over the top corner of a book to keep your place, was found. How it got there was another story -- noone knows. Also, I work for FedEx, and it happened to one of our guys' trucks that kept randomly stalling. The mechanics were at a loss until they dropped the tank and found a small piece of tinfoil (as if someone added a fuel additive, and that small piece was never removed and settled in the fuel line). Something to look into and inexpensive.
Reply With Quote
  #3  
Old 05-19-2011, 05:08 AM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default Re: stops running at 4 to 6 miles

Not sure about 87 but, on some years, the TFI module is mounted separately from the distributor. Has the TFI been changed?
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
  #4  
Old 05-19-2011, 06:49 AM
hwhmobile hwhmobile is offline
94 Ranger XLT 2.3 engine
 
Join Date: Apr 2011
Posts: 129
Default Re: stops running at 4 to 6 miles

Idk but I think your truck is saying enough already I'm old...lol
Reply With Quote
  #5  
Old 05-19-2011, 10:46 AM
Searcherwolfe Searcherwolfe is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 9
Default Re: stops running at 4 to 6 miles

Thanks for the feedback
fifthranger
I have proper fuel pressure when I bypass the fuel relay when she won't start
rwenzing
According to the auto parts stores the 87 has no TFI
hwhmobile
Yes she is old but she passed emissions at 80% of new spec (rebuilt drive train about 4 yrs ago) it's more like you fixed everything else and you missed this part.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 Ranger 532,000 Miles (Half a million miles) audyjl Introduce Yourself 25 09-16-2014 01:34 PM
most miles on a 2010 or 2011 miles... batter up!!! 2010 General Ford Ranger Discussion 20 06-23-2014 05:25 PM
95 stops accelerating while driving cieramavdaze 4-Cylinder Tech 24 04-14-2011 08:44 AM
bump stops bigcountry Suspension Tech 2 02-21-2010 06:51 PM
Stock bump stops ... saus Suspension Tech 0 01-17-2010 08:16 PM