Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-28-2011, 01:36 PM
Black Ranger Black Ranger is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 11
Default Cruise Control cable problem 02 Ranger

Has anyone ever encountered their accelerator pedal sticking because of the cruise control cable? I noticed when my truck is parked and shut off the accelerator feels smooth; no hang-ups or anything but, as soon as I crank her over and everything under the hood energizes the accelerator sticks initially. I feel like it might be the cable assy running from the throttle body to the little cruise control box on the passenger side fender. I have no clue why the action on the cable is so rough when the truck is running. It might even be a potentiometer problem. Does anyone have any ideas on what might be causing this issue? I just want a nice smooth accelerator!
__________________
2002 XLT Extended Cab, Stepside Bed, 4.0L V6 Automatic, 4x4, K&N Cold Air Intake, Sony Xplod Head Unit with iPod control, Sony Xplod 4 way speakers, Galaxy DX979, Alon's Antenna Mount, 102" Whip Antenna, black Pacer Daytona style wheels, black Wheathertech floor mats
Reply With Quote
  #2  
Old 03-28-2011, 02:29 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Cruise Control cable problem 02 Ranger

It's more likely the throttle plate sticking by closing just a hair to far. There is a stop-set screw to the left of the throttle body. If you adjust it a hair, it will stop doing that.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #3  
Old 03-28-2011, 03:13 PM
Black Ranger Black Ranger is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 11
Default Re: Cruise Control cable problem 02 Ranger

Thanks for the input. I'll have to give it a try. So, it meets a little resistance because it's taking in air when I crank her over? That makes sense. Of course it would be smooth while it's off, there's nothing coming into the engine until I turn it on. Thanks again.
__________________
2002 XLT Extended Cab, Stepside Bed, 4.0L V6 Automatic, 4x4, K&N Cold Air Intake, Sony Xplod Head Unit with iPod control, Sony Xplod 4 way speakers, Galaxy DX979, Alon's Antenna Mount, 102" Whip Antenna, black Pacer Daytona style wheels, black Wheathertech floor mats
Reply With Quote
  #4  
Old 03-28-2011, 04:04 PM
Black Ranger Black Ranger is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 11
Default Re: Cruise Control cable problem 02 Ranger

I adjusted the set screw but I noticed the idle kicks up a little if I go too much obviously. It feels a little better now. What rpm should my 4.0 be idling at? Right now it's about 500 right under the 1k mark on the tach. Thanks for your help.
__________________
2002 XLT Extended Cab, Stepside Bed, 4.0L V6 Automatic, 4x4, K&N Cold Air Intake, Sony Xplod Head Unit with iPod control, Sony Xplod 4 way speakers, Galaxy DX979, Alon's Antenna Mount, 102" Whip Antenna, black Pacer Daytona style wheels, black Wheathertech floor mats
Reply With Quote
  #5  
Old 03-31-2011, 04:54 AM
Black Ranger Black Ranger is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 11
Default Re: Cruise Control cable problem 02 Ranger

Accelerator's working a hell of a lot better now. Thanks for the tip. I've been driving it a few days and noticed a world of difference. The idle seems just fine, still idling around 500-800 RPM.
__________________
2002 XLT Extended Cab, Stepside Bed, 4.0L V6 Automatic, 4x4, K&N Cold Air Intake, Sony Xplod Head Unit with iPod control, Sony Xplod 4 way speakers, Galaxy DX979, Alon's Antenna Mount, 102" Whip Antenna, black Pacer Daytona style wheels, black Wheathertech floor mats
Reply With Quote
  #6  
Old 03-31-2011, 05:00 AM
pooleo pooleo is offline
Ban Survivor. (x2)
 
Join Date: Jun 2010
Posts: 6,764
Default Re: Cruise Control cable problem 02 Ranger

My 01 idles at like 900 I would guess, its just a frog fuzz below 1k
__________________
1999 | Ext. Cab | 4.0 | 4x4 | 4.10's
Quote:
A Gladiator does not fear death. He embraces it. Caresses it. Fucks it. Each time he enters the arena, he slips his c0ck in the mouth of the beast, and prays to thrust home before the jaws snap shut. - Oenomaus
Ball Joints/Upper A-Arms How To
Replace Door pin/bushing
Repair broken dome light tabs
VIDEO OHC Install
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with cruise control cdiehn Interior Tech 5 03-26-2011 05:18 PM
Cruise control ?'s 2002VertGT Interior Tech 5 03-07-2011 09:13 PM
Replaced Cruise Control switches...Houston, I may have a problem! Tullphan Interior Tech 4 02-20-2011 02:54 PM
Cruise Control bassplyer92517 Electrical Tech 5 02-07-2010 08:46 PM
cruise control? 07 ranger tremor DR Roxo Interior Tech 3 11-16-2009 06:38 PM