Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 09-16-2009, 05:03 PM
ianbordas ianbordas is offline
'96 Ranger (4cyl 2.3L)
 
Join Date: Sep 2009
Posts: 2
Send a message via Skype™ to ianbordas
Default AC Problems

Hello Guys,
I have a 96 Ranger (4 cyl 2.3L - extended cab)

AC suddenly stopped working in all lower fan speeds, only worked on highest. I've been reading about a bad blower resistor could be the cause.

The problem gets worse: since Ive been having to use the AC in FULL speed, but now adjusting the temperature so I dont freeze, the compressor has also stopped working !!

Any ideas or suggestions?

Thanks!
Ian
ianbordas@hotmail.com

Last edited by ianbordas; 09-16-2009 at 05:13 PM.
Reply With Quote
  #2  
Old 09-16-2009, 05:07 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

might be the compressor that killed the ac
__________________
2005 Edge

Reply With Quote
  #3  
Old 09-19-2009, 02:23 PM
ianbordas ianbordas is offline
'96 Ranger (4cyl 2.3L)
 
Join Date: Sep 2009
Posts: 2
Send a message via Skype™ to ianbordas
Default Compressor cycling on off

I put in some 134 gas and compressor cycles on and off continuosly.

Bad Coil? or compressor completely bad?

Its curious how it was not working at all before I put in some gas, and after that it does the cycling on off.. maybe there is a leak inside the compressor..

any ideas anyone?

Thanks
Ian
Reply With Quote
  #4  
Old 09-24-2009, 09:49 PM
blueovelboy blueovelboy is offline
GO SHARKS
 
Join Date: Aug 2009
Posts: 1,523
Default

if you had to add coolant than yes there is a leak try to do a pressure test on pump up the system up to 50 lbs and see if in 24 hours you still have that pressure if not there is a leak and i don't know if 50 lbs is to much or not enough so you should check with a shop before you do it
__________________
Jay's
09 XL reg cab
L4 2.3 , 40 series flowmaster , tinted windows 5% back 35% sides ,muffler removed from air box mod ,and ac on off switch mod , blinker mod, avs window vent shades
coming soon! k&n drop in/fiberglass bed cover/bed sprayed liner
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
03 engine problems trailblazing81 3.0 Vulcan Tech 3 08-13-2009 08:06 PM
starting problems 1986 ford ranger 2.9 Liter Tech 1 06-27-2009 10:19 PM
91 3.0L idle problems dogboy 3.0 Vulcan Tech 0 06-02-2009 11:45 AM
2.3 idle problems jamesp01 4-Cylinder Tech 0 05-28-2009 05:17 AM
tranny problems rmn42689 Drivetrain Tech 0 05-24-2009 02:59 PM