Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 12-28-2010, 08:22 PM
aridranger03 aridranger03 is offline
3.0hhh
 
Join Date: Aug 2009
Posts: 171
Default 2 Questions

Thought I'd ask here since it gets alot of traffic -
1. I just replaced my front brakes (wheel bearings, rotors, pads) and now my abs light is on. It comes on when I reach 35 mph. Is there any way to clear this light?

2. I have the 3.0 squeaking belt issue and have narrowed it down to the belt area. I believe it is the tensioner/idler pulleys. If I buy the tensioner, does it come with the pulley too? Or would it be better to just try new pulleys first?

Truck has 109,500 miles.
__________________
1999 Ford F-150 XLT S-Cab 4x4 4.6 V8 3:55 L/S
Traded - 2003 Ford Ranger Edge Reg. Cab Flareside 3.0 V6
5 Speed 2wd 4:10 Limited Slip
Mods: Cargo Light, Map Lights, Tow Hooks, Fabtech Add-A-Leaf, Ford Step Bars, 06 Tails
Future Plans: 06+ Corners, Tint
Got a 3.0? Join Us!
Southeast Rangers Join Here!

Last edited by aridranger03; 12-28-2010 at 08:24 PM.
Reply With Quote
  #2  
Old 12-28-2010, 08:49 PM
mazdab2300 mazdab2300 is offline
Totally bummed
 
Join Date: Jun 2010
Posts: 1,106
Default Re: 2 Questions

for the first question try disconnecting the battery for 10 minutes. it resets the computer. and for the second question try some wd-40 or something to grease it up. that way you can make sure its not something that can be fixed for $1.00 instead of spending alot.
__________________
94 Mazda B2300
jvc head unit scosh hds and xplod speakers also have 2 12 inch subs in the back.
american racing directionals on 30/9.5/15s

INDIANA RANGERS
MAZDAS
Reply With Quote
  #3  
Old 12-28-2010, 09:05 PM
aridranger03 aridranger03 is offline
3.0hhh
 
Join Date: Aug 2009
Posts: 171
Default Re: 2 Questions

Thanks for the response. I did unhook the battery last night for about an hour and a half and then drove it again today with the light coming back on. On what little research I've did, I thought I read something about the wheel sensors? getting dirty or something like that. And on the belt, I put a new dayco poly-rib belt on 2 weeks ago and it still squeeks/chirps. A little belt dressing quietens it down but it comes right back. I guess the big question on that is the regular idler pulley on top and the pulley on the tensioner the same size?
__________________
1999 Ford F-150 XLT S-Cab 4x4 4.6 V8 3:55 L/S
Traded - 2003 Ford Ranger Edge Reg. Cab Flareside 3.0 V6
5 Speed 2wd 4:10 Limited Slip
Mods: Cargo Light, Map Lights, Tow Hooks, Fabtech Add-A-Leaf, Ford Step Bars, 06 Tails
Future Plans: 06+ Corners, Tint
Got a 3.0? Join Us!
Southeast Rangers Join Here!
Reply With Quote
  #4  
Old 12-28-2010, 09:41 PM
pooleo pooleo is offline
Ban Survivor. (x2)
 
Join Date: Jun 2010
Posts: 6,764
Default Re: 2 Questions

take the bulb out.
__________________
1999 | Ext. Cab | 4.0 | 4x4 | 4.10's
Quote:
A Gladiator does not fear death. He embraces it. Caresses it. Fucks it. Each time he enters the arena, he slips his c0ck in the mouth of the beast, and prays to thrust home before the jaws snap shut. - Oenomaus
Ball Joints/Upper A-Arms How To
Replace Door pin/bushing
Repair broken dome light tabs
VIDEO OHC Install
Reply With Quote
  #5  
Old 12-29-2010, 02:52 PM
aridranger03 aridranger03 is offline
3.0hhh
 
Join Date: Aug 2009
Posts: 171
Default Re: 2 Questions

Quote:
Originally Posted by pooleo View Post
take the bulb out.
Thats a possibility but I would like my abs to work again if I ever needed it.
__________________
1999 Ford F-150 XLT S-Cab 4x4 4.6 V8 3:55 L/S
Traded - 2003 Ford Ranger Edge Reg. Cab Flareside 3.0 V6
5 Speed 2wd 4:10 Limited Slip
Mods: Cargo Light, Map Lights, Tow Hooks, Fabtech Add-A-Leaf, Ford Step Bars, 06 Tails
Future Plans: 06+ Corners, Tint
Got a 3.0? Join Us!
Southeast Rangers Join Here!
Reply With Quote
  #6  
Old 12-29-2010, 03:07 PM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: 2 Questions

Did you get a new sensor when you did all this?
Reply With Quote
  #7  
Old 12-29-2010, 03:42 PM
aridranger03 aridranger03 is offline
3.0hhh
 
Join Date: Aug 2009
Posts: 171
Default Re: 2 Questions

Quote:
Originally Posted by Clinton View Post
Did you get a new sensor when you did all this?
No. I'm guessing I need a new one? Do you know where exactly it is and how easy is it to get to?

edit - are these the sensors?
http://www.oreillyauto.com/site/c/de...0165&ppt=C0009
http://www.oreillyauto.com/site/c/de...0165&ppt=C0009
__________________
1999 Ford F-150 XLT S-Cab 4x4 4.6 V8 3:55 L/S
Traded - 2003 Ford Ranger Edge Reg. Cab Flareside 3.0 V6
5 Speed 2wd 4:10 Limited Slip
Mods: Cargo Light, Map Lights, Tow Hooks, Fabtech Add-A-Leaf, Ford Step Bars, 06 Tails
Future Plans: 06+ Corners, Tint
Got a 3.0? Join Us!
Southeast Rangers Join Here!

Last edited by aridranger03; 12-29-2010 at 04:07 PM.
Reply With Quote
  #8  
Old 12-30-2010, 08:10 PM
aridranger03 aridranger03 is offline
3.0hhh
 
Join Date: Aug 2009
Posts: 171
Default Re: 2 Questions

bump
__________________
1999 Ford F-150 XLT S-Cab 4x4 4.6 V8 3:55 L/S
Traded - 2003 Ford Ranger Edge Reg. Cab Flareside 3.0 V6
5 Speed 2wd 4:10 Limited Slip
Mods: Cargo Light, Map Lights, Tow Hooks, Fabtech Add-A-Leaf, Ford Step Bars, 06 Tails
Future Plans: 06+ Corners, Tint
Got a 3.0? Join Us!
Southeast Rangers Join Here!
Reply With Quote
  #9  
Old 12-30-2010, 08:28 PM
2002 2WD Edge 2002 2WD Edge is offline
Ford Tough
 
Join Date: Mar 2010
Posts: 387
Default Re: 2 Questions

Try silicone spray instead on the belt. Here is an article on ABS and the warning light/causes of it showing.

http://www.auto-facts.org/ABS-scan-tool.html
__________________
JBA s.s. headers&exhaust, K&N cold air intake, Bosch Iridium Plus 4 plugs, Royal Purple in motor, 5spd & diff.,Superchips programmer, axle girdle. Also have but yet to install KYB Gas-A-Just shocks and Belltech sway bars.
Reply With Quote
  #10  
Old 12-30-2010, 09:10 PM
aridranger03 aridranger03 is offline
3.0hhh
 
Join Date: Aug 2009
Posts: 171
Default Re: 2 Questions

Quote:
Originally Posted by 2002 2WD Edge View Post
Try silicone spray instead on the belt. Here is an article on ABS and the warning light/causes of it showing.

http://www.auto-facts.org/ABS-scan-tool.html
Thanks for the article! I'm still suspecting wheel speed sensors, so I need to pull the wheels off and have a look at them. If only I knew someone who has one of those scanners...
__________________
1999 Ford F-150 XLT S-Cab 4x4 4.6 V8 3:55 L/S
Traded - 2003 Ford Ranger Edge Reg. Cab Flareside 3.0 V6
5 Speed 2wd 4:10 Limited Slip
Mods: Cargo Light, Map Lights, Tow Hooks, Fabtech Add-A-Leaf, Ford Step Bars, 06 Tails
Future Plans: 06+ Corners, Tint
Got a 3.0? Join Us!
Southeast Rangers Join Here!
Reply With Quote
  #11  
Old 12-30-2010, 10:01 PM
2002 2WD Edge 2002 2WD Edge is offline
Ford Tough
 
Join Date: Mar 2010
Posts: 387
Default Re: 2 Questions

Quote:
Originally Posted by aridranger03 View Post
Thanks for the article! I'm still suspecting wheel speed sensors, so I need to pull the wheels off and have a look at them. If only I knew someone who has one of those scanners...
I wonder if Autozone does and scans for free like they do with code readers? However I see many posts of the free code scan..showing whatever..I wonder if anyone ever has had that done and were told nothing is showing?
__________________
JBA s.s. headers&exhaust, K&N cold air intake, Bosch Iridium Plus 4 plugs, Royal Purple in motor, 5spd & diff.,Superchips programmer, axle girdle. Also have but yet to install KYB Gas-A-Just shocks and Belltech sway bars.
Reply With Quote
  #12  
Old 12-31-2010, 12:30 AM
busterdude2 busterdude2 is offline
SoCal Ghost
 
Join Date: Dec 2010
Posts: 105
Default Re: 2 Questions

You can easily test the ABS wheel speed sensors yourself. I did once when my abs kept kicking in randomly.

Just unplug the sensor and using a volt/ohm meter read the voltage (on the sensor side). It should be zero. Then take your metal abs plate (its a disk with slots going from center to edge, mine was part of my brake rotors) and run it across the sensor. It should read a small voltage, record this. Do the same for the other sensor, running it across at about the same speed and compare the voltages. They should be close and you should be able to manipulate the value by going faster or slower. If they are close then they are working fine and not the problem. I did this to mine because a new sensor for my '95 was about $100.

Also, not sure how your year is set up, but my abs plates were attached to my rotors and my problem was that the two new rotors i got were not the same and the plates were different distances from the sensor. I ended up bending one so that it would be closer to the sensor.

Sorry for the long write up, hope you find something useful in it.
__________________
1995 Ford Ranger XLT 4.0L V6 Auto...Totaled at 256K Miles
1998 Ford Ranger XLT 4X4 4.0L V6 Auto 120K Miles
Quote:
Originally Posted by Fordzilla80 View Post
Your manstinct must be broken dude.
Reply With Quote
  #13  
Old 01-02-2011, 08:34 PM
aridranger03 aridranger03 is offline
3.0hhh
 
Join Date: Aug 2009
Posts: 171
Default Re: 2 Questions

Quote:
Originally Posted by 2002 2WD Edge View Post
I wonder if Autozone does and scans for free like they do with code readers? However I see many posts of the free code scan..showing whatever..I wonder if anyone ever has had that done and were told nothing is showing?
I stopped by autozone the other day and they wouldn't even hook up to it. O'reilly's did and their scanner didn't pick up any codes.
__________________
1999 Ford F-150 XLT S-Cab 4x4 4.6 V8 3:55 L/S
Traded - 2003 Ford Ranger Edge Reg. Cab Flareside 3.0 V6
5 Speed 2wd 4:10 Limited Slip
Mods: Cargo Light, Map Lights, Tow Hooks, Fabtech Add-A-Leaf, Ford Step Bars, 06 Tails
Future Plans: 06+ Corners, Tint
Got a 3.0? Join Us!
Southeast Rangers Join Here!
Reply With Quote
  #14  
Old 01-02-2011, 08:41 PM
DiabloBlanco DiabloBlanco is offline
Get Lifted.
 
Join Date: Nov 2010
Posts: 6,402
Default Re: 2 Questions

For the belt if that spray didnt work, Its the idler pully. Pretty common problem
__________________
YZ the way to be!
The Brotherhood!

Mods to come: Camburg entry 6.0 system. FiberwerkX Fenders and bedsides. Tube bumper.
R.I.P. Jeff Ashton. 1992-2011
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
2 questions here azgilamonster Exterior Tech 8 09-10-2010 08:56 PM
2 Questions SmokeyMcPot420 General Tech 3 04-11-2010 09:44 PM
2.5L questions Joel59 4-Cylinder Tech 7 12-22-2009 07:10 AM
Questions ranger4.0 General Ford Ranger Discussion 0 12-17-2009 02:18 PM
A/C questions robsranger 3.0 Vulcan Tech 0 09-27-2009 04:29 PM