Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #16  
Old 09-24-2009, 03:18 PM
Recon Ranger Recon Ranger is offline
Like the Forums
 
Join Date: Aug 2009
Posts: 41
Default

STL,

I did flush the fuel line from the tank to the filter, and from the filter to the engine.
After emptying half the gas out of the tank I'm not convenced that was the problem.

So going back to my Ranger losing power prior to the gas, and thinking it's electrical.
The pump is pumping with plenty of pressure. I've changed the spark plugs, spark plug cables, distributor cap, rotor button, and coil. I'm trying to find the module, and now bbowler said he had a similiar problem that turned out to be the ground from the computer.

Now I'm trying to find my ignition module and computer w/ground.
__________________
Semper Ford

Recon Ranger
94 Ranger XLT
Super Cab
Reply With Quote
  #17  
Old 09-24-2009, 04:11 PM
bbowler bbowler is offline
Learning to use the forums
 
Join Date: Aug 2009
Posts: 5
Default

The ground connection I speak of are on the inside the computer itself. I used to service electronics for a living,so, I took a peek. If you do not know how to service electronics then I would suggest you get a replacement computer and try it, or take it somewhere to get the codes from the computer.Any way, I bought another computer (under $100.00 ) and it brought my truck back to life.By the way, I found out it was the computer by slapping it and the truck would start then not start. Hope this helps
Reply With Quote
  #18  
Old 09-25-2009, 06:14 AM
Clem Clem is offline
Ford Tough
 
Join Date: Aug 2009
Posts: 331
Default

Check the passenger side kick panel for the ECM (computer).
Passenger side of radiator attached to the radiator support for the ICM, it will look similar to the pic.


Ray
Reply With Quote
  #19  
Old 10-02-2009, 02:29 PM
Motopsycho Motopsycho is offline
Liking the Ford Ranger Forum
 
Join Date: Sep 2009
Posts: 21
Default

Too much of an additive will hurt more than help. I thought I would put sea foam in when it was really low once to really do some cleaning. Well it was too concentrated and it ran like crap. My motorcycle did that once too. Try just plain gas.
Reply With Quote
  #20  
Old 10-06-2009, 07:37 PM
Recon Ranger Recon Ranger is offline
Like the Forums
 
Join Date: Aug 2009
Posts: 41
Default

Thanks for all the help Guys!
Turns out the problem is electrical and not fuel.
I'm not getting spark to the distributor.
I've opened a new Thread for help.
I'm trying to find why I'm not getting spark.

The fuel I siphoned and used else where with no problems.
That's not to say my fuel tank couldn't use a cleaning but a mechanic told me to buy some racing fuel to clean the system.
__________________
Semper Ford

Recon Ranger
94 Ranger XLT
Super Cab
Reply With Quote
  #21  
Old 10-12-2009, 06:23 PM
Boujiboy2000 Boujiboy2000 is offline
Learning to use the forums
 
Join Date: Oct 2009
Posts: 8
Default

after all that a new fuel filter wouldnt be a bad idea either
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 ford ranger engine replacement? ufc fighter x6 3.0 Vulcan Tech 5 08-05-2010 05:59 PM
Please Help! Engine Rpm trouble aridranger03 3.0 Vulcan Tech 5 08-23-2009 06:13 AM
engine Replacement 98son 3.0 Vulcan Tech 1 07-21-2009 03:55 AM
V6 in trouble Sifurich 4.0 SOHC / 4.0 OHV Tech 4 07-18-2009 08:51 AM
A/C Trouble Draco General Ford Ranger Discussion 1 07-09-2009 02:38 PM