Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Ford Ranger Technical > General Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 11-24-2010, 07:05 PM
mossyoakranger99
 
Join Date: Nov 2010
Posts: 8
Default 87 ranger 2.9 runs rough when warm

i have a 87 ranger 2.9 4x4 5 speed... picked it up real cheap for a project. it runs but not the way it should. i have put on a new altenator, new tps, new o2 sensor, plugs wires cap and rotor, new fuel pump relay and pulled all the codes and nothing is pointing me in the direction of why it runs good cold, idles smooth and runs good at wide open throttle but at mid range rpm or around 2000 to 3000 rpm when the motor is under load it cuts out and surges until you give it wide open throttle or come to a stop. it never dies... so i am lost. i am a newly certified mechanic and know alot about cars but these old computer systems i cant figure out... i cant stand not having no live data... so can anyone help me out
__________________
mossyoakranger99
Reply With Quote
  #2  
Old 11-24-2010, 07:12 PM
OIF Veteran

 
Join Date: Feb 2010
Posts: 6,042
Default Re: 87 ranger 2.9 runs rough when warm

does the spout connector have its plug in it? i forgot to put mine back in after i set the timing one time back when i had an 86 2.9 and it ran like you described.

this is the spout connector (the white part) with the spout plug in it (the black part) IIRC its located near the distributer.

__________________
2001 Ranger 4x4 Stepside
-RCD Suspension lift
-33x12.5 BFG KM2's on Mickey Thomson classic locks
-4:56 gears
-Auburn gear LS
-James Duff traction bars
-Headers
-Flowmaster duals
-SCT X-Cal2 and some small exterior mods

http://www.cardomain.com/ride/2321189

2005 F-150 Lariat 4x4
-LED third brake light
-Weathertech floor liners
-Edge tuner
Reply With Quote
  #3  
Old 11-24-2010, 07:19 PM
mossyoakranger99
 
Join Date: Nov 2010
Posts: 8
Default Re: 87 ranger 2.9 runs rough when warm

i will check it out... thanks. i am really hoping to figure it out before i end up putting more money into it than what i paid for it... im sure alot of people know how that feels.
__________________
mossyoakranger99
Reply With Quote
  #4  
Old 11-24-2010, 07:21 PM
OIF Veteran

 
Join Date: Feb 2010
Posts: 6,042
Default Re: 87 ranger 2.9 runs rough when warm

Quote:
Originally Posted by mossyoakranger99 View Post
i will check it out... thanks. i am really hoping to figure it out before i end up putting more money into it than what i paid for it... im sure alot of people know how that feels.
good luck, it may not be what your problem is but its easy to check and rule out.
__________________
2001 Ranger 4x4 Stepside
-RCD Suspension lift
-33x12.5 BFG KM2's on Mickey Thomson classic locks
-4:56 gears
-Auburn gear LS
-James Duff traction bars
-Headers
-Flowmaster duals
-SCT X-Cal2 and some small exterior mods

http://www.cardomain.com/ride/2321189

2005 F-150 Lariat 4x4
-LED third brake light
-Weathertech floor liners
-Edge tuner
Reply With Quote
  #5  
Old 11-24-2010, 07:42 PM
mossyoakranger99
 
Join Date: Nov 2010
Posts: 8
Default Re: 87 ranger 2.9 runs rough when warm

ya the plug was in it...damn! any other ideas? i was gonna go after plugged fuel injectors... but seeing that it runs perfect cold and on idle and WOT i think i can rule that out....im lost
__________________
mossyoakranger99
Reply With Quote
  #6  
Old 12-08-2010, 10:33 AM
Psycho Pete
 
Join Date: Jun 2009
Posts: 1,487
Default Re: 87 ranger 2.9 runs rough when warm

Quote:
Originally Posted by 01_ranger_4x4 View Post
Hey, that thumb looks awfully familiar! Hey wait, that's my thumb! Hope it helps someone out, know it's a questions asked a lot and is why I took the pic. That's a SPOUT from a 1988 2.9L mainharness, located near the TFI module.

----------

Quote:
Originally Posted by mossyoakranger99 View Post
ya the plug was in it...damn! any other ideas? i was gonna go after plugged fuel injectors... but seeing that it runs perfect cold and on idle and WOT i think i can rule that out....im lost
I don't know why you're avoiding using the technology built in to the computer system. Pulling codes is free to do. It would be very time consuming to check each wire and sensor in the EEC-IV system to diagnose. The best way to go about this with out spending a lot of money is using the diagnostics that are available to you to help figure out what the problem is. Otherwise you are just shooting in the dark. Have a link in your other thread to Corral that explains how to pull codes in full detail.

http://www.fordfuelinjection.com/ <-- great site also
__________________

1987 Ford Ranger Short Bed 5.0L/T-5 Project
1988 Ford Ranger Long Bed Parts Truck
1993 Ford Tempo 2.3L OHV HSC Auto - D/D Stock.
1999 Honda Accord VTEC Auto
2002 Dodge Caravan - 3.3L Auto
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
My 88 with 2.9 runs rough jimandpam 2.9 Liter Tech 13 10-18-2010 05:31 AM
Ranger runs rough wedge 4-Cylinder Tech 0 08-16-2010 12:17 PM
ranger runs rough smokes alot here and there 94 Ranger 3.0 Vulcan Tech 10 05-10-2010 05:46 PM
runs rough/choked til warm then clicks over to proper idle khgxdctv Electrical Tech 0 11-11-2009 06:09 PM
1998 Ford Ranger runs rough with sulfur smell? Michael K General Ford Ranger Discussion 1 01-01-2009 01:57 PM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.