Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-20-2009, 04:30 PM
Unknowndady Unknowndady is offline
1994 Ford Ranger XLT 4.0L
 
Join Date: Jul 2009
Posts: 31
Default Very low MPG problem

My 1994 4.0L Ranger is only getting 8 mpg in the city. I've changed the oils, filters, spark plugs, and filled up the tires. I think something is bad in it or just old and needs to be replaced.

Any help?
Thanks
__________________
1994 Ford Ranger XLT 4.0L 4X4
140,000 miles
Reply With Quote
  #2  
Old 08-20-2009, 05:34 PM
Tom Tom is offline
Ranger Enthusiast
 
Join Date: Nov 2008
Posts: 6,829
Default

Is this a new problem, or has it been like this as long as you had it?

Throwing any codes? Check the vacuum lines for leaks?
__________________
2006 Ford Ranger Sport 4.0 2WD on 32x11.50R15s
-3" Doetsch Spindle Lift


Using the forum:
How to Post on the Forum
Creating a signature (do this before asking any questions)
Upload an Avatar (image of your Ranger)
How to Post Pictures on the Forum
Switch the site layout: Light Theme or Dark Theme

Things to do:
Participate in Truck of the Month
Participate in the Ranger Photo Contest
Participate in the Non-Automotive Photo Contest
Become a Site Contributor
Shop at the FordRangerForum.com Store
Reply With Quote
  #3  
Old 08-20-2009, 07:27 PM
Unknowndady Unknowndady is offline
1994 Ford Ranger XLT 4.0L
 
Join Date: Jul 2009
Posts: 31
Default

I'm not sure if it has alway been a problem but its definitely not normal and there has to be a way to increase its mpg - 8 mpg is incredibly low. I'm thinking of cleaning the IAC sensor and doing a basic cleaning of the engine.
__________________
1994 Ford Ranger XLT 4.0L 4X4
140,000 miles
Reply With Quote
  #4  
Old 08-20-2009, 08:44 PM
mr.ranger mr.ranger is offline
Ford Ranger Driver
 
Join Date: Jul 2009
Posts: 652
Default

holy!!! 8 mpg is ridiculous, you obviously have a major problems in your air or fuel intake/exhaust/gummed upo engine
__________________
GOING TO BUY a 2009 ford ranger sport 4X4 ..currently saving up enough money
debating on the colour (red, blue or black?)
updating once i buy my baby
Reply With Quote
  #5  
Old 08-21-2009, 10:58 AM
Unknowndady Unknowndady is offline
1994 Ford Ranger XLT 4.0L
 
Join Date: Jul 2009
Posts: 31
Default

I've been researching the topic and I'm pretty sure its the catalytic converter - all plugged up.
__________________
1994 Ford Ranger XLT 4.0L 4X4
140,000 miles
Reply With Quote
  #6  
Old 08-21-2009, 11:36 AM
surfer03133 surfer03133 is offline
Dead Whales Everywhere!
 
Join Date: May 2009
Posts: 929
Send a message via Skype™ to surfer03133
Default

throw a new cat on and see what happens, i think pre 98s only have 2 or something. also i would check the fuel lines and use some sea foam to clean all the gunk out of the engine
__________________
08 Ranger Sport 2wd
aFe CAI, 30x9.5.x15 Grabber AT2s, U/D pulleys, flowmaster super 44

"Those who make peaceful revolution impossible will make violent revolution inevitable."
- John F. Kennedy

"Somehow the "god of the athiests" delivers more miracles than all other religion combined than..."
Reply With Quote
  #7  
Old 08-21-2009, 03:57 PM
mr.ranger mr.ranger is offline
Ford Ranger Driver
 
Join Date: Jul 2009
Posts: 652
Default

sea foam s a great idea, i know many owners use is anually but a cat could get expensive but you might be forced to do that...however, how is the fuel intake system (tank, lines, filter, pump, injectors) fuctions cause i know that can really affect vehicle power and performance, however, a clogged cat is more likely
__________________
GOING TO BUY a 2009 ford ranger sport 4X4 ..currently saving up enough money
debating on the colour (red, blue or black?)
updating once i buy my baby
Reply With Quote
  #8  
Old 08-21-2009, 11:11 PM
02'4.04x4 02'4.04x4 is offline
Ford Ranger Driver
 
Join Date: Aug 2009
Posts: 634
Default

Quote:
Originally Posted by Unknowndady View Post
I've been researching the topic and I'm pretty sure its the catalytic converter - all plugged up.
Food 4 Thought,
Any Muff shop can shoot the temp and tell you if it is bad.

Some Muff shops will weld a piece of straight into space between to pipes as long as there is not a catalyst sticker on the vehicle. . .

A few Muff shops will weld in with sticker on the vehicle, but you have to promise not to tell anyone who did it. . .

Not sure if they sell them for Ranger's?? but there are test pipes(cat delete) that are perfect, great, wonderful. . .
HTH
Reply With Quote
  #9  
Old 09-03-2009, 02:58 PM
orgnlmrwiggles orgnlmrwiggles is offline
Like the Forums
 
Join Date: May 2009
Posts: 43
Default

Quote:
Originally Posted by Unknowndady View Post
I've been researching the topic and I'm pretty sure its the catalytic converter - all plugged up.
so what happened? did you figure this out yet? im getting like 12-15 mpg max in my 94 4.0l 5spd manual... its crazy.
__________________
1994 Ford Ranger XLT Regular Cab
TMA 360.2 bridged to sub
1 JL Audio w1v2 custom ported box
Kenwood Excelon 5x7 kfc-x682c 360 watt max (front)
pioneer 6x9 ts-905 200 watt max (back)
pioneer deh-p7800mp

http://www.cardomain.com/ride/3087188
Reply With Quote
  #10  
Old 09-03-2009, 03:31 PM
Unknowndady Unknowndady is offline
1994 Ford Ranger XLT 4.0L
 
Join Date: Jul 2009
Posts: 31
Default

Well I did the sea foam thing and it started to run better, did another mpg test and Im getting about 12 mpg also. I'm just going to leave it like that for awhile.
__________________
1994 Ford Ranger XLT 4.0L 4X4
140,000 miles
Reply With Quote
  #11  
Old 11-15-2009, 12:37 AM
94Woodhauler 94Woodhauler is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 11
Default

Last week I got the truck out, I had not used it in about a year and a half.
It would start and idle fine, but had no power. OK it is a 2.3, but it would not pull 3500 RPM. I had to haul some things to Kent (about 55 miles) and it took me almost 2 hours.
I had just picked up a almost new stock exhaust (cat back) at the junkyard for $25 and put it on, so I thought a critter had built a nest in it or something.
I pulled it off and it still had no power. It was also quiet... with no muffler!
I am not telling anyone to do this, but if you use a spade bit with 2 extentions chucked in a sturdy drill, a couple good sized holes can be drilled through the pluged catylist core from the flange opening. At least on mine I could. I did not cut it all out so it still smells like it is working. This would not work if your area does smog checks. It sounds better too, at least for a four with stock pipes.
Reply With Quote
  #12  
Old 11-15-2009, 01:50 PM
DisturbedESV DisturbedESV is offline
Original Grab-Her
 
Join Date: Sep 2009
Posts: 2,430
Send a message via AIM to DisturbedESV
Default

Quote:
Originally Posted by Unknowndady View Post
Well I did the sea foam thing and it started to run better, did another mpg test and Im getting about 12 mpg also. I'm just going to leave it like that for awhile.
Is your truck stock?
__________________
2008 XLT 4x4 - GRABBER ORANGE - 4.0 V6 - 5 spd
PNW CREW
Quote:
Originally Posted by camodown View Post
that's it, marie is pissed. game over
Reply With Quote
  #13  
Old 11-15-2009, 04:55 PM
Unknowndady Unknowndady is offline
1994 Ford Ranger XLT 4.0L
 
Join Date: Jul 2009
Posts: 31
Default

I suppose its "stock", the truck is running fine now. Seems that the worst thing for a vehicle is for it just to sit there. Cleaned out some dirty sensors and all is good.
__________________
1994 Ford Ranger XLT 4.0L 4X4
140,000 miles
Reply With Quote
  #14  
Old 11-15-2009, 05:12 PM
olfordtruck olfordtruck is offline
Ford Enthusiast
 
Join Date: May 2009
Posts: 501
Default

Dont forget to change the spark plugs out after doing seafoam.
__________________
2003 Ford Ranger Edge 3.0L Vulcan Auto Tranny
MAC Performance Ram Air Intake
Flowmaster Super 44 w/ tailpipe before the wheel
Interior and Exterior LED w/ music interface
Ford Racing front and rear Sway Bars
Limited Slip with 4.10 gears


http://www.cardomain.com/ride/3114321
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search