Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 09-20-2010, 04:40 PM
csharp100 csharp100 is offline
Learning to use the forums
 
Join Date: Apr 2010
Posts: 12
Default AC problems...

Hey guys, I have a problem with my air conditioner. The systems seems to come on when it wants. I checked the pressure switches on both sides of the systems by unplugging them and jumping the connection. The clutch did not engage at either time. The system has plenty of freon and when the clutch finally does come one, the ac blows very cold air. I am trying to figure out how to troubleshoot the system by narrowing down my choices. I have searched these forums and there is not much with ac problems on here. Any and all help would be appreciated.
Reply With Quote
  #2  
Old 09-20-2010, 04:47 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: AC problems...

Bypass everything and power up the clutch directly. I don't have it in front of me to look, but there is probably one positive or a positive and negative wire going to the clutch. You should be able to power it directly and the clutch should engage. If it doesn't, then you know the problem is the clutch.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #3  
Old 09-20-2010, 05:03 PM
csharp100 csharp100 is offline
Learning to use the forums
 
Join Date: Apr 2010
Posts: 12
Default Re: AC problems...

Well I just checked to see if the compressor was gettinng any power from the plug. It is not. I need to see where the problem lies now. Like I said earlier, it will come on by itself after a period of time and that time could be a half hour or an hour. Nothing really systematic about it.
Reply With Quote
  #4  
Old 09-20-2010, 07:39 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: AC problems...

Some information about your truck would help.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #5  
Old 09-21-2010, 05:10 AM
csharp100 csharp100 is offline
Learning to use the forums
 
Join Date: Apr 2010
Posts: 12
Default Re: AC problems...

yah, I guess that would help. 2003 Ranger Edge, 3.0, 5 speed, cali emissions equiped.
Reply With Quote
  #6  
Old 09-21-2010, 05:48 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: AC problems...

Ok. I think there is a relay in the power distrobution box under the hood next to the battery. The computer switches the relay on and off based on numerous factors, but its probably not the computers screwing it up. More likely, it is a the relay or a fuse in that power distrobution box.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #7  
Old 09-21-2010, 02:35 PM
csharp100 csharp100 is offline
Learning to use the forums
 
Join Date: Apr 2010
Posts: 12
Default Re: AC problems...

Sweet! It was the relay. I swapped it with the fog light relay which was the same. Buying a new one but no stock, have to order. Thanks for your help!
Reply With Quote
  #8  
Old 09-22-2010, 06:27 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: AC problems...

No problem.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #9  
Old 07-09-2012, 02:59 PM
wilsonbh wilsonbh is offline
Learning to use the forums
 
Join Date: Apr 2011
Posts: 10
Default Re: AC problems...

Quote:
Originally Posted by FireRanger View Post
Ok. I think there is a relay in the power distrobution box under the hood next to the battery. The computer switches the relay on and off based on numerous factors, but its probably not the computers screwing it up. More likely, it is a the relay or a fuse in that power distrobution box.
I have a 2000 Ford Ranger v6 Flex fuel 2WD. My A/C turns on right away but will run for about 5 min then shut down. The fan blows nicely but the cold stops at somewhere around 5 min. I can turn the A/C off and after maybe 5 more minutes, it will turn on again for another 5 min or so.

Could this be a relay too?

Bill
__________________
2000 Ford Ranger Ext Cab
v6, Flex-Fuel
Reply With Quote
  #10  
Old 07-10-2012, 02:03 PM
mrskydrol mrskydrol is offline
Like the Forums
 
Join Date: Jun 2012
Posts: 30
Default

Charge could be low. 5 min is about enough time for the evaporator to freeze. When it stops blowing cold. Turn off the a/c and let the blower continue to run. After a few minutes turn the A/c back on and see if it does it again.
Reply With Quote
  #11  
Old 07-10-2012, 02:22 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: AC problems...

Also could be the low pressure switch sticking. It's what shuts the compressor off when the evaporator reaches a pressure that is theoretically it's coldest.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
i have many problems BryFin83 Electrical Tech 16 06-20-2011 04:27 AM
AC Problems earnbud General Tech 4 06-09-2011 06:54 PM
some little problems with my 3.0, HELP!! 2004xlmiller 3.0 Vulcan Tech 19 08-24-2010 05:49 AM
C4 Problems!!! Hinderburger Drivetrain Tech 1 06-22-2010 08:19 AM
problems IVAN General Ford Ranger Discussion 1 02-17-2010 07:40 PM