Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 09-19-2010, 09:39 PM
jessica jessica is offline
Learning to use the forums
Join Date: May 2010
Posts: 1
Default Anyone help?

I have a 2001 ford ranger xlt. My only problem with my truck is once i hit 85 mph it starts shaking and once i hit 90 it makes this awful sound and wont accelerate anymore. I believe its the engine shut off thing and i was told i could take out a fuse but the fuse that it is, is also my windsheild wipers..anyone know how to fix that problem?
Reply With Quote
Old 09-19-2010, 09:42 PM
dixie_boysles dixie_boysles is offline
Joshua 24:15

Join Date: May 2009
Posts: 6,502
Send a message via Yahoo to dixie_boysles
Default Re: Anyone help?

Yeah the problem is the speed, our trucks were not made to go that fast. They are trucks. Just drive the speed limit and you will be fine. But in order to get over 92-93 mph, u have to have a programmer.
2006 Toyota 4Runner Sport 4x4
Clarion CX501 Double Din | 265/70/17 BFG A/T | Remote Start | Tinted Windows | TRD Exhaust | TRD CAI |4.0 V6 |Tow Package | Titanium Metallic
SOLD: 2006 Ranger XLT Supercab 4x4 | The "Original Mr. Clean"
Yes I drive a Toyota 4Runner now, Yes this is a Ranger forum, get over it, the Ranger couldn't fit my child, but I do miss it.
Reply With Quote

fuses, shut off

Thread Tools Search this Thread
Search this Thread:

Advanced Search