Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 09-19-2010, 11:44 AM
99blkranger 99blkranger is offline
Learning to use the forums
Join Date: Sep 2010
Posts: 1
Default 99 ranger sport, Temp gauge problem

First off I would like to say hi to everyone I am new here. This is my first thread, I hope to get a question answered.

Here is the problem, I got a 99 ford ranger sport model 2.5 4 banger, 5 spd, 2wd. A year or so ago the temp guage started reading more than high temp but it didn't smell of antifreeze nor did it boil or over heat. I figured no big deal, well I finally went to replace the coolant temp sensor and I got the same problem. I have a volt ohm meter, but not sure what to set it at to check. My ac works great except the clanking sound i get when the compressor kicks in, also the compressor stays kicked in alot too! The main problem is the gauge, I have ran it all the way by the red without a problem, no smoke, no boiling, no lights warning me, etc. Thanks for the help, if I wasn't clear enough I will try to rephrase this thing a bit, Thanks again.
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 2.3L Ranger Temp. Gauge Problem 2001ranger 4-Cylinder Tech 3 10-26-2011 06:10 AM
temp gauge adk General Ford Ranger Discussion 2 06-02-2011 04:13 PM
New Problem Temp Gauge 99 ranger 4.0 opus007 4.0 SOHC / 4.0 OHV Tech 2 03-17-2010 12:20 PM
Water Temp Gauge 99_NWRanger Electrical Tech 0 02-28-2010 09:33 AM
Temp gauge not functioning twdavis416 Electrical Tech 2 11-23-2009 05:19 PM