Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #16  
Old 09-14-2010, 07:11 PM
ObsoleteE ObsoleteE is offline
I'm an F-18, bro
 
Join Date: Jan 2010
Posts: 1,972
Send a message via AIM to ObsoleteE
Default Re: I think my ECU reset while driving

Today I finally got around to the truck (been driving the car since the issue). Opened the door, and the deck was clicking like it was trying to eject the cd, which was weird because the key wasn't in the ignition. I went to start the truck and nothing. I figured the battery was dead. I first thought that there was a short in the remote wire for the deck because it was definitely powered on. So, I pulled my car around to jump the truck. Opened the car hood, grabbed the jumper cables, opened the truck hood and saw tons of blue corrosion on the battery. Now, I've never seen blue corrosion, its always been yellow/orange. So I decided to clean the corrosion off of the battery (my truck door was open at this point). As soon as I cleaned the corrosion off, I heard the open door chime. Got into the truck and it fired right up. I guess the problem the whole time was corrosion. Now, I have another question. What would cause blue corrosion? Like I said, I've never seen blue corrosion in the past. Am I out of hot water, or do I still have an issue here?
__________________
1999 B2500 5 Speed
Reply With Quote
  #17  
Old 09-14-2010, 07:52 PM
mickblock mickblock is offline
Get off my lawn
 
Join Date: Apr 2010
Posts: 1,059
Default Re: I think my ECU reset while driving

As far as I know the color of battery corrosion does not indicate anything at all about the vehicles electrical or charging system except that they had been operating with that extra resistance.
But yeah blue happens too. Light blue or blueish green.
Doesn't matter if you cleaned it and tightened the terminals.
How do the copper cables look? If they're real green under the insulation, maybe think about replacements.
__________________
08 4.0 Sport 4x4
Stock
Reply With Quote
  #18  
Old 09-14-2010, 07:54 PM
ObsoleteE ObsoleteE is offline
I'm an F-18, bro
 
Join Date: Jan 2010
Posts: 1,972
Send a message via AIM to ObsoleteE
Default Re: I think my ECU reset while driving

I'll have to look at them, thanks for the input.

EDIT: why do you think my deck was clicking when the ignition was off?
__________________
1999 B2500 5 Speed
Reply With Quote
  #19  
Old 09-15-2010, 03:57 AM
crowdpleazer crowdpleazer is offline
^thats what they call me^
 
Join Date: Aug 2010
Posts: 417
Default Re: I think my ECU reset while driving

hey you need an optima battery
__________________
1998 ranger extended cab, 2wd, 4.0 ohv, 5 speed, sony xploid 52 4 way watt radio, 2 pair of pioneer 240 watt speakers, Cobra 29 LX LCD CB radio pushing 100 watts, k&n air filter, 15 inch exploder wheels, dual exhaust with 4 inch stainless tips, 2 12 inch subs with a 1000 watt amp just for the hell of it!

new project: dirt track modified racing at the local saturday night track.
Reply With Quote
  #20  
Old 09-15-2010, 11:20 AM
ObsoleteE ObsoleteE is offline
I'm an F-18, bro
 
Join Date: Jan 2010
Posts: 1,972
Send a message via AIM to ObsoleteE
Default Re: I think my ECU reset while driving

Quote:
Originally Posted by crowdpleazer View Post
hey you need an optima battery
rofl
__________________
1999 B2500 5 Speed
Reply With Quote
  #21  
Old 09-15-2010, 03:38 PM
mickblock mickblock is offline
Get off my lawn
 
Join Date: Apr 2010
Posts: 1,059
Default Re: I think my ECU reset while driving

Quote:
Originally Posted by ObsoleteE View Post
why do you think my deck was clicking when the ignition was off?
No clue. But it hasn't been doing it anymore has it?
Maybe some continuous power process was either interrupted or initiated by the faulty battery connection would be my guess. Does your head unit normally allow you to eject a CD without ignition?
__________________
08 4.0 Sport 4x4
Stock
Reply With Quote
  #22  
Old 09-15-2010, 07:13 PM
ObsoleteE ObsoleteE is offline
I'm an F-18, bro
 
Join Date: Jan 2010
Posts: 1,972
Send a message via AIM to ObsoleteE
Default Re: I think my ECU reset while driving

Quote:
Originally Posted by mickblock View Post
No clue. But it hasn't been doing it anymore has it?
Nope

Quote:
Originally Posted by mickblock View Post
Maybe some continuous power process was either interrupted or initiated by the faulty battery connection would be my guess.
Quite possible

Quote:
Originally Posted by mickblock View Post
Does your head unit normally allow you to eject a CD without ignition?
Not sure on that one, I'll give it a try tomorrow.
__________________
1999 B2500 5 Speed
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
EVAP Monitor reset angst... tyler durden General Tech 0 07-16-2010 04:08 PM
help with ecu rangerwheelinmike Electrical Tech 21 05-29-2010 03:39 PM
Need Ecu Help Please calby10 Electrical Tech 0 04-21-2010 04:10 PM
Ecu? ~Fast*Life~ Electrical Tech 2 02-09-2010 01:27 PM
Engine warning light reset?? ian5001 Electrical Tech 1 01-17-2010 08:15 AM