Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-15-2010, 11:01 AM
acleme1 acleme1 is offline
Learning to use the forums
 
Join Date: Jul 2010
Posts: 8
Default P1443 Error and CEL Help

I'm getting a Check Engine Light with a P1443 on my '96 Ranger. I've replaced the vacuum lines from the manifold to the carbon canister, and also replaced the purge flow sensor. I reset the CEL, and away I went. 30 miles later, the CEL cameon again. What else could it be? Could it be the solenoid? Doesn't the solenoid have it's own code? Any help would be appreciated. ac.

Last edited by acleme1; 08-15-2010 at 11:30 AM.
Reply With Quote
  #2  
Old 08-15-2010, 11:04 AM
richarddhoward richarddhoward is offline
Road Trippin' King!
 
Join Date: Nov 2009
Posts: 5,010
Send a message via MSN to richarddhoward
Default Re: P1443 Error and CEL Help

I'm being lazy, whats the description on P1443?
__________________
97 Ranger - 4.0 V6 auto, 4wd, 31x10.5x15s Wild Country XTX Sport All Terrains, Warn locking hubs, Pioneer deck with iPod attachment, Snugtop Topper, K&N filter, scan gauge II, Hella 500 Lights, More parts coming, waiting for the paycheck to get bigger!

Truck built in loving memory of Norm Howard
Outcast Racing
PNW Crew!!!
Afterhours Clan!!
Quote:
Originally Posted by aaron_ariens View Post
I think Henry just shit himself
Quote:
Originally Posted by Radness View Post
Its kind of like that carnival game "Whack A Mole" but with guns! Haha
Reply With Quote
  #3  
Old 08-15-2010, 11:29 AM
acleme1 acleme1 is offline
Learning to use the forums
 
Join Date: Jul 2010
Posts: 8
Default Re: P1443 Error and CEL Help

P1443 is "Evaporative Emission Control System Control Valve"
Reply With Quote
  #4  
Old 08-15-2010, 11:42 AM
richarddhoward richarddhoward is offline
Road Trippin' King!
 
Join Date: Nov 2009
Posts: 5,010
Send a message via MSN to richarddhoward
Default Re: P1443 Error and CEL Help

Next thought, create a sig so I know what all is in your truck.

What engine, tranny, is it 4wd etc. How many miles is helpful too in answering these questions.

Replace all the vacuum lines back there, I just had to do that on my 97, your canister may be plugged too, I know my truck has seen a lot of dirt and sand and they can get clogged up with crap. I'll make a couple calls and see about anything else it might be...I also would check your gas cap, stupid I know.
__________________
97 Ranger - 4.0 V6 auto, 4wd, 31x10.5x15s Wild Country XTX Sport All Terrains, Warn locking hubs, Pioneer deck with iPod attachment, Snugtop Topper, K&N filter, scan gauge II, Hella 500 Lights, More parts coming, waiting for the paycheck to get bigger!

Truck built in loving memory of Norm Howard
Outcast Racing
PNW Crew!!!
Afterhours Clan!!
Quote:
Originally Posted by aaron_ariens View Post
I think Henry just shit himself
Quote:
Originally Posted by Radness View Post
Its kind of like that carnival game "Whack A Mole" but with guns! Haha
Reply With Quote
  #5  
Old 09-22-2010, 04:27 PM
snackdog snackdog is offline
Liking the Ford Ranger Forum
 
Join Date: Sep 2010
Posts: 17
Default Re: P1443 Error and CEL Help

I have the same problem -- where is the Canister Purge Solenoid/Flow Sensor so I can see how the hoses look? A photo or diagram would be especially helpful. I have a 96 Ranger with a 4L V6.
__________________
Mike
1996 Ford Ranger 4x4 XLT
186k miles
Reply With Quote
  #6  
Old 09-22-2010, 05:54 PM
richarddhoward richarddhoward is offline
Road Trippin' King!
 
Join Date: Nov 2009
Posts: 5,010
Send a message via MSN to richarddhoward
Default Re: P1443 Error and CEL Help

Quote:
Originally Posted by snackdog View Post
I have the same problem -- where is the Canister Purge Solenoid/Flow Sensor so I can see how the hoses look? A photo or diagram would be especially helpful. I have a 96 Ranger with a 4L V6.
Under the bed, they can be a pain to look at that way, at least if you are a bigger person
__________________
97 Ranger - 4.0 V6 auto, 4wd, 31x10.5x15s Wild Country XTX Sport All Terrains, Warn locking hubs, Pioneer deck with iPod attachment, Snugtop Topper, K&N filter, scan gauge II, Hella 500 Lights, More parts coming, waiting for the paycheck to get bigger!

Truck built in loving memory of Norm Howard
Outcast Racing
PNW Crew!!!
Afterhours Clan!!
Quote:
Originally Posted by aaron_ariens View Post
I think Henry just shit himself
Quote:
Originally Posted by Radness View Post
Its kind of like that carnival game "Whack A Mole" but with guns! Haha
Reply With Quote
  #7  
Old 09-23-2010, 04:20 AM
snackdog snackdog is offline
Liking the Ford Ranger Forum
 
Join Date: Sep 2010
Posts: 17
Default Re: P1443 Error and CEL Help

I found the canister and the purge flow sensor near the battery.
__________________
Mike
1996 Ford Ranger 4x4 XLT
186k miles
Reply With Quote
  #8  
Old 05-15-2012, 08:12 PM
RangerDanger27 RangerDanger27 is offline
Ford Tough
 
Join Date: Mar 2012
Posts: 283
Default

Quote:
Originally Posted by richarddhoward
Next thought, create a sig so I know what all is in your truck.

What engine, tranny, is it 4wd etc. How many miles is helpful too in answering these questions.

Replace all the vacuum lines back there, I just had to do that on my 97, your canister may be plugged too, I know my truck has seen a lot of dirt and sand and they can get clogged up with crap. I'll make a couple calls and see about anything else it might be...I also would check your gas cap, stupid I know.
Gas cap really I have the same problem on my truck...had to buy a new gas cap to get it to pass smog...tech told me it was bad aftermarket thread....left smog place and light came on again. Pulled code and there it was P1443.

97 Ford Ranger 2.3L 4cyl
Reply With Quote
  #9  
Old 10-21-2012, 03:05 PM
snackdog snackdog is offline
Liking the Ford Ranger Forum
 
Join Date: Sep 2010
Posts: 17
Default

I ended up having the EGR valve replaced. My truck runs much better now.
__________________
Mike
1996 Ford Ranger 4x4 XLT
186k miles
Reply With Quote
  #10  
Old 10-21-2012, 06:30 PM
DannMarr DannMarr is offline
Not as smart as I think
 
Join Date: Nov 2009
Posts: 258
Default Re: P1443 Error and CEL Help

Your purge control valve (not the sensor) is stuck open.
__________________
2001 Ford Ranger with the flare sides. 4x4 with a 4.0 engine. The only thing I did so far is: F/R Brakes, rotors, drums, F/R shocks, tires, bed cap, cone filter, hanger/shackles, F/P wheel bearing, upper control arm, lower ball joint, filler neck, fuel filter and DPFE sensor, muffler, sway bar links and spark plugs!
Reply With Quote
  #11  
Old 11-18-2012, 05:43 PM
96ranger30 96ranger30 is offline
Ford Ranger Owner
 
Join Date: Jul 2010
Posts: 61
Default Re: P1443 Error and CEL Help

i just got this code on my truck, is it possible to jus take the purge valve off and clean it with some carb cleaner? And is it okay to drive with this code for a little while?
__________________
1996 3.0- spectre drop-in filter, 3" exhaust w/ 2nd cat delete & flowmaster 40 SI/DO,3.73's
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ejection error Jilllyy Audio / Video 6 06-01-2010 09:51 AM
6 disc changer error message E-7 trucker101 Audio / Video 0 05-24-2010 07:19 PM
OBDII Error Code... ufgators68 4.0 SOHC / 4.0 OHV Tech 0 04-20-2010 01:33 PM
CEL keeps coming on 1freaky1 4.0 SOHC / 4.0 OHV Tech 26 03-08-2010 10:29 AM
error codes lildevjkoch1977 4-Cylinder Tech 1 02-04-2010 07:32 AM