Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-13-2010, 05:34 PM
heisgr8er heisgr8er is offline
Learning to use the forums
 
Join Date: Aug 2010
Posts: 2
Angry Horrible Acceleration

Hi I have a 2000 Ford Ranger 3.0 V6 Flex fuel. I have replaced the engine, the catalytic converter, spark plugs, wires, fuel filter, air filter, idle air controller, and I STILL have a problem with my truck taking forever to be able to accelerate. It seems to act right until I get up to about 40 miles an hour, and then it takes a long time to get up to 55-60. Getting to 70-75 is almost impossible. I have taken it in to 3 mechanics and no one seems to be able to figure out the cause.
Reply With Quote
  #2  
Old 08-13-2010, 06:59 PM
mickblock mickblock is offline
Get off my lawn
 
Join Date: Apr 2010
Posts: 1,059
Default Re: Horrible Acceleration

Just answered a post about a 2000 3.0 flex fuel.
He had a code P0176 though.

So is your engine light on and do you have codes for us?

Although there isn't much left is there?
__________________
08 4.0 Sport 4x4
Stock

Last edited by mickblock; 08-13-2010 at 07:02 PM.
Reply With Quote
  #3  
Old 08-14-2010, 08:52 AM
mazdaman mazdaman is offline
mazda owner since 1989
 
Join Date: Mar 2010
Posts: 493
Send a message via Skype™ to mazdaman
Default Re: Horrible Acceleration

You may have a stretched throttle cable , my 96 had poor acceleration , turned out the throttle cable was stretched a 1/2 an inch
__________________
2003 Ranger totally stock for now ,mods coming soon .
SOLD 1996 Mazda B3000
Reply With Quote
  #4  
Old 08-15-2010, 10:46 AM
heisgr8er heisgr8er is offline
Learning to use the forums
 
Join Date: Aug 2010
Posts: 2
Default Re: Horrible Acceleration

I havent had any codes, and my check engine light has not come on. The last mechanic I had could tell the power loss, but could not find it. Is it possible it is the torque converter?

I will check on the throttle cable and see if that could be it too.

Thanks for the help so far...
Reply With Quote
  #5  
Old 08-15-2010, 04:37 PM
mickblock mickblock is offline
Get off my lawn
 
Join Date: Apr 2010
Posts: 1,059
Default Re: Horrible Acceleration

You gonna be ok if it turns out to be your throttle cable?
'Cause I'd be really pissed.
__________________
08 4.0 Sport 4x4
Stock
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Horrible gas mileage, I mean horrible..... Millerman General Tech 60 08-13-2010 07:32 PM
New exhaust. It looks horrible. Help!!! rusty13 Exhaust and Mufflers 24 08-10-2010 08:24 AM
4.0, A/C, Acceleration, and Noise joldtown General Tech 5 07-15-2010 12:14 PM
Ticking under acceleration 2002-FX4 4.0 SOHC / 4.0 OHV Tech 6 04-01-2010 08:25 PM
XLT hesitates on acceleration Tamarack Drivetrain Tech 0 02-02-2010 07:54 AM