Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 10-14-2020, 04:26 PM
cobrajocky cobrajocky is offline
Learning to use the forums
 
Join Date: Jul 2010
Posts: 11
Exclamation More troubles - suddenly B4000/V6 won't fire up after running day before!

You know, I could write a Country song about this damn truck! "If I didn't Have Bad Luck, I wouldn't have this Damn 97 Mazda B4000!"

I think it's possessed, the ODO say's 99,999.4 miles. (23 years old going on 100 in it's crankiness.)

After driving around stop and go errands all Monday, starting right up each time, running fine, plenty a 4Litre V6 power, this damn truck won't fire up Tuesday or today (Wednesday)! Not a momentary, not a cough, not a thing except the starter more than sufficiently spinning over the motor.

Pumping the gas pedal I can smell some gas fumes. All the dash advisory lights are on while cranking it.

This has happened before for a few minutes and then a backfire and some rough initial running, but that's been some time ago (months). It's been pretty hot mid 90's here on the Worst Coast the last few days. The beast is parked in my driveway nose down hill on a maybe 6 degree slopped short driveway. So Gravity should be helping get gas from the tank to the front.

I popped the gas cap, no vacuum whoosh.

In the last 12 months I put in a complete new AC system, a new Evap System and a new Alternator. What the hell else does this truck want from me??!!

Anyways, I'm at a loss what and where to check, diagnose first, second or third. Any sincere help would be greatly appreciated.

Thanks
Reply With Quote
  #2  
Old 10-14-2020, 04:43 PM
tomboy tomboy is offline
Ford Ranger Driver
 
Join Date: Nov 2011
Posts: 1,876
Default Re: More troubles - suddenly B4000/V6 won't fire up after running day before!

Can you hear the fuel pump run when you turn the switch on, check the shut off switch under the right kick panel, if the pump does run, check the presure at the fuel rail.
Reply With Quote
  #3  
Old 10-14-2020, 08:39 PM
cobrajocky cobrajocky is offline
Learning to use the forums
 
Join Date: Jul 2010
Posts: 11
Default Re: More troubles - suddenly B4000/V6 won't fire up after running day before!

Quote:
Originally Posted by tomboy View Post
Can you hear the fuel pump run when you turn the switch on, check the shut off switch under the right kick panel, if the pump does run, check the pressure at the fuel rail.
The one thing I've never dealt with on these Ranger/Mazda B V6 Series is the fuel pump. I can't say I have ever heard the fuel pump, even when the truck was new. - Where is it and what should I hear? I'm assuming it's an electric pump?

As I said in the OP, I can smell gas when I pump the pedal while trying to start the engine.

I don't have a fuel line pressure gauge.

One more thing, I sprayed Carb Cleaner into the opened throttle body air duct at the front of the truck one of the times I tried to start it and nothing, not even a cough from the engine. Shouldn't this more likely indicate something electrical? (Computer module, main coil - if it has one, something else disabling spark?)

thanks
Reply With Quote
  #4  
Old 10-17-2020, 07:11 PM
cobrajocky cobrajocky is offline
Learning to use the forums
 
Join Date: Jul 2010
Posts: 11
Default Re: More troubles - suddenly B4000/V6 won't fire up after running day before!

(bump bump)

Can Anyone Else HELP, offer testing / solutions based on my feedback above???

I don't have a Fuel Live pressure tester, as I said I do smell fuel when pumping the gas pedal.

Any thoughts on it being an Electrical Issue??

Help please!
Reply With Quote
Reply

Tags
mazda b4000, no starting

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C Quit Suddenly DeplorableInfadel77 General Tech 2 09-07-2019 01:08 PM
Suddenly running rough netminda 3.0 Vulcan Tech 5 10-17-2013 08:09 PM
Very suddenly refuses to stay running. doublepedaldylan 4.0 SOHC / 4.0 OHV Tech 0 09-26-2013 05:47 AM
Suddenly running rough after timing belt replace skratch 4-Cylinder Tech 3 05-21-2013 08:09 PM