Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-16-2010, 04:08 PM
tyler durden tyler durden is offline
Learning to use the forums
 
Join Date: Dec 2009
Posts: 9
Default EVAP Monitor reset angst...

Hi everyone,

Anyone have trouble resetting their EVAP monitor back to "readiness" mode....for emissions testing?

Been doing repeated drive cycles as per Ford recomendations, but my EVAP monitor remains "not ready".

My truck (2.3L) has never shown a MIL/CEL. No fault codes have ever been stored or pending. I've always passed Colorado emisiions test in the past. My truck has never been "worked on" by anyone but me (plugs, belts, pads, etc).

I have no actual emissions issues, but Illinois Air Team has rejected me twice due to my EVAP monitor not being in ready mode.

I get one more "free" test, if rejected again I'll be forced (by law) to spend big bucks at an authorised emissions repair joint.

Color me baffled. And pissed.

TIA
__________________
2.3 liter powerhouse, 0 to 60 in under 5 minutes!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
EVAP large leak coop10 3.0 Vulcan Tech 3 12-04-2013 11:47 AM
New Monitor... RangerJustin Music/Movies/Computers/etc. 5 01-26-2010 01:30 PM
Engine warning light reset?? ian5001 Electrical Tech 1 01-17-2010 08:15 AM
multiswitch replacement; Reset airbag light possible? hrulive Electrical Tech 2 11-19-2009 02:44 PM
My new monitor and the system tell me what ya think MasturJC Vehicle Snapshots 12 08-25-2009 07:45 AM