Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 04-11-2018, 08:07 PM
TtocsPuohs TtocsPuohs is offline
Learning to use the forums
 
Join Date: Apr 2018
Posts: 2
Default Pulled bed to change fuel pump and missing piece of rubber.

My truck been running lean for a year or more now. Starts strong, then sputters and dies after 15 seconds. Smells like burnt hair. I have changed the fuel filter, best I can tell it is the pump so I removed the bed and found this. Not sure what part the rubber hose is supposed to attach to, nothing else is found.
Attached Images
File Type: jpg 20180411_185304.jpg (20.5 KB, 39 views)
__________________
1998 Ford Ranger Xlt 6 cyclinder 3.0 liter rwd, Many years as work truck. Replaced tons of stuff over the years. Trying to revive so I can drive it again.
Reply With Quote
  #2  
Old 04-12-2018, 06:09 PM
Tfownes Tfownes is offline
Ford Motor Company
 
Join Date: Oct 2015
Posts: 149
Default Re: Pulled bed to change fuel pump and missing piece of rubber.



goes to a charcoal canister/ filter
__________________
1987 ranger, 302, T5, djm 3-4" lowering kit, 8.8 t-lock, 12" front brakes, cobra rear brakes
Reply With Quote
  #3  
Old 04-12-2018, 06:57 PM
TtocsPuohs TtocsPuohs is offline
Learning to use the forums
 
Join Date: Apr 2018
Posts: 2
Default Re: Pulled bed to change fuel pump and missing piece of rubber.

Yes, that is it. Thank you, Any idea if that would be the cause of the truck sputtering out and dying when started? I assumed it was the fuel pump, 2 codes showed up for lean fuel. Maybe too much 02 is getting into the system due to this broken line?
__________________
1998 Ford Ranger Xlt 6 cyclinder 3.0 liter rwd, Many years as work truck. Replaced tons of stuff over the years. Trying to revive so I can drive it again.
Reply With Quote
  #4  
Old 04-17-2018, 06:07 AM
LargeR LargeR is offline
Arizona 2wd Ranger
 
Join Date: Nov 2012
Posts: 167
Default Re: Pulled bed to change fuel pump and missing piece of rubber.

Lean means too much air and not enough fuel measured by the upstream o2 sensors. This could mean you have unmetered air (vacuum leak) or insufficient fuel volume typically caused by low pressure). Check fuel pressure and look for leaks in the airflow path past the mass airflow sensor.

Sent from my SAMSUNG-SM-G930A using Tapatalk
__________________
Rick Large
Mesa AZ
'99 Ex-Ranger 2wd XLT 5.0, Explorer V8 and auto transmission swap, floor shifter from Nissan Altima Parts, aluminum radiator & electric fan, OBX headers, 3" custom exhaust, explorer roof rack, 2006 mirrors, cut front 60/40 seat to buckets, 4 in lift spindles up front and shackles in back
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Releasing fuel system pressure before fuel pump change? dillong How-To Submissions 4 07-30-2014 07:49 AM
Identify a missing piece DimePaul Exterior Tech 5 01-16-2014 11:22 PM
$1000 for Ford to change my fuel pump. Seriously? kman101 General Tech 21 12-14-2013 08:03 AM
name the missing piece... please 94bseries Interior Tech 10 11-25-2012 10:55 PM
What's the best way to change out my fuel pump? 1997 4.0 v6 Broke Guy 4.0 SOHC / 4.0 OHV Tech 5 11-22-2012 02:51 PM