Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-07-2017, 05:55 PM
LionsFan LionsFan is offline
NOOB
 
Join Date: Nov 2017
Posts: 2
Exclamation Coolant temperature sending unit - coolant temperature sensor

There are 2 connectors on my 97 2wd 2.3 4cyl
1 is right on the thermostat housing the other is right in the coolant line a few inches away. Are they the same part serving different purposes or are they 2 different parts altogether? My ranger doesn't reach normal operating temperature. I have flushed the coolant system at the oil change place and back flushed the heater core at home. I have also replaced the thermostat, viscous clutch, and water pump. I have heat in the cab. Wondering what else could be going on. Any thoughts and ideas are welcome.

Charlie
__________________
1997 Ranger
2wd 2.3L 4Cyl
5 speed manual
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 2.3 temperature sending unit amaisonet 4-Cylinder Tech 11 05-09-2015 11:48 AM
Coolant temperature sensor/switch.. itsmyyname 3.0 Vulcan Tech 3 08-06-2014 02:12 PM
Coolant leak at temperature sensor bodkin1 4.0 SOHC / 4.0 OHV Tech 6 07-21-2013 04:57 PM
2.3 temperature sending unit help please Vermicryx 4-Cylinder Tech 6 02-27-2012 08:02 AM
Temperature sending unit motherb6 Electrical Tech 1 12-18-2011 06:57 PM