Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-25-2010, 02:46 PM
MFDTRK1 MFDTRK1 is offline
Learning to use the forums
 
Join Date: Jan 2010
Posts: 13
Angry Yet another AC problem

I have a 99 Ranger and my AC pump (on max) clickes on and off with no cold air comming out. I replaced the relay but to no avail. Could it be the switch in the accumulater? The pump should stay engaged on max right? Let me know your thoughts! Thanks!

P.S. With a gauge on the line when the pump clicks in pressure goes up to "charged" then when it clicks off the gauge drops!
Reply With Quote
  #2  
Old 05-25-2010, 03:00 PM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default Re: Yet another AC problem

The compressor clutch can cycle on and off in MAX A/C. The cycling is pressure dependent and frequent cycling along with poor cooling usually means that the refrigerant charge is low.
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
  #3  
Old 05-25-2010, 03:03 PM
MFDTRK1 MFDTRK1 is offline
Learning to use the forums
 
Join Date: Jan 2010
Posts: 13
Default Re: Yet another AC problem

Well, I tried to charge it but it wouldn't take it. The clutch clicks on and off in short burst. Not normal.
__________________
1999 Ranger XL 4x4. extra cab, with 105k miles and runs OK so far!
Reply With Quote
  #4  
Old 05-25-2010, 03:05 PM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default Re: Yet another AC problem

"The clutch clicks on and off in short bursts" usually means that the charge is low.
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
  #5  
Old 05-25-2010, 03:06 PM
MFDTRK1 MFDTRK1 is offline
Learning to use the forums
 
Join Date: Jan 2010
Posts: 13
Default Re: Yet another AC problem

Hummm. I'll try again to add refrigerant.
__________________
1999 Ranger XL 4x4. extra cab, with 105k miles and runs OK so far!
Reply With Quote
  #6  
Old 05-25-2010, 03:12 PM
MFDTRK1 MFDTRK1 is offline
Learning to use the forums
 
Join Date: Jan 2010
Posts: 13
Default Re: Yet another AC problem

Could it be possible that the can I have lost its pressure? Also, Is it possible to over fill it? The gauge on the can shoots past fill to almost over fill when it (compressor) kicks on.
__________________
1999 Ranger XL 4x4. extra cab, with 105k miles and runs OK so far!
Reply With Quote
  #7  
Old 05-25-2010, 03:37 PM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default Re: Yet another AC problem

Quote:
Originally Posted by MFDTRK1 View Post
The gauge on the can shoots past fill to almost over fill when it (compressor) kicks on.
The charge is introduced to the low pressure side of the system, not the high pressure side. It sounds like you may be trying to charge the high pressure side which could be very dangerous.

Of course, a discharged system indicates a leak somewhere. If the system is recharged before correcting the cause of the discharge, it will need to charged again before long.

If the system has ever been completely discharged, a vacuum pump should be used before charging to evacuate the air and water vapor before introducing the refrigerant. Skipping this step causes an incomplete charge and lowered efficiency.
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem need help silverfoxvtx General Ford Ranger Discussion 1 02-18-2010 09:48 PM
problem duane321 Lifted Suspension 5 02-16-2010 10:56 PM
4 by problem mikertldg Electrical Tech 0 01-26-2010 09:33 PM
Problem? cody_ranger General Tech 2 08-02-2009 11:25 AM
A/C Problem. Mike Electrical Tech 1 07-30-2009 06:52 AM