Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 06-22-2009, 12:18 AM
littleblue littleblue is offline
Semper Paratus
Join Date: May 2009
Posts: 274
Default 3.0 engine chirping sound

Originally Posted by bluerangerftlaud View Post
yup 54 bucks, I guess I get what I pay for. I disconnected the battery and reset my codes and the light hasnt come back on...............yet
As I said in an earlier reply I got mine at Napa because it was recommended on other sites to be better than the Autozone units. I had the same problem as you. It would throw a cel after driving on the freeway for at least 8-10 miles. I do a lot of back road driving, 40-50mph, so I wouldn't get the cel until after driving on the freeway which was every three or four weeks. Really frustrating. It wasn't until I replaced it with the Ford unit that it stopped. Apparently poor production tolerances that caused problems at sustained 65-70 mph speeds.
'00 XLT 3.0 Exted cab
Mods: Roush hood & cai, ASP pwr pulley, hot wtr bypass, 180 therm, e-fan, Gibson exh., 4.10 l/s, FabTech lift, kyb's, bii sway bar. 31x10.50 Yokahama ATs, Panther rims, light bar, SS grille, 03 stang buckets, explorer console, hurst shifter
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
1989 2.3L engine HPvs 2004 2.3L engine HP? Kitsap 4-Cylinder Tech 4 12-02-2009 01:25 PM
Looking to up grade sound in Ford Ranger? buck_master007 Audio / Video 8 11-07-2009 06:06 PM
1999 Ford Ranger's belt is chirping.? Matt General Ford Ranger Discussion 2 12-08-2008 06:40 PM
Disturbing Sound in Ford Ranger Clutch? Dingo444 Drivetrain Tech 1 12-06-2008 07:04 PM