Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 04-05-2014, 04:26 PM
ThaHickChick ThaHickChick is offline
Found Off Road Diggin'.
 
Join Date: Dec 2011
Posts: 44
Default Squealing noise at 3000 RPMS

I apologize if I am posting in the wrong section, but I am stumped!
I recently replaced my cam shaft sensor, and shortly after, my truck started making a high pitched, ear piercing squealing noise at 3000-3500 RPMS. It does not make the noise at any other time.
It also only makes this noise while driving, not while idling.
The noise goes away once it downshifts.
I have showed the noise to a few mechanics and they all say they have never heard anything like it.
I have heard a few theories that it could be:
Power Steering pump,
Cam Shaft Sensor,
or pulleys or the belt..
I checked the belt and pulleys and don't see anything wrong,
I tried spraying them and the noise does not go away.

The only noticable thing that I could find with an issue on my pickup is that the top piece on the intake plenum is separated because the bolts are stripped, and it may be sucking in air at a certain speed?

Hoping to hear if anyone else has had this issue!
Let me know your ideas.

Thanks y'all!
Reply With Quote
  #2  
Old 04-05-2014, 09:35 PM
youbastard88 youbastard88 is offline
Ford Tough
 
Join Date: Aug 2013
Posts: 336
Default

If your plenom was sucking in air it'd run rough, since it has the maf sensor, any air leaks past that would throw the computer off. Be easy on her more than likely its a pulley. So if you rev it to 3-3500 in park it doesn't do it or it does?
Reply With Quote
  #3  
Old 04-05-2014, 10:41 PM
finho1m finho1m is offline
Ford Pickup
 
Join Date: Feb 2014
Posts: 111
Default

I have the same problem!! It sounds like a blown bearing or something in my opinion but i cant figure it out for the life of me.. Ill be watching this thread closely!
Reply With Quote
  #4  
Old 04-06-2014, 08:10 AM
youbastard88 youbastard88 is offline
Ford Tough
 
Join Date: Aug 2013
Posts: 336
Default

Quote:
Originally Posted by finho1m View Post
I have the same problem!! It sounds like a blown bearing or something in my opinion but i cant figure it out for the life of me.. Ill be watching this thread closely!
Id check all your pulleys. See if any of em got play to em
Reply With Quote
  #5  
Old 04-06-2014, 09:35 AM
dvrich dvrich is offline
Lifetime DAV Member
 
Join Date: Sep 2010
Posts: 2,404
Default Re: Squealing noise at 3000 RPMS

Remove the fan belt and see if the noise goes away.
__________________
2014 Ford F150 4x4 Supercab 5.0 STX 9500 miles 18 mpg overall
2015 Ford F150 4x2 Supercab 3.5 TIVCT 13,500 miles 21 mpg overall
Reply With Quote
  #6  
Old 04-06-2014, 10:20 AM
youbastard88 youbastard88 is offline
Ford Tough
 
Join Date: Aug 2013
Posts: 336
Default

Quote:
Originally Posted by dvrich View Post
Remove the fan belt and see if the noise goes away.
Yep, best way about it. Could be any of the pulleys, if it goes away wiggle them and see which one has play in it. Or spin em and see which one is too free or spins rough
Reply With Quote
  #7  
Old 06-12-2014, 02:19 PM
ThaHickChick ThaHickChick is offline
Found Off Road Diggin'.
 
Join Date: Dec 2011
Posts: 44
Default Re: Squealing noise at 3000 RPMS

Quote:
Originally Posted by youbastard88 View Post
If your plenom was sucking in air it'd run rough, since it has the maf sensor, any air leaks past that would throw the computer off. Be easy on her more than likely its a pulley. So if you rev it to 3-3500 in park it doesn't do it or it does?
This noise does not occur during idle. Only while the truck is going down the road.
It seemingly disappeared for a while and is now extremely bad again.
I checked the entire belt system and did not find any issues.
I did find that one of the bearings in my alternator seems to be going out (which is crap because I just replaced it less than a year ago).
But that is the only issue issue that was apparent..

----------

Quote:
Originally Posted by finho1m View Post
I have the same problem!! It sounds like a blown bearing or something in my opinion but i cant figure it out for the life of me.. Ill be watching this thread closely!
Did you ever find the issue?!
Reply With Quote
Reply

Tags
noise, rpms, squealing

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Squealing Noise Vikhab09 Wheels and Tires 2 10-19-2013 05:56 AM
Squealing noise! LaOffroad90 Drivetrain Tech 3 02-24-2012 08:38 PM
Hear a leak when rpms get over 3000 kahlmant Drivetrain Tech 0 12-27-2010 05:33 PM
squealing noise ryangtp89 4.0 SOHC / 4.0 OHV Tech 5 11-11-2010 05:16 AM
squealing at higher rpms jus97tin Drivetrain Tech 2 07-12-2010 04:59 AM