Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 04-08-2010, 10:16 AM
FordMan8109 FordMan8109 is offline
Learning to use the forums
Join Date: Jan 2010
Posts: 13
Default 03 ranger

Ive been having issues with my 03 Ranger 2.3, im only getting like 250 miles out of a full tank of gas which is terrible cause when i first got the truck it was getting close to 400 out of a full tank. Ive changed the plugs, wires, pcv valve, and the fuel filter and im running out of things that i think it could be. Anyone have any suggestions on what else i can check?
Reply With Quote
Old 04-08-2010, 10:32 AM
Pbav8tor Pbav8tor is offline
Flyin High

Join Date: Jan 2010
Posts: 1,859
Default Re: 03 ranger

I'm sure that you changed the air filter but just checking.
60/40 Seat Mod, Expo Full Console, Expo Mod Diff Cover, Thunderbolt Signal Mirrors, Flowmaster, Billet Grills, One Piece Halo Projector Headlights, HID Fogs w/Halos,
LED Lightbar, Euro Taillights, Interior Accents Painted, OHC, Indigo Cluster, 7" LCD Headunit, Mustang Dome Light, Manik Brush Guard
Reply With Quote
Old 04-09-2010, 06:06 AM
sgtsandman sgtsandman is offline
Tank Diver
Join Date: Mar 2010
Posts: 3,078
Default Re: 03 ranger

Air filter maybe? When was the last time some fuel system cleaner was used? Try those first. If you are still having problems, try cleaning the mass air flow sensor and/or the intake air controler valve.
Sgtsandman's Work in Progress
2011 Ranger XLT, 4X4, 4 door Super Cab. 4.0L, 5 Speed M50D-R1HD, 3.73:1, 8.8" open differential, Jason Pace cap
1999 Honda CR-V EX, RT4WD, 2.0L, 5 Speed MT, 4.56:1, open differential
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search