Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 12-03-2013, 04:20 PM
ColtonSchmidt ColtonSchmidt is offline
Learning to use the forums
 
Join Date: Nov 2013
Posts: 5
Default Failed Smog - NO

I failed smog yesterday for NO at 15 mph. The smog guy said it could possibly be my thermostat because my temp gauge isn't working properly. My cel isn't on, I had just replaced my O2 sensor.

My readings @ 15 mph were: rpm 2445, %CO2 14.6, %O2 0.1, HC(ppm)16, CO% 0.02, NO(ppm) 580.

The readings for 25 mph were: rpm 2392, %CO2 14.6, %O2 0.1, HC(ppm)15, CO% 0.03, NO(ppm) 473.

I've look around online and from what i've read it could be this, but also says there could be a problem with the egr. I also have a cold air intake and don't know if it pulling to much air. Maybe a vacuum leak? Any ideas?
__________________
1999 Ranger 3.0 V6 2wd
Reply With Quote
  #2  
Old 12-03-2013, 04:23 PM
96_4x4_XLT 96_4x4_XLT is offline
Ford Ranger Driver
 
Join Date: Mar 2013
Posts: 6,189
Default

Quote:
Originally Posted by ColtonSchmidt View Post
I failed smog yesterday for NO at 15 mph. The smog guy said it could possibly be my thermostat because my temp gauge isn't working properly. My cel isn't on, I had just replaced my O2 sensor. My readings @ 15 mph were: rpm 2445, %CO2 14.6, %O2 0.1, HC(ppm)16, CO% 0.02, NO(ppm) 580. The readings for 25 mph were: rpm 2392, %CO2 14.6, %O2 0.1, HC(ppm)15, CO% 0.03, NO(ppm) 473. I've look around online and from what i've read it could be this, but also says there could be a problem with the egr. I also have a cold air intake and don't know if it pulling to much air. Maybe a vacuum leak? Any ideas?
first off it's not your coolant lol
second off go see if you have any stored codes the computer might have

----------

Quote:
Originally Posted by 96_4x4_XLT View Post
first off it's not your coolant lol second off go see if you have any stored codes the computer might have
also try ice o heet
I've heard of people failing smog and using that and then passing
__________________
95 Ranger XLT 4x2 2.3 I4 5 speed 206,000 *dead*
96 Ranger XLT 4x4 4.0 V6 5 speed 173,000 *alive*
D35 front, 8.8 rear, 3.73 gears, limited slip rear diff
Reply With Quote
  #3  
Old 12-03-2013, 07:23 PM
ColtonSchmidt ColtonSchmidt is offline
Learning to use the forums
 
Join Date: Nov 2013
Posts: 5
Default Re: Failed Smog - NO

Quote:
Originally Posted by 96_4x4_XLT View Post
first off it's not your coolant lol
second off go see if you have any stored codes the computer might have

----------



also try ice o heet
I've heard of people failing smog and using that and then passing

I checked and no codes stored, ill look into ice o heet. im thinking its a vacuum leak somewhere. im still going to replace the thermostat and check the hoses for leaks.
__________________
1999 Ranger 3.0 V6 2wd
Reply With Quote
  #4  
Old 12-03-2013, 07:56 PM
StockBlueFord StockBlueFord is offline
Mr. MPG
 
Join Date: Feb 2012
Posts: 748
Default Re: Failed Smog - NO

Quote:
Originally Posted by ColtonSchmidt View Post
I checked and no codes stored, ill look into ice o heet. im thinking its a vacuum leak somewhere. im still going to replace the thermostat and check the hoses for leaks.
x2 on vac leak.

although if it a leak, it must be freakin tiny to not set a code. i'd lean more toward the EGR or a biased o2 sensor.
__________________
2011 Ranger XL Extended cab, 2x4, 2.3 L Duratec, Automatic, Mis-colored Leer camper shell, Ultragauge, LED plate bulbs, DDM "cree" reverse lights. Staying as stock as possible
Quote:
Originally Posted by robertmcclure View Post
and yeah, you wanna spend dat moneh on dat pusseh!
Reply With Quote
  #5  
Old 12-27-2013, 06:10 PM
ColtonSchmidt ColtonSchmidt is offline
Learning to use the forums
 
Join Date: Nov 2013
Posts: 5
Default Re: Failed Smog - NO

Does anyone know where the EGR gets its readings from? what tells the valve to open and close? is its temperature reading from the same source as the temp gauge in the dashboard?
__________________
1999 Ranger 3.0 V6 2wd
Reply With Quote
  #6  
Old 12-27-2013, 10:56 PM
cowboybilly9mile cowboybilly9mile is offline
Ford Ranger Driver
 
Join Date: Mar 2010
Posts: 4,897
Default Re: Failed Smog - NO

ECM will manage opening/closing of the EGR valve. Whoever told you to look at the EGR system for problems gave you good advice, that's exactly where I'd have gone looking first. Make sure your EGR valve is able to open by applying vaccum to it and either seeing if you can feel rod movement on the valve itself or with(if) the engine running, see if it dies. Is there any indication that this vehicle is running hot or are you idling in line while you wait?
__________________
2004 Ranger FX4 Level II, 5R55E, Sonic Blue Pearl

Proudly JAP/RICE free since March 2000
Reply With Quote
  #7  
Old 12-30-2013, 08:45 PM
ColtonSchmidt ColtonSchmidt is offline
Learning to use the forums
 
Join Date: Nov 2013
Posts: 5
Default Re: Failed Smog - NO

egr valve works ive tested it with a vacuum and also cleaned it. i also replaced the egr solenoid, but that didnt change anything. my guess is that what ever is sending the signal to the egr isnt working properly. I have a lower NOx reading at higher mph. ive read it might be a faulty O2 sensor? My temp gauge also dosent work properly, it says im running colder than i should be, im going to repace the theromostat, temp sensor, and temp sending unit next. I think (but dont know) that the egr is getting signals that my engine is running colder than it actually is, so its not opening the valve as much as it should.

----------

Quote:
Originally Posted by cowboybilly9mile View Post
ECM will manage opening/closing of the EGR valve. Whoever told you to look at the EGR system for problems gave you good advice, that's exactly where I'd have gone looking first. Make sure your EGR valve is able to open by applying vaccum to it and either seeing if you can feel rod movement on the valve itself or with(if) the engine running, see if it dies. Is there any indication that this vehicle is running hot or are you idling in line while you wait?
What is the ECM?
__________________
1999 Ranger 3.0 V6 2wd
Reply With Quote
  #8  
Old 12-31-2013, 08:07 PM
cowboybilly9mile cowboybilly9mile is offline
Ford Ranger Driver
 
Join Date: Mar 2010
Posts: 4,897
Default Re: Failed Smog - NO

Engine Control Module, another acronym for the 'puter and usually for ones that can't be flashed.
__________________
2004 Ranger FX4 Level II, 5R55E, Sonic Blue Pearl

Proudly JAP/RICE free since March 2000
Reply With Quote
Reply

Tags
3.0, egr, nox, smog, thermostat

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
ca smog need help 89RangerXLT2.9 2.9 Liter Tech 4 10-26-2013 01:31 PM
Failed smog test Tim101 Exhaust and Mufflers 10 06-24-2012 12:09 AM
Failed Smog - No Vacuum pressure to EGR - Code 334 pad2383 4-Cylinder Tech 0 07-27-2011 10:47 AM
smog? POPTART972 4.0 SOHC / 4.0 OHV Tech 0 11-08-2010 02:16 PM
failed smog gas tank pressurizing smog budwieser1 General Tech 1 07-16-2009 06:19 PM